Проблема с зависимостями в R11?

Ответить
geof
Сообщения: 4
Зарегистрирован: 18 апр 2017, 10:29
Operating system: ROSA 16.1

Проблема с зависимостями в R11?

Сообщение geof » 24 июл 2019, 09:04

Доброго дня.

В метапакете task-plasma5 какая-то незадача с зависимостями. Не ставится kate из-за нарушения зависимостей. Его можно позже доставить ручками, но если после этого сказать:

Код: Выделить всё

# urpme --auto-orphan
то снесётся почти вся плазма.

Что-то тут не так :)

Аватара пользователя
VictorR2007
Сообщения: 6056
Зарегистрирован: 12 сен 2011, 13:00
Operating system: ROSA 2016.1
Откуда: Северодвинск

Проблема с зависимостями в R11?

Сообщение VictorR2007 » 24 июл 2019, 10:07

geof писал(а):
24 июл 2019, 09:04
Что-то тут не так
Дело в том, что при установке пакета kate удаляется пакет task-plasma5.
И поэтому удаляется вся плазма.
Нужно читать сообщение при установке kate.
Вы ведь устанавливаете приложение от KDE4 на окружение plasma5.
Для plasma5 устанавливайте пакет plasma5-kate.

geof
Сообщения: 4
Зарегистрирован: 18 апр 2017, 10:29
Operating system: ROSA 16.1

Проблема с зависимостями в R11?

Сообщение geof » 24 июл 2019, 10:58

Код: Выделить всё

~ $ sudo urpmi kate
Следующие пакеты будут удалены для обновления остальных:
plasma5-konsole-18.12.1-1-rosa2016.1.x86_64
 (из-за конфликтов с konsole)
task-plasma5-5.11-1-rosa2016.1.noarch
 (из-за отсутствия task-plasma5-minimal)
task-plasma5-minimal-5.11-1-rosa2016.1.noarch
 (из-за отсутствия plasma5-konsole) (y/N)
И всё равно это не правильно.

Аватара пользователя
adeptru
Сообщения: 626
Зарегистрирован: 29 ноя 2015, 11:03
Operating system: ROSA Desktop Fresh R11
Контактная информация:

Проблема с зависимостями в R11?

Сообщение adeptru » 24 июл 2019, 15:23

geof писал(а):
24 июл 2019, 10:58

Код: Выделить всё

~ $ sudo urpmi kate
Следующие пакеты будут удалены для обновления остальных:
plasma5-konsole-18.12.1-1-rosa2016.1.x86_64
 (из-за конфликтов с konsole)
task-plasma5-5.11-1-rosa2016.1.noarch
 (из-за отсутствия task-plasma5-minimal)
task-plasma5-minimal-5.11-1-rosa2016.1.noarch
 (из-за отсутствия plasma5-konsole) (y/N)
И всё равно это не правильно.
...Вам же выше по-русски написали: не kate, а plasma5-kate! То есть: sudo urpmi plasma5-kate!
...сегодня - лучше, чем вчера, завтра - лучше, чем сегодня!..

geof
Сообщения: 4
Зарегистрирован: 18 апр 2017, 10:29
Operating system: ROSA 16.1

Проблема с зависимостями в R11?

Сообщение geof » 25 июл 2019, 05:31

adeptru писал(а):
24 июл 2019, 15:23
...Вам же выше по-русски написали
Хамить не надо.
Ещё раз. Установка приложения с зависимостями от старых библиотек и приложений не повод ломать установленную "task".

Аватара пользователя
VictorR2007
Сообщения: 6056
Зарегистрирован: 12 сен 2011, 13:00
Operating system: ROSA 2016.1
Откуда: Северодвинск

Проблема с зависимостями в R11?

Сообщение VictorR2007 » 25 июл 2019, 11:16

geof писал(а):
25 июл 2019, 05:31
Установка приложения с зависимостями от старых библиотек и приложений не повод ломать установленную "task".
Как раз повод. Вы устанавливаете приложение, которое конфликтует с приложением из task-plasma5.
Если точнее, вы устанавливаете старый kate, который при установке дополнительно устанавливает пакет konsole.
А так как у вас уже есть установленный пакет plasma5-konsole, который конфликтует с пакетом konsole,
то пакет plasma5-konsole удаляется. Так как удаляется пакет plasma5-konsole, который входит в список пакетов task-plasma5,
то его удаление тянет за собой удаление пакета task-plasma5.
Так что устанавливайте приложение из своего окружения, и проблем не будет.
Не стоит упираться, что вот я устанавливаю что хочу, а вы сделайте, чтобы всё без проблем работало. :)
Если бы можно было так сделать, то так и сделали бы.
Так как в Росе сделан упор, чтобы были доступны для установки и KDE4, и plasma5,
то пришлось таким образом разделить их, поставив в конфликты пакеты от разных версий.
Если вы на kde4 будете устанавливать пакет plasma5-kate, то тоже удалите там пакет task-kde4.

Аватара пользователя
Barmalei
Сообщения: 4948
Зарегистрирован: 29 дек 2014, 15:45
Operating system: Intel Pentium 2020M / 6 Gb RAM / AMD GRadeon HD 8570 / Rosa Fresh R11 KDE4 2016.1 x64

Проблема с зависимостями в R11?

Сообщение Barmalei » 25 июл 2019, 13:12

У меня стоит KDE 4, но без task-kde4. Сносить ничего не будет?
Вложения
3.png
3.png (10.66 КБ) 1742 просмотра

Аватара пользователя
VictorR2007
Сообщения: 6056
Зарегистрирован: 12 сен 2011, 13:00
Operating system: ROSA 2016.1
Откуда: Северодвинск

Проблема с зависимостями в R11?

Сообщение VictorR2007 » 25 июл 2019, 13:18

Barmalei писал(а):
25 июл 2019, 13:12
urpme --auto-orphan
Видимо был установлен какой-то пакет, который его снёс.
На самом деле, это не проблема, как и у товарища, создавшего эту тему.
Проблема будет, если запускать команду

Код: Выделить всё

urpme --auto-orphan
К счастью для многих, о ней не все знают.
Бездумное применение этой команды никогда к хорошему не приведёт.
Она для опытных пользователей, которые обратят внимание, что команда может
привести систему в негодность, и установят необходимые метапакеты назад.

geof
Сообщения: 4
Зарегистрирован: 18 апр 2017, 10:29
Operating system: ROSA 16.1

Проблема с зависимостями в R11?

Сообщение geof » 26 июл 2019, 17:08

VictorR2007 писал(а):
25 июл 2019, 11:16
Как раз повод.
Вот не согласен :) Да, заменить kate и konsole можно, но зачем сносить task-plasma5? В других дистрибутивах именно так и происходит.
В прочем, это моё ИМХО. Свой устав продвигать не буду.

Аватара пользователя
Zeffanyx
Сообщения: 1369
Зарегистрирован: 12 сен 2011, 14:25
Operating system: Rosa Fresh R11, OpenMandriva Lx 4 (Cooker)
Откуда: Санкт-Петербург

Проблема с зависимостями в R11?

Сообщение Zeffanyx » 26 июл 2019, 17:11

Когда будут образы R11 с Plasma5? Сейчас на АБФ постоянно собираются образы только с KDE4 (риторический вопрос: кому в 2019 нужны KDE4, для которых уже и доп. плазмоиды не всегда можно найти?).

Аватара пользователя
Barmalei
Сообщения: 4948
Зарегистрирован: 29 дек 2014, 15:45
Operating system: Intel Pentium 2020M / 6 Gb RAM / AMD GRadeon HD 8570 / Rosa Fresh R11 KDE4 2016.1 x64

Проблема с зависимостями в R11?

Сообщение Barmalei » 26 июл 2019, 19:34

Zeffanyx писал(а):
26 июл 2019, 17:11
(риторический вопрос: кому в 2019 нужны KDE4, для которых уже и доп. плазмоиды не всегда можно найти?).
Мне нужны и плазмоиды которые мне нужны были в архивчике моем лежат.

Ответить