AutoFS и R10 (R11)

Ответить
Аватара пользователя
ans
Сообщения: 2378
Зарегистрирован: 11 сен 2011, 08:42
Operating system: Rosa
Откуда: Ekaterinburg
Контактная информация:

AutoFS и R10 (R11)

Сообщение ans » 24 окт 2018, 15:00

Autofs в R10 не работает, а в R8 при тех же условиях работает.
mikhailnov писал(а):
23 окт 2018, 18:44
Сценарий можете описать и дать конфиги?
auto.master
#
# Sample auto.master file
# This is a 'master' automounter map and it has the following format:
# mount-point [map-type[,format]:]map [options]
# For details of the format look at auto.master(5).
#
#/misc /etc/auto.misc
#
# NOTE: mounts done from a hosts map will be mounted with the
# "nosuid" and "nodev" options unless the "suid" and "dev"
# options are explicitly given.
#
#/net -hosts
#
# Include /etc/auto.master.d/*.autofs
# The included files must conform to the format of this file.
#
+dir:/etc/auto.master.d
#
# Include central master map if it can be found using
# nsswitch sources.
#
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
#
+auto.master
/mnt/cons /etc/autofs/auto.cons --timeout=60
auto.cons
#
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage

sh -fstype=cifs,user=,password=,iocharset=utf8,file_mode=0777,dir_mode=0777,noserverino,noperm ://192.168.10.125/shared

Код: Выделить всё

# service autofs restart
Redirecting to /bin/systemctl restart  autofs.service
# service autofs status
# service autofs status
Redirecting to /bin/systemctl status autofs.service
● autofs.service - Automounts filesystems on demand
Loaded: loaded (/lib/systemd/system/autofs.service; disabled; vendor preset: disabled)
Active: active (running) since Wed 2018-10-24 08:17:26 +05; 4s ago
Process: 21159 ExecStart=/usr/sbin/automount $OPTIONS --pid-file /run/autofs.pid (code=exited, status=0/SUCCESS)
Main PID: 21161 (automount)
Tasks: 4 (limit: 512)
CGroup: /system.slice/autofs.service
└─21161 /usr/sbin/automount --pid-file /run/autofs.pid

Oct 24 08:17:15 r10 systemd[1]: Starting Automounts filesystems on demand...
Oct 24 08:17:25 r10 automount[21161]: problem reading master map, maximum wait exceeded
Oct 24 08:17:25 r10 automount[21161]: /usr/sbin/automount: warning: could not read at least one map source after waiting, continuing ...
Oct 24 08:17:26 sa-opo systemd[1]: Started Automounts filesystems on demand.
Дальше обнаружил - такие ошибки выдаются даже при "чистом" auto.master который по умолчанию.
В системе нет /etc/auto.master.d. Я так понял, что это для записи логов.
Но если закомментировать +dir:/etc/auto.master.d и +auto.master, ошибок нет, но всё-равно не работает.

А в R8 работает.

P.S. Нашёл ссылку с подобной проблемой на этом форуме за 2015. Там поправили.
Изображение

Аватара пользователя
mikhailnov
Сообщения: 141
Зарегистрирован: 29 авг 2015, 22:53
Operating system: Ubuntu, ROSA, FreeBSD
Контактная информация:

AutoFS и R10 (R11)

Сообщение mikhailnov » 30 мар 2019, 16:58


Аватара пользователя
ans
Сообщения: 2378
Зарегистрирован: 11 сен 2011, 08:42
Operating system: Rosa
Откуда: Ekaterinburg
Контактная информация:

AutoFS и R10 (R11)

Сообщение ans » 31 мар 2019, 06:59

mikhailnov писал(а):
30 мар 2019, 16:58
Проверяйте:
https://bugzilla.rosalinux.ru/show_bug.cgi?id=9822#c2
Проверить только в понедельник смогу.
О результатах здесь напишу. :)
Изображение

Аватара пользователя
ans
Сообщения: 2378
Зарегистрирован: 11 сен 2011, 08:42
Operating system: Rosa
Откуда: Ekaterinburg
Контактная информация:

AutoFS и R10 (R11)

Сообщение ans » 01 апр 2019, 06:03

ans писал(а):
31 мар 2019, 06:59
mikhailnov писал(а):
30 мар 2019, 16:58
Проверяйте:
https://bugzilla.rosalinux.ru/show_bug.cgi?id=9822#c2
Проверить только в понедельник смогу.
О результатах здесь напишу. :)
Есть изменения в выводе статуса, и вроде проблемы ушли, а всё-равно не работает

Было:

Код: Выделить всё

CGroup: /system.slice/autofs.service
└─21161 /usr/sbin/automount --pid-file /run/autofs.pid

Oct 24 08:17:15 r10 systemd[1]: Starting Automounts filesystems on demand...
Oct 24 08:17:25 r10 automount[21161]: problem reading master map, maximum wait exceeded
Oct 24 08:17:25 r10 automount[21161]: /usr/sbin/automount: warning: could not read at least one map source after waiting, continuing ...
Oct 24 08:17:26 sa-opo systemd[1]: Started Automounts filesystems on demand.
Стало:

Код: Выделить всё

 CGroup: /system.slice/autofs.service
           └─12486 /usr/sbin/automount --systemd-service --dont-check-daemon

Apr 01 09:25:42 sa-it systemd[1]: Starting Automounts filesystems on demand...
Apr 01 09:25:42 sa-it systemd[1]: Started Automounts filesystems on demand.
# service autofs start
Redirecting to /bin/systemctl start autofs.service

# service autofs status
Redirecting to /bin/systemctl status autofs.service
● autofs.service - Automounts filesystems on demand
Loaded: loaded (/lib/systemd/system/autofs.service; disabled; vendor preset: disabled)
Active: active (running) since Mon 2019-04-01 09:25:42 +05; 2s ago
Main PID: 12486 (automount)
Tasks: 5 (limit: 512)
CGroup: /system.slice/autofs.service
└─12486 /usr/sbin/automount --systemd-service --dont-check-daemon

Apr 01 09:25:42 sa-it systemd[1]: Starting Automounts filesystems on demand...
Apr 01 09:25:42 sa-it systemd[1]: Started Automounts filesystems on demand.
Изображение

Аватара пользователя
mikhailnov
Сообщения: 141
Зарегистрирован: 29 авг 2015, 22:53
Operating system: Ubuntu, ROSA, FreeBSD
Контактная информация:

AutoFS и R10 (R11)

Сообщение mikhailnov » 01 апр 2019, 10:00

У вас /etc/autofs/auto.master не старый сохранился? Есть /etc/autofs/auto.master.rpmnew?

Аватара пользователя
ans
Сообщения: 2378
Зарегистрирован: 11 сен 2011, 08:42
Operating system: Rosa
Откуда: Ekaterinburg
Контактная информация:

AutoFS и R10 (R11)

Сообщение ans » 01 апр 2019, 11:15

mikhailnov писал(а):
01 апр 2019, 10:00
У вас /etc/autofs/auto.master не старый сохранился? Есть /etc/autofs/auto.master.rpmnew?
Проверил сначала после обновления - не работает, потом полностью удалил вместе с папкой /etc/autofs/ и установил заново.
auto.master.rpmnew был после обновления. После новой установки нет.
Изображение

Аватара пользователя
mikhailnov
Сообщения: 141
Зарегистрирован: 29 авг 2015, 22:53
Operating system: Ubuntu, ROSA, FreeBSD
Контактная информация:

AutoFS и R10 (R11)

Сообщение mikhailnov » 10 апр 2019, 14:29

Мне кажется, у вас конфиг неправильный, вряд ли надо писать в auto.master
Откопал свой старый конфиг: https://vk.com/wall-33847957_56075?reply=56220

Аватара пользователя
ans
Сообщения: 2378
Зарегистрирован: 11 сен 2011, 08:42
Operating system: Rosa
Откуда: Ekaterinburg
Контактная информация:

AutoFS и R10 (R11)

Сообщение ans » 11 апр 2019, 08:42

mikhailnov писал(а):
10 апр 2019, 14:29
вряд ли надо писать в auto.master
Что не писать?
В архиве так же.
Не надо дополнительный каталог?

И потом, в R8 всё замечательно работает.
Изображение

Аватара пользователя
mikhailnov
Сообщения: 141
Зарегистрирован: 29 авг 2015, 22:53
Operating system: Ubuntu, ROSA, FreeBSD
Контактная информация:

AutoFS и R10 (R11)

Сообщение mikhailnov » 11 апр 2019, 20:16

Да, там несоответствие версии протокола SMB в autofs и современных ядрах
https://www.happyassassin.net/2017/11/0 ... rsion-fun/
https://bugzilla.rosalinux.ru/show_bug.cgi?id=9852
Наверное, надо в "-fstype=cifs,user=,password=,iocharset=utf8,file_mode=0777,dir_mode=0777,noserverino,noperm" добавить: "vers=1.0"
Я посмотрю, что можно сделать, чтобы работало из коробки.

Аватара пользователя
ans
Сообщения: 2378
Зарегистрирован: 11 сен 2011, 08:42
Operating system: Rosa
Откуда: Ekaterinburg
Контактная информация:

AutoFS и R10 (R11)

Сообщение ans » 12 апр 2019, 06:03

mikhailnov писал(а):
11 апр 2019, 20:16
добавить: "vers=1.0"
Заработало!!!!! :Yahoo!:

P.S. Виндовые программы запускаются с winсерверов без всякой бесшовной интеграции.
Изображение

Ответить