Нет пакета libgccjit-devel который нужен для нового emacs28.1

Текущая информация от разработчиков о тех или иных компонентах системы, общение с разработчиками и участниками команды
Ответить
leanid.chaika
Сообщения: 2
Зарегистрирован: 15 апр 2022, 21:56
Operating system: ROSA Fresh 12.2

Нет пакета libgccjit-devel который нужен для нового emacs28.1

Сообщение leanid.chaika » 15 апр 2022, 22:03

Здравствуйте,
Установил себе ROSA Fresh 12.2. Установил компилятор gcc, gcc-c++, make, и решил собрать самый свежий emacs 28.1, и главное включить в нем поддержку компиляции elisp в нативный код(--with-native-compilation). Получил сообщение во время фазы конфигурирования:
./configure —with-native-compilation
...
configure: error: ELisp native compiler was requested, but libgccjit was not found.
Please try installing libgccjit or a similar package.
If you are sure you want Emacs be compiled without ELisp native compiler,
pass the —without-native-compilation option to configure.
...
Дальше поискал и не нашел пакет - gccjit (libgccjit, lib64gccjit и т.д.) Посморел на версию компилятора - gcc —version - получил - 11.2 - новая версия, куда же пропала эта библиотека?
Пока искал к кому обратиться за помощью собрал эту библиотеку, самостоятельно, но тесты не проходят, поэтому решил спросить помощи, где я могу найти скрипты, от сборки компилятора gcc и или gcc-c++ - и по примеру хочу посмотреть на эти скрипты сборки пакета, и сделать свой, только для gccjit - что бы все взлетело! Есть кто-нибудь кто может меня направить? Репозитория со скриптами сборки я не нашел...
Заранее благодарю.

irton
Сообщения: 254
Зарегистрирован: 30 окт 2021, 04:17
Operating system: PuppyRus linux

Нет пакета libgccjit-devel который нужен для нового emacs28.1

Сообщение irton » 17 апр 2022, 03:10

Откройте баг на багзилле


Ответить

Вернуться в «Информация от разработчиков»