Установка 1С-Предприятие

Ответить
vid
Сообщения: 3
Зарегистрирован: 21 фев 2022, 08:11
Operating system: ROSA Fresh Desktop 2021.1

Установка 1С-Предприятие

Сообщение vid » 21 фев 2022, 08:44

Не запускается клиент 1С 8.3.18.1334. установка проходит без замечений, а при запуске из термина пишет, что не найдены файлы webkitgtk3
Установить пакет webkitgtk-3.0.0 не удалось.

nickm
Сообщения: 342
Зарегистрирован: 31 май 2016, 07:08
Operating system: ROSA Fresh 2023.1

Установка 1С-Предприятие

Сообщение nickm » 21 фев 2022, 09:15

У Вас так было?

Код: Выделить всё

# dnf install ./*.rpm
Последняя проверка окончания срока действия метаданных: 0:03:19 назад, Пн 21 фев 2022 11:02:47.
Зависимости разрешены.
=======================================================================================================================================================================================================================================
 Пакет                                                                       Архитектура                              Версия                                        Репозиторий                                                  Размер
=======================================================================================================================================================================================================================================
Установка:
 1c-enterprise-8.3.18.1334-thin-client                                       x86_64                                   8.3.18-1334                                   @commandline                                                 106 M
 1c-enterprise-8.3.18.1334-thin-client-nls                                   x86_64                                   8.3.18-1334                                   @commandline                                                  22 M
Установка зависимостей:
 lib64javascriptcoregtk3.0_0                                                 x86_64                                   1:2.4.11-6                                    mirror-rosa-x86_64-contrib                                   1.7 M
 lib64webkitgtk3.0_0                                                         x86_64                                   1:2.4.11-6                                    mirror-rosa-x86_64-contrib                                   7.8 M

Результат транзакции
=======================================================================================================================================================================================================================================
Установка  4 Пакета

Общий размер: 137 M
Объем загрузки: 9.5 M
Объем изменений: 480 M
Продолжить? [д/Н]: y
Загрузка пакетов:
(1/2): lib64javascriptcoregtk3.0_0-2.4.11-6-rosa2021.1.x86_64.rpm                                                                                                                                      1.2 MB/s | 1.7 MB     00:01    
(2/2): lib64webkitgtk3.0_0-2.4.11-6-rosa2021.1.x86_64.rpm                                                                                                                                              2.7 MB/s | 7.8 MB     00:02    
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Общий размер                                                                                                                                                                                           3.3 MB/s | 9.5 MB     00:02     
Проверка транзакции
Проверка транзакции успешно завершена.
Идет проверка транзакции
Тест транзакции проведен успешно.
Выполнение транзакции
  Подготовка       :                                                                                                                                                                                                               1/1 
  Установка        : 1c-enterprise-8.3.18.1334-thin-client-8.3.18-1334.x86_64                                                                                                                                                      1/4 
  Запуск скриптлета: 1c-enterprise-8.3.18.1334-thin-client-8.3.18-1334.x86_64                                                                                                                                                      1/4 
  Установка        : lib64javascriptcoregtk3.0_0-1:2.4.11-6.x86_64                                                                                                                                                                 2/4 
  Установка        : lib64webkitgtk3.0_0-1:2.4.11-6.x86_64                                                                                                                                                                         3/4 
  Установка        : 1c-enterprise-8.3.18.1334-thin-client-nls-8.3.18-1334.x86_64                                                                                                                                                  4/4 
  Запуск скриптлета: 1c-enterprise-8.3.18.1334-thin-client-8.3.18-1334.x86_64                                                                                                                                                      4/4 
  Запуск скриптлета: 1c-enterprise-8.3.18.1334-thin-client-nls-8.3.18-1334.x86_64                                                                                                                                                  4/4 
  Проверка         : lib64javascriptcoregtk3.0_0-1:2.4.11-6.x86_64                                                                                                                                                                 1/4 
  Проверка         : lib64webkitgtk3.0_0-1:2.4.11-6.x86_64                                                                                                                                                                         2/4 
  Проверка         : 1c-enterprise-8.3.18.1334-thin-client-8.3.18-1334.x86_64                                                                                                                                                      3/4 
  Проверка         : 1c-enterprise-8.3.18.1334-thin-client-nls-8.3.18-1334.x86_64                                                                                                                                                  4/4 

Установлен:
  1c-enterprise-8.3.18.1334-thin-client-8.3.18-1334.x86_64        1c-enterprise-8.3.18.1334-thin-client-nls-8.3.18-1334.x86_64        lib64javascriptcoregtk3.0_0-1:2.4.11-6.x86_64        lib64webkitgtk3.0_0-1:2.4.11-6.x86_64       

Выполнено!
А после так было?

Код: Выделить всё

$ ./1cestart
./1cestart: /opt/1cv8/common/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/libwebkitgtk-3.0.so.0)
./1cestart: /opt/1cv8/common/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /usr/lib64/libwebkitgtk-3.0.so.0)
./1cestart: /opt/1cv8/common/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/libaspell.so.15)
Если да, тогда Вам следует "отодвинуть" 1с-овую библиотеку:

Код: Выделить всё

libstdc++.so.6
из каталогов этой самой 1с8.

vid
Сообщения: 3
Зарегистрирован: 21 фев 2022, 08:11
Operating system: ROSA Fresh Desktop 2021.1

Установка 1С-Предприятие

Сообщение vid » 21 фев 2022, 12:42

Да именно так и было. Что значит "отодвинуть"?

nickm
Сообщения: 342
Зарегистрирован: 31 май 2016, 07:08
Operating system: ROSA Fresh 2023.1

Установка 1С-Предприятие

Сообщение nickm » 21 фев 2022, 14:12

vid писал(а):
21 фев 2022, 12:42
Что значит "отодвинуть"?
Переместить из текущего расположения/ переименовать, но не удалять, вдруг когда-нибудь пригодится?
Тут дело такое - библиотека расположена рядом с исполнимым файлом, и именно она в первую очередь этим самым файлом и используется/ вызывается, а не системная (это следует знать и помнить).
И эта самая библиотека "жестко" слинкована с др. библиотеками определенных/ отличных от системных библиотек версий.
"Пододвинув" 1с-овую библиотеку, Вы тем самым заставите этот 1с8 использовать системные библиотеки.

vid
Сообщения: 3
Зарегистрирован: 21 фев 2022, 08:11
Operating system: ROSA Fresh Desktop 2021.1

Установка 1С-Предприятие

Сообщение vid » 25 фев 2022, 07:16

Да теперь клиент 1С запустился

Аватара пользователя
Raskaton
Сообщения: 38
Зарегистрирован: 05 ноя 2022, 03:45
Operating system: ROSA Fresh Desktop 2021.1

Установка 1С-Предприятие

Сообщение Raskaton » 25 апр 2024, 17:24

Опять эта же беда! :evil:
Обновлялся на новую технологическую платформу 8.3.25.1257 от 22.04.2024 г. (с 8.3.23.17)
Скачал, установил от админа. Не запускается! Предыдущая запускается, а новая нет...
Достал бубен, открыл консоль, а там:

Код: Выделить всё

raskaton@SG05 /opt/1cv8/common $ ./1cestart
./1cestart: /opt/1cv8/common/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/libwebkit2gtk-4.0.so.37)
./1cestart: /opt/1cv8/common/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/libjavascriptcoregtk-4.0.so.18)
./1cestart: /opt/1cv8/common/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/libWPEBackend-fdo-1.0.so.1)
./1cestart: /opt/1cv8/common/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/libwoff2dec.so.1.0.2)
./1cestart: /opt/1cv8/common/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/libaspell.so.15)
попробовал напрямую запустить, без стартовой приложухи:

Код: Выделить всё

raskaton@SG05 /opt/1cv8/x86_64/8.3.25.1257 $ ./1cv8s
./1cv8s: /opt/1cv8/x86_64/8.3.25.1257/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/libwebkit2gtk-4.0.so.37)
./1cv8s: /opt/1cv8/x86_64/8.3.25.1257/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/libjavascriptcoregtk-4.0.so.18)
./1cv8s: /opt/1cv8/x86_64/8.3.25.1257/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/libwoff2dec.so.1.0.2)
./1cv8s: /opt/1cv8/x86_64/8.3.25.1257/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/libjxl.so.0.9)
./1cv8s: /opt/1cv8/x86_64/8.3.25.1257/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/libaspell.so.15)
Смотрю что у меня в дистре:

Код: Выделить всё

raskaton@SG05 ~ $ ls -la /lib/libstdc++*
lrwxrwxrwx 1 root root      19 апр  3 21:57 /lib/libstdc++.so.6 -> libstdc++.so.6.0.29
-rwxr-xr-x 1 root root 2193348 апр  3 22:01 /lib/libstdc++.so.6.0.29
и понимаю, что 1С-ники снова добавили в свою поставку старую либу зачем-то!

Код: Выделить всё

raskaton@SG05 ~ $ ls -la /opt/1cv8/common/libstdc++*
-rw-r--r-- 1 root root 2531984 апр 15 22:25 /opt/1cv8/common/libstdc++.so.6.0.28
lrwxrwxrwx 1 root root      19 апр 23 00:20 /opt/1cv8/common/libstdc++.so.6 -> libstdc++.so.6.0.28

raskaton@SG05 ~ $ ls -la /opt/1cv8/x86_64/8.3.25.1257/libstdc++*
-rw-r--r-- 1 root root 2531984 апр 15 22:25 /opt/1cv8/x86_64/8.3.25.1257/libstdc++.so.6.0.28
lrwxrwxrwx 1 root root      19 апр 23 00:20 /opt/1cv8/x86_64/8.3.25.1257/libstdc++.so.6 -> libstdc++.so.6.0.28
В установленной версии этого безобразия нет и всё работает.
Для лечения переименовал ссылки внутри 1С:

Код: Выделить всё

raskaton@SG05 /opt/1cv8/common $ sudo mv libstdc++.so.6 libstdc++.so.6-off
raskaton@SG05 /opt/1cv8/x86_64/8.3.25.1257 $ sudo mv libstdc++.so.6 libstdc++.so.6-off
Заработало. И даже меньше тормозит, чем предыдущая версия. И пока ни разу не повисла [тьфу тьфу тьфу].

Но вот червячок меня гложет: зачем то же они вшили эту библиотеку в свой инсталятор...
Надеюсь, что ответ на этот вопрос в банальной недальновидности.

nickm
Сообщения: 342
Зарегистрирован: 31 май 2016, 07:08
Operating system: ROSA Fresh 2023.1

Установка 1С-Предприятие

Сообщение nickm » 26 апр 2024, 06:50

Raskaton писал(а):
25 апр 2024, 17:24
Заработало. И даже меньше тормозит, чем предыдущая версия.
Отлично, спасибо!

Тоже планирую обновить версию на паре-тройке АРМ, теперь буду знать, на что следует обратить внимание;
Raskaton писал(а):
25 апр 2024, 17:24
зачем то же они вшили эту библиотеку в свой инсталятор...
Полагаю, что это некая совместимость - заработает в тех операционных системам, где версия системной библиотеки менее:

Код: Выделить всё

libstdc++.so.6.0.28

irton
Сообщения: 739
Зарегистрирован: 30 окт 2021, 04:17
Operating system: Rosa Fresh Xfce

Установка 1С-Предприятие

Сообщение irton » 26 апр 2024, 08:00

Дайте пожалуйста рецепт, как ставить из run файла. Мне сообщают что после того, как пройти этапы в инсталяторе, выдается ошибка что не хватает зависимостей

libgtk-3-0 libenchant1c2a libharfbuzz-icu0 libgstreamer1.0-0
libgstreamer-plugins-base1.0-0 gstreamer1.0-plugins-good
gstreamer1.0-plugins-bad libsecret-1-0 libsoup2.4-1 libsqlite3-0 libgl1 libegl1
libxrender1 libxfixes3 libxslt1.1 geoclue-2.0

nickm
Сообщения: 342
Зарегистрирован: 31 май 2016, 07:08
Operating system: ROSA Fresh 2023.1

Установка 1С-Предприятие

Сообщение nickm » 26 апр 2024, 13:37

irton писал(а):
26 апр 2024, 08:00
Дайте пожалуйста рецепт, как ставить из run файла. Мне сообщают что после того, как пройти этапы в инсталяторе, выдается ошибка что не хватает зависимостей
Зачастую, это сообщение можно игнорировать, клиентское приложение работает и без указанных зависимостей.

За два года эксплуатации 1с8 на "R12" и использования нескольких различных версий (поддерживаю актуальность версий), ни разу не столкнулся с неработающим/ с ошибками работы в 1с8 (в Моём сценарии используется клиент-серверное подключение, когда сервер под Win).

irton
Сообщения: 739
Зарегистрирован: 30 окт 2021, 04:17
Operating system: Rosa Fresh Xfce

Установка 1С-Предприятие

Сообщение irton » 26 апр 2024, 13:59

Так оно ставит файлы в систему даже выдавая ошибки зависимостей ?

nickm
Сообщения: 342
Зарегистрирован: 31 май 2016, 07:08
Operating system: ROSA Fresh 2023.1

Установка 1С-Предприятие

Сообщение nickm » 26 апр 2024, 15:00

irton писал(а):
26 апр 2024, 13:59
Так оно ставит файлы в систему даже выдавая ошибки зависимостей ?
Да, *.run - это считай простой распаковщик архива. Распаковывает в /opt и создаёт ярлыки.

Калашников Сергей
Сообщения: 22
Зарегистрирован: 21 июн 2017, 22:34
Operating system: POSA LXQt
Lubuntu

Установка 1С-Предприятие

Сообщение Калашников Сергей » 27 апр 2024, 21:27

nickm писал(а):
21 фев 2022, 14:12
vid писал(а):
21 фев 2022, 12:42
Что значит "отодвинуть"?
Переместить из текущего расположения/ переименовать, но не удалять, вдруг когда-нибудь пригодится?
Тут дело такое - библиотека расположена рядом с исполнимым файлом, и именно она в первую очередь этим самым файлом и используется/ вызывается, а не системная (это следует знать и помнить).
И эта самая библиотека "жестко" слинкована с др. библиотеками определенных/ отличных от системных библиотек версий.
"Пододвинув" 1с-овую библиотеку, Вы тем самым заставите этот 1с8 использовать системные библиотеки.
Прошу прощения, из моего опыта 1С слегка запаздывает за обновлением систем. Как правило системные библиотеки лучше 1Совских, лучше ориентироваться на них Если хочешь работать в 1С никуда не денешься от умения ставить и манипулировать библиотеками.
СпасиБо за коменты

Аватара пользователя
Raskaton
Сообщения: 38
Зарегистрирован: 05 ноя 2022, 03:45
Operating system: ROSA Fresh Desktop 2021.1

Установка 1С-Предприятие

Сообщение Raskaton » 02 май 2024, 22:51

irton писал(а):
26 апр 2024, 08:00
Дайте пожалуйста рецепт, как ставить из run файла. Мне сообщают что после того, как пройти этапы в инсталяторе, выдается ошибка что не хватает зависимостей

libgtk-3-0 libenchant1c2a libharfbuzz-icu0 libgstreamer1.0-0
libgstreamer-plugins-base1.0-0 gstreamer1.0-plugins-good
gstreamer1.0-plugins-bad libsecret-1-0 libsoup2.4-1 libsqlite3-0 libgl1 libegl1
libxrender1 libxfixes3 libxslt1.1 geoclue-2.0
Да, была такая беда при самой первой установке на чистую систему. Помню, что честно проверил все пакеты ручками и установил. Загвоздка в том, что эти пакеты в Росе по-другому называются. Запускаем dnfdragora и ищем похожее. Главное отличие, что пакеты начинаются с lib64, например lib64gtk+3_0. Мне показалось, что это сообщение неверно выдаётся даже когда пакеты установлены. Опять же из-за другого именования. Но какого-то одного может не хватать.
Увидел, что в новом инсталяторе(run) можно выбрать опцию "Установить зависимости". Возможно, как-то автоматизировали это.

И главное, конфигурацию "1С:Бухгалтерия для 1ИНН" первый раз нужно запустить от root/sudo, чтобы она смогла лицензию запросить правильную. Это особая конфа с "короткой" электронной лицензией.

P.S. Из-за новых форм отчётности пришлось сделать 6 обновлений конфигурации подряд. Теперь пропали все картинки рекламные и информационные - открываются пустые окошки. То ли бага в конфах, то ли какую-то зависимость надо доставлять... жить можно, вроде.

turik02
Сообщения: 297
Зарегистрирован: 01 июн 2022, 13:47
Operating system: ROSA FRESH GNOME 12.5 x86_64

Установка 1С-Предприятие

Сообщение turik02 » 14 июн 2024, 13:40

GNOME 12.5.1. Попробовал установить. Получилось двумя способами:
1) Устанавливаем «1С:Предприятие» (в окне установки всё оставляем как есть, то есть рядом с пунктом «ЗАВИСИМОСТИ» галочку ставить НЕ НАДО! Затем устанавливаем из репозитория

Код: Выделить всё

sudo dnf install lib64enchant1
2) Устанавливаем «1С:Предприятие» (в окне установки ставим галочку напротив пункта «ЗАВИСИМОСТИ») и после установки программы необходимо удалить файл libstdc++.so.6 из папок /opt/1cv8/common/ и /opt/1cv8/x86_64/8.3.[ВашНомерВерсии]/.
Затем устанавливаем из репозитория

Код: Выделить всё

sudo dnf install lib64gtk+3_0

Ответить

Вернуться в «Обсуждение ROSA Fresh R12 (платформа 2021.1)»