Проблемы с ip_forward

Ответить
crasher332
Сообщения: 82
Зарегистрирован: 25 июл 2016, 13:40
Operating system: ROSA DESKTOP FRESH R10 (PLASMA)

Проблемы с ip_forward

Сообщение crasher332 » 25 апр 2019, 09:43

Доброго всем времени суток! Настраиваю nat и столкнулся с такой проблемой - не могу активировать проброс. Какие бы скрипты не писал, куда бы их не забрасывал. Всё время, после перезагрузке системы проверка командой: sudo cat /proc/sys/net/ipv4/ip_forward выдаёт 0, пока я не выполню команду: susdo sysctl -w net.ipv4.ip_forward=1, после проверка командой: sudo cat... выдаёт 1. Я создавал файл /etc/sysctl.conf, прописывал в нём net.ipv4.ip_forward=1, добавлял команду syctl -w net.ipv4.ip_forward во всевозможные скрипты, создавал собственный скрипт, в network-scripts добавлял, добавлял её в автозагрузку, даже в cron создавал задание - всё безрезультатно, после перезагрузки net.ipv4.ip_forward=0. Samba настроена в качестве контроллера домена, dns работает, клиенты подключаются, машины вносятся в домен. Shorewall отключен, таблица маршрутизации автоматически настроена при поднятии домена, в таблицу маршрутизации добавлен маскарад. Подскажите пожалуйста, как заставить систему грузиться с net.ipv4.ip_forward=1.

crasher332
Сообщения: 82
Зарегистрирован: 25 июл 2016, 13:40
Operating system: ROSA DESKTOP FRESH R10 (PLASMA)

Проблемы с ip_forward

Сообщение crasher332 » 25 апр 2019, 13:55

Проблема решилась переходом от настройки iptables до использования shorewall. В shorewall.conf по пути /etc/shorewall/shorewall.conf есть параметр IP_FORWARDING, после установки параметра в "Yes", "nat" заработал (после настройки shorewall конечно).

Ответить