AutoFS и R10 (R11)

Ответить
Аватара пользователя
ans
Сообщения: 2266
Зарегистрирован: 11 сен 2011, 08:42
Operating system: Rosa
Откуда: Ekaterinburg
Контактная информация:

AutoFS и R10 (R11)

Сообщение ans » 24 окт 2018, 15:00

Autofs в R10 не работает, а в R8 при тех же условиях работает.
mikhailnov писал(а):
23 окт 2018, 18:44
Сценарий можете описать и дать конфиги?
auto.master
#
# Sample auto.master file
# This is a 'master' automounter map and it has the following format:
# mount-point [map-type[,format]:]map [options]
# For details of the format look at auto.master(5).
#
#/misc /etc/auto.misc
#
# NOTE: mounts done from a hosts map will be mounted with the
# "nosuid" and "nodev" options unless the "suid" and "dev"
# options are explicitly given.
#
#/net -hosts
#
# Include /etc/auto.master.d/*.autofs
# The included files must conform to the format of this file.
#
+dir:/etc/auto.master.d
#
# Include central master map if it can be found using
# nsswitch sources.
#
# Note that if there are entries for /net or /misc (as
# above) in the included master map any keys that are the
# same will not be seen as the first read key seen takes
# precedence.
#
+auto.master
/mnt/cons /etc/autofs/auto.cons --timeout=60
auto.cons
#
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage

sh -fstype=cifs,user=,password=,iocharset=utf8,file_mode=0777,dir_mode=0777,noserverino,noperm ://192.168.10.125/shared

Код: Выделить всё

# service autofs restart
Redirecting to /bin/systemctl restart  autofs.service
# service autofs status
# service autofs status
Redirecting to /bin/systemctl status autofs.service
● autofs.service - Automounts filesystems on demand
Loaded: loaded (/lib/systemd/system/autofs.service; disabled; vendor preset: disabled)
Active: active (running) since Wed 2018-10-24 08:17:26 +05; 4s ago
Process: 21159 ExecStart=/usr/sbin/automount $OPTIONS --pid-file /run/autofs.pid (code=exited, status=0/SUCCESS)
Main PID: 21161 (automount)
Tasks: 4 (limit: 512)
CGroup: /system.slice/autofs.service
└─21161 /usr/sbin/automount --pid-file /run/autofs.pid

Oct 24 08:17:15 r10 systemd[1]: Starting Automounts filesystems on demand...
Oct 24 08:17:25 r10 automount[21161]: problem reading master map, maximum wait exceeded
Oct 24 08:17:25 r10 automount[21161]: /usr/sbin/automount: warning: could not read at least one map source after waiting, continuing ...
Oct 24 08:17:26 sa-opo systemd[1]: Started Automounts filesystems on demand.
Дальше обнаружил - такие ошибки выдаются даже при "чистом" auto.master который по умолчанию.
В системе нет /etc/auto.master.d. Я так понял, что это для записи логов.
Но если закомментировать +dir:/etc/auto.master.d и +auto.master, ошибок нет, но всё-равно не работает.

А в R8 работает.

P.S. Нашёл ссылку с подобной проблемой на этом форуме за 2015. Там поправили.
Изображение

Ответить