Страница 1 из 5

Неофициальная сборка новой plasma5

Добавлено: 24 сен 2018, 13:12
VictorR2007
У меня один наш товарищ с форума попросил выкладывать свежие сборки в отдельной теме.

Неофициальная сборка новой plasma5

Добавлено: 24 сен 2018, 13:37
VictorR2007
Это сборка сделана вчера.
https://yadi.sk/d/QxBSkcMPKeg6Rg
В архив с локальным репозиторием входит
Qt-5.11.2, KF 5.50.0, plasma 5.13.90.
Так-же там последний dolphin из гит, музыкальный проигрыватель elisa из гит.
Ещё последний vlc и tano, собранные с qt-5.11.
Там же последний Falkon из гит.
Где заметил, исправил перевод.
Для видео карт intel лучше на мой взгляд использовать иксы из x11_backports,
в комплекте с пакетом x11-driver-video-intel-config-modesetting.
Если есть принтер HP, то не устанавливайте эту сборку.
Слетит принтер, так как не получается собрать нужные ему python-sip и python-qt5
с новым qt5, да и не сильно заморачивался, так как мне не нужен на ноутбуке принтер.
Добавил qt-creator, пересобранный с новым Qt5 https://yadi.sk/d/AykIR39EAzH4vQ

Неофициальная сборка новой plasma5

Добавлено: 25 сен 2018, 08:27
ans
VictorR2007 писал(а):
24 сен 2018, 13:37
Это сборка сделана вчера.
https://yadi.sk/d/dH6u2WcefagX8w
Получилось так:
Хоть часть пакетов и могла быть установлена, произошли ошибки.
Следующие пакеты будут удалены для обновления остальных:
hplip-3.16.11-7-rosa2016.1.x86_64
(из-за отсутствия hplip-gui,
из-за неудовлетворённости hplip-compat-libs == 3.16.11-7)
hplip-compat-libs-3.16.11-7-rosa2016.1.x86_64
(из-за неудовлетворённости hplip == 3.16.11-7)
hplip-gui-3.16.11-7-rosa2016.1.x86_64
(из-за отсутствия python3-qt5-core,
из-за отсутствия python3-qt5-gui,
из-за отсутствия python3-qt5-dbus,
из-за отсутствия python3-qt5-widgets,
из-за неудовлетворённости hplip == 3.16.11-7)
lib64qgsttools_p1-5.9.4-1-rosa2016.1.x86_64
(из-за отсутствия libQt5Multimedia.so.5(Qt_5_PRIVATE_API)(64bit))
python-qt5-core-5.9-1-rosa2016.1.x86_64
(из-за отсутствия libQt5Core.so.5(Qt_5_PRIVATE_API)(64bit))
python-qt5-gui-5.9-1-rosa2016.1.x86_64
(из-за неудовлетворённости python-qt5-core == 5.9-1:2016.1)
python-qt5-widgets-5.9-1-rosa2016.1.x86_64
(из-за неудовлетворённости python-qt5-core == 5.9-1:2016.1)
python3-qt5-core-5.9-1-rosa2016.1.x86_64
(из-за отсутствия libQt5Core.so.5(Qt_5_PRIVATE_API)(64bit))
python3-qt5-dbus-5.9-1-rosa2016.1.x86_64
(из-за неудовлетворённости python3-qt5-core == 5.9-1:2016.1)
python3-qt5-gui-5.9-1-rosa2016.1.x86_64
(из-за неудовлетворённости python3-qt5-core == 5.9-1:2016.1)
python3-qt5-widgets-5.9-1-rosa2016.1.x86_64
(из-за неудовлетворённости python3-qt5-core == 5.9-1:2016.1)
rosa-freeze-ui-0.9-5-rosa2016.1.noarch
(из-за отсутствия python-qt5-gui,
из-за отсутствия python-qt5-widgets)
task-printing-2014-4-rosa2016.1.x86_64
(из-за неудовлетворённости task-printing-hp == 2014-4)
task-printing-hp-2014-4-rosa2016.1.x86_64
(из-за неудовлетворённости hplip-gui >= 3.13.11,
из-за неудовлетворённости hplip >= 3.13.11)
task-printing-scanning-2014-4-rosa2016.1.x86_64
(из-за отсутствия hplip-gui,
из-за неудовлетворённости task-printing == 2014)
Screenshot_20180925_104815.png

Неофициальная сборка новой plasma5

Добавлено: 25 сен 2018, 10:07
VictorR2007
ans писал(а):
25 сен 2018, 08:27
Получилось так:
Это потому, что как и написал выше
VictorR2007 писал(а):
24 сен 2018, 13:37
Слетит принтер, так как не получается собрать нужные ему python-sip и python-qt5
с новым qt5,
но если принтер HP не нужен, то и проблем нет.

Неофициальная сборка новой plasma5

Добавлено: 25 сен 2018, 11:59
Kelpee
VictorR2007 писал(а):
24 сен 2018, 13:37
Это сборка сделана вчера.
https://yadi.sk/d/dH6u2WcefagX8w
В архив с локальным репозиторием входит
Qt-5.11.2, KF 5.50.0, plasma 5.13.90.
Так-же там последний dolphin из гит, музыкальный проигрыватель elisa из гит.
Ещё последний vlc и tano, собранные с qt-5.11.
Там же последний Falkon из гит.
Где заметил, исправил перевод.
Для видео карт intel лучше на мой взгляд использовать иксы из x11_backports,
в комплекте с пакетом x11-driver-video-intel-config-modesetting.
Если есть принтер HP, то не устанавливайте эту сборку.
Слетит принтер, так как не получается собрать нужные ему python-sip и python-qt5
с новым qt5, да и не сильно заморачивался, так как мне не нужен на ноутбуке принтер.
Спасибо! В пятницу вернусь в командировки и непременно установлю и протестирую.

Неофициальная сборка новой plasma5

Добавлено: 25 сен 2018, 15:12
Zeffanyx
VictorR2007 писал(а):
25 сен 2018, 10:07
ans писал(а):
25 сен 2018, 08:27
Получилось так:
Это потому, что как и написал выше
VictorR2007 писал(а):
24 сен 2018, 13:37
Слетит принтер, так как не получается собрать нужные ему python-sip и python-qt5
с новым qt5,
но если принтер HP не нужен, то и проблем нет.
Поясните, пожалуйста, связь принтера HP и python-qt5.
У меня принтер HP Deskjet 930c, работает с драйвером Turboprint. Мне нужно чего-то опасаться при обновлении?

Неофициальная сборка новой plasma5

Добавлено: 25 сен 2018, 17:48
VictorR2007
Zeffanyx писал(а):
25 сен 2018, 15:12
Мне нужно чего-то опасаться при обновлении?
Будут удалены пакеты
hplip-gui
hplip
hplip-compat-libs
task-printing-hp
Можете их удалить сначала для проверки.
А после проверки опять установить.
Я другого способа узнать, что у вас получится при обновлении, не знаю.
Впрочем, всегда можно воспользоваться для отката urpm-reposync.
Я проверял его работу несколько раз с откатом на qt-5.11.1.
Работало без проблем.
Единственно, ругалось на krusader, но после удаления krusader отрабатывало без ошибок.

Неофициальная сборка новой plasma5

Добавлено: 28 сен 2018, 12:21
Kelpee
VictorR2007 писал(а):
24 сен 2018, 13:37
Это сборка сделана вчера.
https://yadi.sk/d/dH6u2WcefagX8w
В архив с локальным репозиторием входит
Qt-5.11.2, KF 5.50.0, plasma 5.13.90.
Так-же там последний dolphin из гит, музыкальный проигрыватель elisa из гит.
Ещё последний vlc и tano, собранные с qt-5.11.
Там же последний Falkon из гит.
Где заметил, исправил перевод.
Для видео карт intel лучше на мой взгляд использовать иксы из x11_backports,
в комплекте с пакетом x11-driver-video-intel-config-modesetting.
Если есть принтер HP, то не устанавливайте эту сборку.
Слетит принтер, так как не получается собрать нужные ему python-sip и python-qt5
с новым qt5, да и не сильно заморачивался, так как мне не нужен на ноутбуке принтер.
Добрый день!
Попробовал установить вашу последнюю сборку.
При попытке установки пишет:
Следующие пакеты будут удалены для обновления остальных:
hplip-3.16.11-7-rosa2016.1.x86_64
(из-за отсутствия hplip-gui,
из-за неудовлетворённости hplip-compat-libs == 3.16.11-7)
hplip-compat-libs-3.16.11-7-rosa2016.1.x86_64
(из-за неудовлетворённости hplip == 3.16.11-7)
hplip-gui-3.16.11-7-rosa2016.1.x86_64
(из-за отсутствия python3-qt5-core,
из-за отсутствия python3-qt5-dbus,
из-за отсутствия python3-qt5-gui,
из-за отсутствия python3-qt5-widgets,
из-за неудовлетворённости hplip == 3.16.11-7)
lib64qgsttools_p1-5.9.4-1-rosa2016.1.x86_64
(из-за отсутствия libQt5Multimedia.so.5(Qt_5_PRIVATE_API)(64bit))
python-qt5-core-5.9-1-rosa2016.1.x86_64
(из-за отсутствия libQt5Core.so.5(Qt_5_PRIVATE_API)(64bit))
python-qt5-gui-5.9-1-rosa2016.1.x86_64
(из-за неудовлетворённости python-qt5-core == 5.9-1:2016.1)
python-qt5-widgets-5.9-1-rosa2016.1.x86_64
(из-за неудовлетворённости python-qt5-core == 5.9-1:2016.1)
python3-qt5-core-5.9-1-rosa2016.1.x86_64
(из-за отсутствия libQt5Core.so.5(Qt_5_PRIVATE_API)(64bit))
python3-qt5-dbus-5.9-1-rosa2016.1.x86_64
(из-за неудовлетворённости python3-qt5-core == 5.9-1:2016.1)
python3-qt5-gui-5.9-1-rosa2016.1.x86_64
(из-за неудовлетворённости python3-qt5-core == 5.9-1:2016.1)
python3-qt5-widgets-5.9-1-rosa2016.1.x86_64
(из-за неудовлетворённости python3-qt5-core == 5.9-1:2016.1)
rosa-freeze-ui-0.9-5-rosa2016.1.noarch
(из-за отсутствия python-qt5-widgets,
из-за отсутствия python-qt5-gui)
task-printing-2014-4-rosa2016.1.x86_64
(из-за неудовлетворённости task-printing-hp == 2014-4)
task-printing-hp-2014-4-rosa2016.1.x86_64
(из-за неудовлетворённости hplip-gui >= 3.13.11,
из-за неудовлетворённости hplip >= 3.13.11)
task-printing-scanning-2014-4-rosa2016.1.x86_64
(из-за отсутствия hplip-gui,
из-за неудовлетворённости task-printing == 2014)
viber-7.0.0.1035-4-rosa2016.1.x86_64
(из-за отсутствия libqgsttools_p.so.1()(64bit)) (y/N)
Большинство строчек мне не интересны - принтера у меня нет и не предвидится.
Но две последние для меня, можно сказать, критичны: так как важно наличие клиента вайбера на компьютере :

Следующие пакеты будут удалены для обновления остальных:
................................................................
viber-7.0.0.1035-4-rosa2016.1.x86_64
(из-за отсутствия libqgsttools_p.so.1()(64bit)) (y/N)

Как решить эту проблему, т.е. где взять этот libqgsttools_p.so.1()(64bit) ?

Неофициальная сборка новой plasma5

Добавлено: 28 сен 2018, 13:21
VictorR2007
Kelpee писал(а):
28 сен 2018, 12:21
Следующие пакеты будут удалены для обновления остальных:
................................................................
viber-7.0.0.1035-4-rosa2016.1.x86_64
(из-за отсутствия libqgsttools_p.so.1()(64bit)) (y/N)

Как решить эту проблему, т.е. где взять этот libqgsttools_p.so.1()(64bit) ?
Заменил архив с обновлениями.
Там есть viber, который не должен конфликтовать.
Ну и небольшие обновления plasma5, которые были с момента
публикации предыдущего архива.
Там совсем мало, вроде только plasma5-pulseaudio обновился.
https://yadi.sk/d/zu9taJjgujEa0w
З.Ы.
Если несложно, можно не так сильно цитировать предыдущее сообщение.
Достаточно одной - двух строк на актуальную тему.
А то аж глаза режет такой большой объём (в данном случае моего сообщения.)

Неофициальная сборка новой plasma5

Добавлено: 28 сен 2018, 17:55
Kelpee
VictorR2007 писал(а):
28 сен 2018, 17:45
Как всегда, напоминаю, что работу отдельных приложений нужно обсуждать в отдельных темах.
Так что не ленитесь их заводить.:)
Как я понял, plasma5-browser-integration работает только с Плазмой с версией от 5.13.x (Неофициальная сборка новой plasma5).
А в Росе Плазма 5.12.x (Официальная сборка).

И честно не знаю: можно ли заводить тему на форуме о том, чего как бы официально нет? :)

Неофициальная сборка новой plasma5

Добавлено: 28 сен 2018, 17:59
VictorR2007
Kelpee писал(а):
28 сен 2018, 17:55
И честно не знаю: можно ли заводить тему на форуме о том, чего как бы официально нет? :)
Тут столько тем было о том, чего нет. Просто флудильня получалась.
А эта вполне законная.
Как появится в официальных репах, а у нас уже всё обговорено.:)

Неофициальная сборка новой plasma5

Добавлено: 29 сен 2018, 13:52
Kelpee
Заметил один недостаток в последней сборке Плазмы.
После перезагрузки отключаются эффекты рабочего стола. Например полупрозрачность окон при перетаскивании.
Когда перезагрузил компьютер - все эффекты отключены. Захожу: Параметры системы - Экран - Обеспечение эффектов. И переключаю на другой любой движок (например: было OpenGL 3.1 - я переключаю на OpenGL 2.0) и эффекты опять работают. И так до следующей перезагрузки.
На всякий случай моя проба: https://linux-hardware.org/?probe=196d23a8fa

Неофициальная сборка новой plasma5

Добавлено: 29 сен 2018, 14:58
Kelpee
Ну за 8 лет много воды утекло...
Сейчас компания AMD продвигает открытые драйвера (в моем случае AMDGPU, который находится в ядре, благодаря этому нет проблем со сменой ядер и т.д.). У NVIDIA драйвер закрытый. Как я читал, бывает много проблем после обновления ядра.
Что я хотел сказать - драйвер от AMD совершенно не то что было 8 лет назад. Советую обратить внимание на видеокарты от этой компании.
В данном случае - это лично мое мнение.

Неофициальная сборка новой plasma5

Добавлено: 29 сен 2018, 15:29
VictorR2007
Ох, как я не люблю такие отступления темах, а сам написал про дрова.
Ведь отлично знаю, что такие слова сразу вызывают полемику.
Почистил своё сообщение.
По теме.
А включены ли эффекты вообще.
Вот тут на картинке.
Если включены, нужно посмотреть под новым пользователем.
А то может стоит конфиги почистить после большого обновления.

Неофициальная сборка новой plasma5

Добавлено: 29 сен 2018, 17:44
Kelpee
Да, как говорится - слона то я и не заметил. Действительно не стояла галочка напротив "Включить графические эффекты при входе в систему".
Просто смутило возобновление работы эффектов при изменении "движка".
Спасибо за помощь!

Неофициальная сборка новой plasma5

Добавлено: 05 окт 2018, 01:00
adeptru
Здравствуйте.
Наверное, я туплю чего-то: скачал архив, распаковал, сделал и добавил источник из этой папки, а при urpmi --auto-update просто пишет, что источник обновлен, а ставить из него не ставит :(
Подскажите, пожалуйста, чего не так делаю?

Неофициальная сборка новой plasma5

Добавлено: 05 окт 2018, 01:44
VictorR2007
adeptru писал(а):
05 окт 2018, 01:00
а при urpmi --auto-update просто пишет, что источник обновлен, а ставить из него не ставит
А что написано в файле /etc/urpmi/urpmi.cfg
Можно сюда текст приложить.

Неофициальная сборка новой plasma5

Добавлено: 05 окт 2018, 09:39
Zeffanyx
adeptru писал(а):
05 окт 2018, 01:00
Здравствуйте.
Наверное, я туплю чего-то: скачал архив, распаковал, сделал и добавил источник из этой папки, а при urpmi --auto-update просто пишет, что источник обновлен, а ставить из него не ставит :(
Подскажите, пожалуйста, чего не так делаю?
Я сделал точно также, но у меня всё обновилось, правда с предварительным удалением некоторых пакетов (qtcurve-qt5, qt-creator). Вы точно правильно подключили источник?

Неофициальная сборка новой plasma5

Добавлено: 05 окт 2018, 11:06
adeptru
VictorR2007 писал(а):
05 окт 2018, 01:44
adeptru писал(а):
05 окт 2018, 01:00
а при urpmi --auto-update просто пишет, что источник обновлен, а ставить из него не ставит
А что написано в файле /etc/urpmi/urpmi.cfg
Можно сюда текст приложить.

Код: Выделить всё

{
}

Plasma5 /home/adeptru/plasma {
}

Main http://mirror.rosalab.ru/rosa/rosa2016.1/repository/x86_64/media/main/release {
  key-ids: 16a853e7
}

Main\ Updates http://mirror.rosalab.ru/rosa/rosa2016.1/repository/x86_64/media/main/updates {
  update
}

Main\ Testing http://mirror.rosalab.ru/rosa/rosa2016.1/repository/x86_64/media/main/testing {
  ignore
  update
}

Main32 http://mirror.rosalab.ru/rosa/rosa2016.1/repository/i586/media/main/release {
}

Main32\ Updates http://mirror.rosalab.ru/rosa/rosa2016.1/repository/i586/media/main/updates {
  update
}

Main32\ Testing http://mirror.rosalab.ru/rosa/rosa2016.1/repository/i586/media/main/testing {
  ignore
  update
}

Contrib http://mirror.rosalab.ru/rosa/rosa2016.1/repository/x86_64/media/contrib/release {
}

Contrib\ Updates http://mirror.rosalab.ru/rosa/rosa2016.1/repository/x86_64/media/contrib/updates {
  update
}

Contrib\ Testing http://mirror.rosalab.ru/rosa/rosa2016.1/repository/x86_64/media/contrib/testing {
  ignore
  update
}

Non-free http://mirror.rosalab.ru/rosa/rosa2016.1/repository/x86_64/media/non-free/release {
  key-ids: 16a853e7
}

Non-free\ Updates http://mirror.rosalab.ru/rosa/rosa2016.1/repository/x86_64/media/non-free/updates {
  key-ids: 16a853e7
  update
}

Non-free\ Testing http://mirror.rosalab.ru/rosa/rosa2016.1/repository/x86_64/media/non-free/testing {
  ignore
  update
}

Non-free32 http://mirror.rosalab.ru/rosa/rosa2016.1/repository/i586/media/non-free/release {
  key-ids: 16a853e7
}

Non-free32\ Updates http://mirror.rosalab.ru/rosa/rosa2016.1/repository/i586/media/non-free/updates {
  key-ids: 16a853e7
  update
}

Non-free32\ Testing http://mirror.rosalab.ru/rosa/rosa2016.1/repository/i586/media/non-free/testing {
  ignore
  update
}

Restricted http://mirror.rosalab.ru/rosa/rosa2016.1/repository/x86_64/media/restricted/release {
  key-ids: 16a853e7
}

Restricted\ Updates http://mirror.rosalab.ru/rosa/rosa2016.1/repository/x86_64/media/restricted/updates {
  key-ids: 16a853e7
  update
}

Restricted\ Testing http://mirror.rosalab.ru/rosa/rosa2016.1/repository/x86_64/media/restricted/testing {
  ignore
  update
}

Restricted32 http://mirror.rosalab.ru/rosa/rosa2016.1/repository/i586/media/restricted/release {
  key-ids: 16a853e7
}

Restricted32\ Updates http://mirror.rosalab.ru/rosa/rosa2016.1/repository/i586/media/restricted/updates {
  key-ids: 16a853e7
  update
}

Restricted32\ Testing http://mirror.rosalab.ru/rosa/rosa2016.1/repository/i586/media/restricted/testing {
  ignore
  update
}

kernel_4.18 http://abf-downloads.rosalinux.ru/kernels_stable_personal/repository/rosa2016.1/x86_64/kernel_4_18/release {
}

Неофициальная сборка новой plasma5

Добавлено: 05 окт 2018, 19:03
VictorR2007
А как подключали?
Командой

Код: Выделить всё

urpmi.addmedia Plasma5 /home/adeptru/plasma
А точно название папки plasma?
Я вроде делал название plasma5-5.13.90.
Уже точно не помню, а проверить не могу сейчас.

Неофициальная сборка новой plasma5

Добавлено: 05 окт 2018, 21:49
adeptru
VictorR2007 писал(а):
05 окт 2018, 19:03
А как подключали?
Командой

Код: Выделить всё

urpmi.addmedia Plasma5 /home/adeptru/plasma
А точно название папки plasma?
Я вроде делал название plasma5-5.13.90.
Уже точно не помню, а проверить не могу сейчас.
...да, именно так и подключал; да, Вы папку не так называли - это уже я сам для удобства распакованный вариант переименовывал...
Только что установил (вот, буквально две минуты как перезагрузился), правда нервов мне эта процедура съела массу: приходилось и systemd вручную удалять, и кучу пакетов из обновления вручную пропускать (в основном из libreoffice), и пол дня еще чего... У меня подозрения, что это из-за того, что Система новая - суток еще нету как переустановил, не обновлял, а сразу же ядро новое и Плазму захотел впиндюрить, может, потому оно всё и законфликтовало? ...Короче, справился с горем пополам :)
Спасибо.

Неофициальная сборка новой plasma5

Добавлено: 05 окт 2018, 23:58
Zeffanyx
Я попользовался пару дней и всё таки откатился (urpm-reposync). Мне не понравилось, что из-за новой плазмы многое никак теперь не установить, так как программы в основных репозиториях Росы теперь зависят от "пакетов, старее уже установленных".
Жду полноценный релиз R11. Кстати, он будет на прежней платформе 2016 или уже на новой 2018?

Неофициальная сборка новой plasma5

Добавлено: 06 окт 2018, 01:18
VictorR2007
Zeffanyx писал(а):
05 окт 2018, 23:58
Кстати, он будет на прежней платформе 2016 или уже на новой 2018?
На 2016.

Неофициальная сборка новой plasma5

Добавлено: 06 окт 2018, 01:25
VictorR2007
adeptru писал(а):
05 окт 2018, 21:49
приходилось и systemd вручную удалять, и кучу пакетов из обновления вручную пропускать (в основном из libreoffice), и пол дня еще чего..
Очень странно. Даже не знаю, что и сказать.
Должно устанавливаться с пол-пинка.
Просто соглашаться со всем, и установится на раз.
А про syatemd, так это вообще непонятно, что у вас там.
А может совсем уж старый образ был?
Я устанавливаю всегда с этого образа с ядром 4.15 https://abf.rosalinux.ru/platforms/rosa ... ists/21800

Неофициальная сборка новой plasma5

Добавлено: 06 окт 2018, 01:34
VictorR2007
Zeffanyx писал(а):
05 окт 2018, 09:39
правда с предварительным удалением некоторых пакетов (qtcurve-qt5, qt-creator).

Пакет qt5-style-qtcurve удалился из-за того, что там устанавливалась новая версия 1.9, а вот про qt-creator стоило
сообщить, чтобы я его пересобрал. Самому то не нужен он, так и не догадался его пересобрать с новым QT5.
Сейчас добавил qt-creator, пересобранный с новым Qt5 во второе сообщение темы.
https://yadi.sk/d/AykIR39EAzH4vQ

Неофициальная сборка новой plasma5

Добавлено: 06 окт 2018, 13:48
adeptru
VictorR2007 писал(а):
06 окт 2018, 01:25
adeptru писал(а):
05 окт 2018, 21:49
приходилось и systemd вручную удалять, и кучу пакетов из обновления вручную пропускать (в основном из libreoffice), и пол дня еще чего..
Очень странно. Даже не знаю, что и сказать.
Должно устанавливаться с пол-пинка.
Просто соглашаться со всем, и установится на раз.
А про syatemd, так это вообще непонятно, что у вас там.
А может совсем уж старый образ был?
Я устанавливаю всегда с этого образа с ядром 4.15 https://abf.rosalinux.ru/platforms/rosa ... ists/21800
...образ только скачал перед установкой (с 4.9 ядром) - из wiki, официальный второй релиз ROSA c Plasma 5
несколько раз за день (три раза) требовал от меня (установщик) скачать по гигу обновлений, а вот там при установке и начинались эти самые "выкрутасы"...

Неофициальная сборка новой plasma5

Добавлено: 06 окт 2018, 18:02
Kelpee
Лично у меня никаких проблем с установкой новой плазмы не возникло.
Установил систему с ядром 4.9
Полностью обновил.
Установил последнее ядро 4.18.x
Для моей карты Radeon 290x активировал драйвер AMDGPU (не думаю, что это важно)
Подключил источник с новой плазмой. Установил плазму.
Перезагрузился и все работает.

Неофициальная сборка новой plasma5

Добавлено: 09 окт 2018, 19:02
ans
Глянем в будущее, на версию Plasma 5.14 :)

Неофициальная сборка новой plasma5

Добавлено: 09 окт 2018, 19:34
VictorR2007
ans писал(а):
09 окт 2018, 19:02
Глянем в будущее, на версию Plasma 5.14 :)
Конечно глянем.
Только пока смогу выкладывать отдельными партиями как обновление к последнему выложенному архиву.
У меня пока сложности с трафиком, так как сейчас не дома, и нужно будет экономить до конца месяца.
Сначала обновлю plasma5, а потом как раз подойдёт frameworks 5.51.0
З.Ы.
Но там почти нет изменений относительно версии 5.13.90.
Даже исправлений почти не было с тех пор в этой ветке.
Может совсем немного в kwin.
Но всё равно соберу.

Неофициальная сборка новой plasma5

Добавлено: 09 окт 2018, 19:38
ans
VictorR2007 писал(а):
09 окт 2018, 19:34
Только пока смогу выкладывать отдельными партиями как обновление к последнему выложенному архиву.
А откуда обновляться?

Неофициальная сборка новой plasma5

Добавлено: 09 окт 2018, 21:33
VictorR2007
ans писал(а):
09 окт 2018, 19:38
А откуда обновляться?
Ещё не собрал. Надеюсь к утру смогу собрать, и тогда выложу, если успею.
Если не успею, то завтра выложу.
Нужно ещё проверить, чтобы везде был перевод.

Неофициальная сборка новой plasma5

Добавлено: 09 окт 2018, 22:34
Kelpee
ans писал(а):
09 окт 2018, 19:02
Глянем в будущее, на версию Plasma 5.14 :)
Тоже не откажусь в будущее заглянуть. :)

Неофициальная сборка новой plasma5

Добавлено: 10 окт 2018, 04:22
VictorR2007
ans писал(а):
09 окт 2018, 19:38
А откуда обновляться?
Это обновление к ранее выложенной plasma5-5.13.90, ссылка на которую во втором сообщении.
Без него оно просто не установится.
Обновление plasma5-5.14.0 идёт как дополнение к plasma5-5.13.90.
Просто из-за трафика не могу залить пока простую замену, чтобы удалить старый источник, и подключить новый.
Помимо plasma5-5.14.0, в архиве последняя plasma5-konsole и plasma5-kwrite.
И обновлён музыкальный проигрыватель elisa.
Ссылка на обновление https://yadi.sk/d/sJdsp1B8Wb5HjA

Неофициальная сборка новой plasma5

Добавлено: 10 окт 2018, 11:40
Zeffanyx
VictorR2007 писал(а):
10 окт 2018, 04:22
ans писал(а):
09 окт 2018, 19:38
А откуда обновляться?
Это обновление к ранее выложенной plasma5-5.13.90, ссылка на которую во втором сообщении.
Без него оно просто не установится.
Обновление plasma5-5.14.0 идёт как дополнение к plasma5-5.13.90.
Просто из-за трафика не могу залить пока простую замену, чтобы удалить старый источник, и подключить новый.
Помимо plasma5-5.14.0, в архиве последняя plasma5-konsole и plasma5-kwrite.
И обновлён музыкальный проигрыватель elisa.
Ссылка на обновление https://yadi.sk/d/sJdsp1B8Wb5HjA
Какая версия плазмы будет в R11, и когда примерно её ждать?

Неофициальная сборка новой plasma5

Добавлено: 10 окт 2018, 12:43
Barmalei
Zeffanyx писал(а):
10 окт 2018, 11:40
Какая версия плазмы будет в R11, и когда примерно её ждать?
Обычное обновление и немного свежего софта. Все новое будет когда будет новая платформа отличная от 2016.1

Неофициальная сборка новой plasma5

Добавлено: 10 окт 2018, 12:58
adeptru
Уважаемый VictorR2007, а как можно вернуть klook в Dolphin (чтобы кнопка предварительного просмотра на файлах вновь появилась)?

Неофициальная сборка новой plasma5

Добавлено: 10 окт 2018, 13:14
Zeffanyx
Barmalei писал(а):
10 окт 2018, 12:43
Zeffanyx писал(а):
10 окт 2018, 11:40
Какая версия плазмы будет в R11, и когда примерно её ждать?
Обычное обновление и немного свежего софта. Все новое будет когда будет новая платформа отличная от 2016.1
Plasma 5.13.90 или 5.14 попадёт в R11 или нет?

Неофициальная сборка новой plasma5

Добавлено: 10 окт 2018, 18:44
VictorR2007
adeptru писал(а):
10 окт 2018, 12:58
Уважаемый VictorR2007, а как можно вернуть klook в Dolphin (чтобы кнопка предварительного просмотра на файлах вновь появилась)?
Я это не смогу сделать. Ждите, когда обновят в оффрепах.
А пока можно удалить этот Dolphin, и установить старый.
Если будете это делать, подскажу как это можно сделать.

Неофициальная сборка новой plasma5

Добавлено: 10 окт 2018, 18:46
VictorR2007
Zeffanyx писал(а):
10 окт 2018, 13:14
Plasma 5.13.90 или 5.14 попадёт в R11 или нет?
Будет Plasma 5.12.х.

Неофициальная сборка новой plasma5

Добавлено: 10 окт 2018, 19:28
adeptru
VictorR2007 писал(а):
10 окт 2018, 18:44
adeptru писал(а):
10 окт 2018, 12:58
Уважаемый VictorR2007, а как можно вернуть klook в Dolphin (чтобы кнопка предварительного просмотра на файлах вновь появилась)?
Я это не смогу сделать. Ждите, когда обновят в оффрепах.
А пока можно удалить этот Dolphin, и установить старый.
Если будете это делать, подскажу как это можно сделать.
Подскажите, пожалуйста... на всякий случай :)

Неофициальная сборка новой plasma5

Добавлено: 10 окт 2018, 20:29
VictorR2007
adeptru писал(а):
10 окт 2018, 19:28
Подскажите, пожалуйста... на всякий случай
Отключите источники с plasma5, потом через «Установка и удаление программ»
удалите пакеты
plasma5-dolphin,
lib64dolphinprivate5,
lib64dolphinvcs5.
Потом установите пакет plasma5-dolphin.
Так-же потом удалите эти пакеты из источников plasma5, и потом выполнить команду, типа такой, со своим путём.

Код: Выделить всё

genhdlist2 /home/victor/plasma5-5.14.0/
для обоих источников, откуда удалили пакеты plasma5-dolphin.
И потом подключите и обновите источники.

Неофициальная сборка новой plasma5

Добавлено: 11 окт 2018, 00:13
Kelpee
VictorR2007 писал(а):
10 окт 2018, 04:22
Ссылка на обновление https://yadi.sk/d/sJdsp1B8Wb5HjA
Благодарю!

Неофициальная сборка новой plasma5

Добавлено: 18 окт 2018, 04:09
VictorR2007
Это обновление к ранее выложенным источникам.
В обновлении frameworks 5.51.0.
Обновление идёт как дополнение к plasma5-5.13.90.
Ссылка на обновление https://yadi.sk/d/STKpT4zf1b3oxA

Неофициальная сборка новой plasma5

Добавлено: 18 окт 2018, 07:19
Kelpee
VictorR2007 писал(а):
18 окт 2018, 04:09
Ссылка на обновление https://yadi.sk/d/STKpT4zf1b3oxA
Спасибо!

Неофициальная сборка новой plasma5

Добавлено: 18 окт 2018, 10:40
ans
VictorR2007 писал(а):
18 окт 2018, 04:09
В обновлении frameworks 5.51.0.
Screenshot_20181018_123722.png

Неофициальная сборка новой plasma5

Добавлено: 18 окт 2018, 21:53
VictorR2007
Zeffanyx писал(а):
10 окт 2018, 13:14
Plasma 5.13.90 или 5.14 попадёт в R11 или нет?
Pulfer начал собирать Plasma-5.13.5.
Пока в kde5_backports_personal.
http://abf-downloads.rosalinux.ru/kde5_ ... n/release/

Неофициальная сборка новой plasma5

Добавлено: 02 ноя 2018, 12:52
Kelpee
Что-то давно Plasma 5.14 не обновлялась.
6 ноября Plasma 5.14.3 вышла, а у нас только 5.14.0 :(
Ждем обновлений.

Неофициальная сборка новой plasma5

Добавлено: 11 ноя 2018, 14:45
VictorR2007
Собрал обновление https://yadi.sk/d/gX-Z1ccMDjyAbg
В архиве frameworks-5.52 и plasma-5.14.80.
Plasma5 хотя и пишет, что версия 5.14.0,
но по факту она обновлена до версии 4.14.80 на вчерашнее состояние.
Я занижаю версию, чтобы не пересобирать все пакеты, а только те,
в которые в гите попадают изменения.
Теперь должны работать принтеры HP.
Я форкнул проекты python у termim (спасибо ему), которые он обсуждал тут
viewtopic.php?f=40&t=9334&p=97661&hilit ... sip#p97661
и добавил их в архив.
Этот источник идёт как замена всем предыдущим источникам.
Можно старые источники удалить, а этот добавить.

Неофициальная сборка новой plasma5

Добавлено: 11 ноя 2018, 15:41
VictorR2007
З.Ы.
Удалось починить отображение перевода для настройки мышки и сенсорной панели
на движках libinput.
Для мышки настройка на иксах, а для сенсорной панели этот движок виден в сеансе wayland.

Неофициальная сборка новой plasma5

Добавлено: 12 ноя 2018, 01:58
ans
VictorR2007 писал(а):
11 ноя 2018, 14:45
Собрал обновление https://yadi.sk/d/gX-Z1ccMDjyAbg
В архиве frameworks-5.52 и plasma-5.14.80.
........
Этот источник идёт как замена всем предыдущим источникам.
Можно старые источники удалить, а этот добавить.

Код: Выделить всё

Хоть часть пакетов и могла быть установлена, произошли ошибки.
Следующие пакеты будут удалены для обновления остальных:
lib64qgsttools_p1-5.9.4-1-rosa2016.1.x86_64
 (из-за отсутствия libQt5Multimedia.so.5(Qt_5_PRIVATE_API)(64bit))
qtcurve-gtk2-1.8.18-2.20170506.1-rosa2016.1.x86_64
 (из-за неудовлетворённости lib64qtcurve-gtk2 == 1.8.18-2.20170506.1:2016.1)
viber-7.0.0.1035-4-rosa2016.1.x86_64
 (из-за отсутствия libqgsttools_p.so.1()(64bit))
Система перезагрузилась. Но как будет влиять отсутствие данных пакетов не понятно.
Где их найти?

Код: Выделить всё

# urpmi libQt5Multimedia.so.5
Пакеты libpng16-1.6.28-3-rosa2016.1.i586, libc6-2.24-8-rosa2016.1.x86_64, libgcc1-5.5.0_2017.10-2-rosa2016.1.x86_64, libcups2-2.2.1-2-rosa2016.1.i586, libgl1-18.2.4-1-rosa2016.1.i586, libz1-1.2.8-12-rosa2016.1.x86_64, libjpeg8-2.0.0-2-rosa2016.1.i586, libstdc++6-5.5.0_2017.10-2-rosa2016.1.x86_64, libqt5network5-5.9.4-2-rosa2016.1.i586 уже установлены
Не удаётся установить следующие пакеты, т.к. они зависят от пакетов,
более старых, чем установленные:
libqt5gui5-5.9.4-2
libqt5multimedia5-5.9.4-1
Продолжить установку? (Y/n) y
Хоть часть пакетов и могла быть установлена, произошли ошибки.
Не удаётся установить следующие пакеты, т.к. они зависят от пакетов,
более старых, чем установленные:
libqt5gui5-5.9.4-2
libqt5multimedia5-5.9.4-1
Продолжить установку?

Неофициальная сборка новой plasma5

Добавлено: 12 ноя 2018, 12:23
VictorR2007
Они не нужны. Это просто оповещение при обновлении.
viber нужно снова установить, если он удалился.
Странно с ним вышло.
Про qtcurve пишет, так как он обновился до новой версии.
Он давно собран, но я его из архивов удалая обычно,
перед тем как выложить здесь, чтобы не сбивало с толку.
А сейчас забыл.
Сейчас выброшу их, и заменю архив.

По второму выводу.
Команда «urpmi libQt5Multimedia.so.5» неправильная, нужно писать

Код: Выделить всё

urpmi lib64qt5multimedia5

Неофициальная сборка новой plasma5

Добавлено: 12 ноя 2018, 18:34
Kelpee
VictorR2007 писал(а):
11 ноя 2018, 14:45
Собрал обновление https://yadi.sk/d/gX-Z1ccMDjyAbg

Этот источник идёт как замена всем предыдущим источникам.
Можно старые источники удалить, а этот добавить.
Спасибо!

Неофициальная сборка новой plasma5

Добавлено: 15 ноя 2018, 17:18
ans
Почему-то перестали отображаться значки на рабочем столе :(

Неофициальная сборка новой plasma5

Добавлено: 15 ноя 2018, 19:20
VictorR2007
ans писал(а):
15 ноя 2018, 17:18
Почему-то перестали отображаться значки на рабочем столе :(
У меня нет, не перестали.

Неофициальная сборка новой plasma5

Добавлено: 16 ноя 2018, 05:37
ans
VictorR2007 писал(а):
15 ноя 2018, 19:20
ans писал(а):
15 ноя 2018, 17:18
Почему-то перестали отображаться значки на рабочем столе :(
У меня нет, не перестали.
У меня так:
16.jpg

Неофициальная сборка новой plasma5

Добавлено: 16 ноя 2018, 07:03
VictorR2007
Наверное установлен тип комнаты «Рабочий стол по умолчанию».
Замени на «Просмотр папки».

Неофициальная сборка новой plasma5

Добавлено: 16 ноя 2018, 14:19
ans
VictorR2007 писал(а):
16 ноя 2018, 07:03
Наверное установлен тип комнаты «Рабочий стол по умолчанию».
Замени на «Просмотр папки».
Пробовал уже. Эта настройка заблокирована, открыл через ПУТЬ->Указать расположение, и тогда значки появились.

Неофициальная сборка новой plasma5

Добавлено: 16 ноя 2018, 16:08
VictorR2007
ans писал(а):
16 ноя 2018, 14:19
Пробовал уже. Эта настройка заблокирована,
Ну надо было в контекстном меню сначала «Разблокировать виджетоы»,
и кнопка стала бы активной.

Неофициальная сборка новой plasma5

Добавлено: 21 ноя 2018, 20:08
VictorR2007
Собрал обновления.
Там последние изменения в гит.
Исправления утечки памяти в нескольких пакетах.
Идёт как замена к предыдущему архиву с пакетами.
Сейчас там тоже заменю ссылку.
https://yadi.sk/d/QgeQHIfbIziYJA

Неофициальная сборка новой plasma5

Добавлено: 22 ноя 2018, 23:10
Kelpee
В новой плазме 5.14.x из меню не работает программа Rosa Image Writer. При попытке открыть файл образа вылазит ошибка со следующим сообщением: "Ошибка создания вспомогательного процесса ввода/вывода. Не удалось создать сокет для запуска вспомогательного процесса ввода-вывода для протокола «file»."
При запуске из консоли командой "sudo rosa-imagewriter" все работает нормально.

Неофициальная сборка новой plasma5

Добавлено: 23 ноя 2018, 00:15
VictorR2007
Kelpee писал(а):
22 ноя 2018, 23:10
При запуске из консоли командой "sudo rosa-imagewriter" все работает нормально.
Да, и ещё при открытии файла образа через контекстное меню «Открыть с помощью - Rosa Image Writer»

Неофициальная сборка новой plasma5

Добавлено: 23 ноя 2018, 17:03
VictorR2007
Обновил некоторые пакеты.
Не очень большое обновление.
Идёт как замена к предыдущему архиву с пакетами.
Сейчас там тоже заменю ссылку.
https://yadi.sk/d/QgeQHIfbIziYJA

Неофициальная сборка новой plasma5

Добавлено: 24 ноя 2018, 16:37
ans
VictorR2007 писал(а):
23 ноя 2018, 17:03
Обновил некоторые пакеты.
Не очень большое обновление.
Идёт как замена к предыдущему архиву с пакетами.
Сейчас там тоже заменю ссылку.
https://yadi.sk/d/QgeQHIfbIziYJA
Подготовка... #################################################################################################################################
Установка не удалась: файл /usr/share/locale/ca/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/ca@valencia/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/cs/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/da/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/de/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/en_GB/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/es/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/eu/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/fi/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/fr/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/gl/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/id/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/it/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/ja/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/ko/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/nl/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/nn/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/pl/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/pt/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/pt_BR/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/ru/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/sk/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/sv/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/uk/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
файл /usr/share/locale/zh_CN/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch

Неофициальная сборка новой plasma5

Добавлено: 24 ноя 2018, 17:25
VictorR2007
ans писал(а):
24 ноя 2018, 16:37

Установка не удалась: файл /usr/share/locale/ca/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-5.14.0-1.x86_64 конфликтует с файлом из пакета kdecoration-i18n-5.13.5-1.noarch
Нужно дать команду

Код: Выделить всё

rpm -e --nodeps kdecoration-i18n
а потом снова

Код: Выделить всё

urpmi --auto-update
Пересоберу пакет kdecoration, чтобы нормально обновлялся с версии 5.13.5,
и заменю архив.
З.Ы.
Заменил https://yadi.sk/d/QxBSkcMPKeg6Rg

Неофициальная сборка новой plasma5

Добавлено: 25 ноя 2018, 06:15
VictorR2007
Вдруг кому интересно, собрал себе в репы модули обоев.
Видео обои, список воспроизведения, перелистывание и слайд-шоу с эффектами.
Помимо обоев, их можно включить как фон в блокировке экрана.
Пакеты
plasma5-wallpaper-effectslideshow
plasma5-wallpaper-coverflow
plasma5-wallpaper-videowallpaper
plasma5-wallpaper-videoplaylist

Неофициальная сборка новой plasma5

Добавлено: 25 ноя 2018, 08:04
ans
VictorR2007 писал(а):
24 ноя 2018, 17:25
Заменил https://yadi.sk/d/QgeQHIfbIziYJA
Для удовлетворения зависимостей будут установлены следующие пакеты:
Пакет Версия Релиз Dist DEpoch Платформа
(источник «p»)
kdecoration-i18n 5.14.0 2 rosa 2016.1 noarch
lib64kdecorations2_5 5.14.0 2 rosa 2016.1 x86_64
lib64kdecorations2private6 5.14.0 2 rosa 2016.1 x86_64
Будет использовано 29КБ дополнительного дискового пространства.
Будет загружено 61КБ пакетов.
Установить 3 пакетов? (Y/n) y


устанавливается lib64kdecorations2_5-5.14.0-2-rosa2016.1.x86_64.rpm kdecoration-i18n-5.14.0-2-rosa2016.1.noarch.rpm lib64kdecorations2private6-5.14.0-2-rosa2016.1.x86_64.rpm из /home/sp/ÐагÑÑзки/rpm/plasma5-5.14.81
Подготовка... ###############################################################################################################
1/3: lib64kdecorations2private6
###############################################################################################################
2/3: kdecoration-i18n ###############################################################################################################
3/3: lib64kdecorations2_5 ###############################################################################################################
1/2: удаляется lib64kdecorations2_5-5.14.0-1.x86_64
###############################################################################################################
2/2: удаляется lib64kdecorations2private6-5.14.0-1.x86_64
###############################################################################################################
Без вопросов. Работает - просто сказка. Спасибо. :good:

P.S. Росу установил заново из образа Plasma 21800

Неофициальная сборка новой plasma5

Добавлено: 25 ноя 2018, 08:28
ans
VictorR2007 писал(а):
25 ноя 2018, 06:15
Вдруг кому интересно, собрал себе в репы модули обоев.
Видео обои, список воспроизведения, перелистывание и слайд-шоу с эффектами.
Помимо обоев, их можно включить как фон в блокировке экрана.
Пакеты
plasma5-wallpaper-effectslideshow
plasma5-wallpaper-coverflow
plasma5-wallpaper-videowallpaper
plasma5-wallpaper-videoplaylist
Космос! :good:
только для видео нужно ещё qtmultimedia установить.

Неофициальная сборка новой plasma5

Добавлено: 26 ноя 2018, 00:22
VictorR2007
В последних обновлениях была проблема.
Если пытаться открыть приложения, сгруппированные по имени на панели задач, то список не показывается (фотка),
и если ткнуть в язычок, то плазма падает.
Нашёл проблему https://cgit.kde.org/plasma-desktop.git ... a7da935a5c
и пересобрал, откатив этот патч.
Заодно обновил все пакеты до версии 5.14.3.
Так же добавлены пакеты, описанные здесь viewtopic.php?p=98019#p98019


Архив с обновлениями plasma-5.14.3 https://yadi.sk/d/QxBSkcMPKeg6Rg

Неофициальная сборка новой plasma5

Добавлено: 26 ноя 2018, 06:11
ans
VictorR2007 писал(а):
26 ноя 2018, 00:22
Заодно обновил все пакеты до версии 5.14.3.
А тот, который был 5.14.81, он этим заменяется?
Или я что-то не понял.

Неофициальная сборка новой plasma5

Добавлено: 26 ноя 2018, 07:00
VictorR2007
ans писал(а):
26 ноя 2018, 06:11
А тот, который был 5.14.81, он этим заменяется?
Ага.

Неофициальная сборка новой plasma5

Добавлено: 26 ноя 2018, 12:52
adeptru
Всегда, в первую очередь скачивал все обновления, но в последнее время перестал: то, что Дельфин теряет возможность предпросмотра - это полбеды и перетерпеть можно, а вот то, что bomi перестает запускаться - уже ощутимо (другие плееры я просто поудалял) ))

Неофициальная сборка новой plasma5

Добавлено: 26 ноя 2018, 13:51
VictorR2007
adeptru писал(а):
26 ноя 2018, 12:52
что bomi перестает запускаться - уже ощутимо (другие плееры я просто поудалял) ))
bomi автор забросил.
И теперь он не работает с новыми версиями qt5.
На мой взгляд, qmplay2 получше будет.
И в плане загрузки системы, и в плане просмотра и возможности скачивания с youtube.
Есть интернет радио, запуск последнего воспроизводимого файла с момента закрытия проигрывателя и др.
Гибкий в настройке и выборе движка вывода видео и приоритетов декодеров.

Неофициальная сборка новой plasma5

Добавлено: 26 ноя 2018, 14:59
adeptru
VictorR2007 писал(а):
26 ноя 2018, 13:51
adeptru писал(а):
26 ноя 2018, 12:52
что bomi перестает запускаться - уже ощутимо (другие плееры я просто поудалял) ))
bomi автор забросил.
И теперь он не работает с новыми версиями qt5.
На мой взгляд, qmplay2 получше будет.
И в плане загрузки системы, и в плане просмотра и возможности скачивания с youtube.
Есть интернет радио, запуск последнего воспроизводимого файла с момента закрытия проигрывателя и др.
Гибкий в настройке и выборе движка вывода видео и приоритетов декодеров.
Жаль, конечно, что автор забросил...
Спасибо за подсказку - прямо сейчас попробую!

Неофициальная сборка новой plasma5

Добавлено: 26 ноя 2018, 22:48
VictorR2007
VictorR2007 писал(а):
25 ноя 2018, 06:15
Вдруг кому интересно, собрал себе в репы модули обоев.
Видео обои, список воспроизведения, перелистывание и слайд-шоу с эффектами.
Помимо обоев, их можно включить как фон в блокировке экрана.
Пакеты
plasma5-wallpaper-effectslideshow
plasma5-wallpaper-coverflow
plasma5-wallpaper-videowallpaper
plasma5-wallpaper-videoplaylist
Теперь эти пакеты доступны в официальных репах.
И плюс пакет plasma5-wallpaper-animatedhue
для изменения оттенков обоев.

Неофициальная сборка новой plasma5

Добавлено: 26 ноя 2018, 23:56
adeptru
...у меня, почему-то, все эти "прибамбасы" выбираются только для настройки блокировки экрана, а для настройки рабочего стола как были три стандартных варианта, так и остались (хотя, я эти дополнительные плагины скачивал как раз из окна настройки рабочего стола - пока их еще не было в официальных репах)!..

Неофициальная сборка новой plasma5

Добавлено: 27 ноя 2018, 00:36
VictorR2007
adeptru писал(а):
26 ноя 2018, 23:56
скачивал как раз из окна настройки рабочего стола - пока их еще не было в официальных репах)!..
Удали их, и должны появиться.
Можно удалить через настройки рабочего стола,
или удалить папку ~/.local/share/plasma/wallpapers

Неофициальная сборка новой plasma5

Добавлено: 27 ноя 2018, 12:56
adeptru
VictorR2007 писал(а):
27 ноя 2018, 00:36
adeptru писал(а):
26 ноя 2018, 23:56
скачивал как раз из окна настройки рабочего стола - пока их еще не было в официальных репах)!..
Удали их, и должны появиться.
Можно удалить через настройки рабочего стола,
или удалить папку ~/.local/share/plasma/wallpapers
Точно! Удалил папку, и сразу появились без перезапуска! Благодарю за подсказку!

Неофициальная сборка новой plasma5

Добавлено: 30 ноя 2018, 12:59
VictorR2007
Очередное обновление.
plasma-5.14.4 https://yadi.sk/d/NU1vXtG5Z-UeLA

Неофициальная сборка новой plasma5

Добавлено: 30 ноя 2018, 18:02
ans
VictorR2007 писал(а):
30 ноя 2018, 12:59
Очередное обновление.
plasma-5.14.4 https://yadi.sk/d/NU1vXtG5Z-UeLA
.............
Установка не удалась: файл /usr/share/locale/zh_CN/LC_MESSAGES/kdecoration.mo из устанавливаемого пакета kdecoration-i18n-5.14.4-1.noarch конфликтует с файлом из пакета kdecoration-5.14.0-1.x86_64
после urpme kdecoration-5.14.0-1.x86_64
установилось

Неофициальная сборка новой plasma5

Добавлено: 06 дек 2018, 09:24
ans
ans писал(а):
15 ноя 2018, 17:18
Почему-то перестали отображаться значки на рабочем столе :(
Добавлю. Такое происходит после перезагрузки на стародавних установках Росы, если подключены новые модули обоев. Если стоят стандартные - значки на столе.
А вот на свежих установках(например, с образа 23718) такого уже нет.

Неофициальная сборка новой plasma5

Добавлено: 27 дек 2018, 01:24
VictorR2007
adeptru писал(а):
26 ноя 2018, 12:52
а вот то, что bomi перестает запускаться - уже ощутимо (другие плееры я просто поудалял) ))
Pulfer починил его.
Так что обновляйте, и начнёт работать.

Неофициальная сборка новой plasma5

Добавлено: 27 дек 2018, 07:45
ans
VictorR2007 писал(а):
27 дек 2018, 01:24
adeptru писал(а):
26 ноя 2018, 12:52
а вот то, что bomi перестает запускаться - уже ощутимо (другие плееры я просто поудалял) ))
Pulfer починил его.
Так что обновляйте, и начнёт работать.
Не похоже :(

Screenshot_20181227_094028.png

Неофициальная сборка новой plasma5

Добавлено: 27 дек 2018, 09:36
VictorR2007
А bomi-0.9.11-11?
Если он, то проверь установку пакетов
qt5-qtgraphicaleffects-qml
qt5-qtquickcontrols-qml
qt5-qtquickcontrols2-qml
Должно быть так

Неофициальная сборка новой plasma5

Добавлено: 27 дек 2018, 10:15
adeptru
VictorR2007 писал(а):
27 дек 2018, 09:36
А bomi-0.9.11-11?
Если он, то проверь установку пакетов
qt5-qtgraphicaleffects-qml
qt5-qtquickcontrols-qml
qt5-qtquickcontrols2-qml
Должно быть так
Запустилось! И без допустановки этих пакетов! :Yahoo!:

Неофициальная сборка новой plasma5

Добавлено: 27 дек 2018, 11:17
ans
VictorR2007 писал(а):
27 дек 2018, 09:36
А bomi-0.9.11-11?
Только сейчас обновления прилетели, с ними и bomi-0.9.11-11.
Заработало. :)

Неофициальная сборка новой plasma5

Добавлено: 30 дек 2018, 05:39
adeptru
С Наступающим всех Росаводов!!!!
...тут, вот, прилетели обновления Plasma5, но устанавливаться не хотят - конфликтуют с уже установленными (из сборки VictorR2007)!
Подскажите, плиз, как исправить можно?

Неофициальная сборка новой plasma5

Добавлено: 30 дек 2018, 08:20
ans
adeptru писал(а):
30 дек 2018, 05:39
С Наступающим всех Росаводов!!!!
...тут, вот, прилетели обновления Plasma5, но устанавливаться не хотят - конфликтуют с уже установленными (из сборки VictorR2007)!
Подскажите, плиз, как исправить можно?
Либо откатить установленные, либо так

Неофициальная сборка новой plasma5

Добавлено: 30 дек 2018, 19:34
VictorR2007
adeptru писал(а):
30 дек 2018, 05:39
С Наступающим всех Росаводов!!!!
...тут, вот, прилетели обновления Plasma5, но устанавливаться не хотят - конфликтуют с уже установленными (из сборки VictorR2007)!
Подскажите, плиз, как исправить можно?
Нужно отключить все дополнительные источники, а потом дать команду

Код: Выделить всё

urpm-reposync
Это вернёт установку к актуальному состоянию с репозиторием, и заодно установит обновления.

Неофициальная сборка новой plasma5

Добавлено: 31 дек 2018, 07:14
adeptru
VictorR2007 писал(а):
30 дек 2018, 19:34
Нужно отключить все дополнительные источники, а потом дать команду

Код: Выделить всё

urpm-reposync
Это вернёт установку к актуальному состоянию с репозиторием, и заодно установит обновления.
Отключил локальный источник, сделал urpm-reposync, потом urpmi --auto-update - результат кот же: конфликт с уже установленными пакетами (на скрине)
Screenshot_20181231_131007.png

Неофициальная сборка новой plasma5

Добавлено: 31 дек 2018, 09:06
VictorR2007
adeptru писал(а):
31 дек 2018, 07:14
Отключил локальный источник, сделал urpm-reposync, потом urpmi --auto-update - результат кот же: конфликт с уже установленными пакетами (на скрине)
Нужно просто удалить пакет plasma5-kcm-launchfeedback

Код: Выделить всё

rpm -e --nodeps plasma5-kcm-launchfeedback
Похоже, команда urpm-reposync не сработала.
Видимо остались ещё сторонние репы, может x11_backports.
Если есть нестандартные источники, urpm-reposync не срабатывает,
и не удаляет все левые пакеты с заменой на стандартные.

Неофициальная сборка новой plasma5

Добавлено: 31 дек 2018, 10:48
adeptru
VictorR2007 писал(а):
31 дек 2018, 09:06
adeptru писал(а):
31 дек 2018, 07:14
Отключил локальный источник, сделал urpm-reposync, потом urpmi --auto-update - результат кот же: конфликт с уже установленными пакетами (на скрине)
Нужно просто удалить пакет plasma5-kcm-launchfeedback

Код: Выделить всё

rpm -e --nodeps plasma5-kcm-launchfeedback
Похоже, команда urpm-reposync не сработала.
Видимо остались ещё сторонние репы, может x11_backports.
Если есть нестандартные источники, urpm-reposync не срабатывает,
и не удаляет все левые пакеты с заменой на стандартные.
...да, отключил все Х-сы, потом удалил (как Вы выше предложили), повторил весь процесс - отлично все установилось!
Благодарю за совет!
С Наступающим!!! :)

Неофициальная сборка новой plasma5

Добавлено: 31 дек 2018, 11:07
ans
VictorR2007 писал(а):
30 дек 2018, 19:34
обновления.
Виктор, я так понял сейчас обновления актуальны из /kde5_backports_personal ?

С НАСТУПАЮЩИМ ВСЕХ!!!!

Christmas_Russian2.jpg

Неофициальная сборка новой plasma5

Добавлено: 31 дек 2018, 19:16
VictorR2007
ans писал(а):
31 дек 2018, 11:07
Виктор, я так понял сейчас обновления актуальны из /kde5_backports_personal ?
Да.
Туда сейчас Pulfer собирает обновления KDE5 до последней актуальной версии.
После проверки на QA они уйдут в основные репы.

Неофициальная сборка новой plasma5

Добавлено: 01 янв 2019, 14:54
Zeffanyx
Что-то у меня KMail не стартует:

Код: Выделить всё

kmail
qt.svg: link button-pressed-right hasn't been detected!
qt.svg: link button-pressed-bottom hasn't been detected!
qt.svg: link button-pressed hasn't been detected!
qt.svg: link button-pressed-bottomright hasn't been detected!
qt.svg: link button-pressed-top hasn't been detected!
qt.svg: link button-pressed-topright hasn't been detected!
qt.svg: link button-pressed-left hasn't been detected!
qt.svg: link button-pressed-bottomleft hasn't been detected!
qt.svg: link button-pressed-topleft hasn't been detected!
KCrash: Application 'kmail' crashing...
KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit
sock_file=/run/user/500/kdeinit5__0

[1]+  Остановлено  kmail
Система обновлена из бэкпортов kde5 и qt5.

Неофициальная сборка новой plasma5

Добавлено: 01 янв 2019, 20:16
VictorR2007
Zeffanyx писал(а):
01 янв 2019, 14:54
Что-то у меня KMail не стартует:
Система обновлена из бэкпортов kde5 и qt5.
Ещё рано с такими вопросами, при установке из этих источников.
Источник kde5 ещё не полностью собран.
А после сборки уйдёт на QA, и всё будет проверяться и лечиться.

Неофициальная сборка новой plasma5

Добавлено: 01 янв 2019, 21:10
Zeffanyx
VictorR2007 писал(а):
01 янв 2019, 20:16
Zeffanyx писал(а):
01 янв 2019, 14:54
Что-то у меня KMail не стартует:
Система обновлена из бэкпортов kde5 и qt5.
Ещё рано с такими вопросами, при установке из этих источников.
Источник kde5 ещё не полностью собран.
А после сборки уйдёт на QA, и всё будет проверяться и лечиться.
Понял, подожду.

Неофициальная сборка новой plasma5

Добавлено: 10 янв 2019, 12:57
VictorR2007
Если есть заинтересованные, собрал обновление
https://yadi.sk/d/JVGOSY8hann9qw
В архиве qt5-5.11.3, frameworks-5.54.0 и plasma5-5.14.5, хотя по факту там 5.14.80.
Ну и по мелочи кое-что.
Можно использовать как замену предыдущих сборок.

Неофициальная сборка новой plasma5

Добавлено: 10 янв 2019, 16:13
Kelpee
VictorR2007 писал(а):
10 янв 2019, 12:57
Если есть заинтересованные, собрал обновление
https://yadi.sk/d/JVGOSY8hann9qw
Спасибо. Сегодня поставлю.

Неофициальная сборка новой plasma5

Добавлено: 11 янв 2019, 09:20
ans
VictorR2007 писал(а):
10 янв 2019, 12:57
Если есть заинтересованные, собрал обновление
https://yadi.sk/d/JVGOSY8hann9qw
Конфликт
Установка не удалась: файл /usr/share/kpackage/kcms/kcm_translations/contents/ui/main.qml из устанавливаемого пакета plasma5-workspace-5.14.5-3.1.x86_64 конфликтует с файлом из пакета plasma5-desktop-5.14.4.1-5.x86_64
файл /usr/share/kpackage/kcms/kcm_translations/metadata.desktop из устанавливаемого пакета plasma5-workspace-5.14.5-3.1.x86_64 конфликтует с файлом из пакета plasma5-desktop-5.14.4.1-5.x86_64
файл /usr/share/kpackage/kcms/kcm_translations/metadata.json из устанавливаемого пакета plasma5-workspace-5.14.5-3.1.x86_64 конфликтует с файлом из пакета plasma5-desktop-5.14.4.1-5.x86_64
файл /usr/share/doc5/HTML/en/kcontrol/translations/index.cache.bz2 из устанавливаемого пакета plasma5-workspace-5.14.5-3.1.x86_64 конфликтует с файлом из пакета plasma5-desktop-5.14.4.1-5.x86_64
файл /usr/share/doc5/HTML/en/kcontrol/translations/index.docbook из устанавливаемого пакета plasma5-workspace-5.14.5-3.1.x86_64 конфликтует с файлом из пакета plasma5-desktop-5.14.4.1-5.x86_64
файл /usr/lib64/qt5/plugins/kcms/kcm_translations.so из устанавливаемого пакета plasma5-workspace-5.14.5-3.1.x86_64 конфликтует с файлом из пакета plasma5-desktop-5.14.4.1-5.x86_64
файл /usr/share/kservices5/kcm_translations.desktop из устанавливаемого пакета plasma5-workspace-5.14.5-3.1.x86_64 конфликтует с файлом из пакета plasma5-desktop-5.14.4.1-5.x86_64
файл /usr/share/locale/kf5/ru/LC_MESSAGES/kcm_translations.mo из устанавливаемого пакета plasma5-workspace-5.14.5-3.1.x86_64 конфликтует с файлом из пакета plasma5-desktop-5.14.4.1-5.x86_64
Хоть часть пакетов и могла быть установлена, произошли ошибки.
Следующие пакеты будут удалены для обновления остальных:
hplip-3.16.11-8-rosa2016.1.x86_64
(из-за отсутствия hplip-gui,
из-за неудовлетворённости hplip-compat-libs == 3.16.11-8)
hplip-compat-libs-3.16.11-8-rosa2016.1.x86_64
(из-за неудовлетворённости hplip == 3.16.11-8)
hplip-gui-3.16.11-8-rosa2016.1.x86_64
(из-за отсутствия python3-qt5-core,
из-за отсутствия python3-qt5-dbus,
из-за отсутствия python3-qt5-widgets,
из-за отсутствия python3-qt5-gui,
из-за неудовлетворённости hplip == 3.16.11-8)
lib64qgsttools_p5-5.11.2-1-rosa2016.1.x86_64
(из-за отсутствия libQt5Multimedia.so.5(Qt_5.11.2_PRIVATE_API)(64bit))
lib64qt5multimediaquick_p5-5.11.2-1-rosa2016.1.x86_64
(из-за отсутствия libQt5Multimedia.so.5(Qt_5.11.2_PRIVATE_API)(64bit))
python3-qt5-core-5.11.3-4-rosa2016.1.x86_64
(из-за отсутствия libQt5Core.so.5(Qt_5.11.2_PRIVATE_API)(64bit))
python3-qt5-dbus-5.11.3-4-rosa2016.1.x86_64
(из-за неудовлетворённости python3-qt5-core == 3:5.11.3-4:2016.1)
python3-qt5-gui-5.11.3-4-rosa2016.1.x86_64
(из-за неудовлетворённости python3-qt5-core == 3:5.11.3-4:2016.1)
python3-qt5-widgets-5.11.3-4-rosa2016.1.x86_64
(из-за неудовлетворённости python3-qt5-core == 3:5.11.3-4:2016.1)
task-printing-hp-2014-6-rosa2016.1.x86_64
(из-за неудовлетворённости hplip-gui >= 3.13.11,
из-за неудовлетворённости hplip >= 3.13.11)
Решается через удвление plasma5-desktop-5.14.4.1-5.x86_64

До этого обновлялся через kde5_backports

Неофициальная сборка новой plasma5

Добавлено: 11 янв 2019, 11:43
Zeffanyx
При выборе пункта "Завершить сеанс" или другого пункта, связанного с выключением, раньше был красивый эффект плавного затенения. В 5.14.5 затенение происходит быстро и без этого эффекта. Интересно, это в апстриме так сделали?