google-earth-pro-stable-7.3.1.4507-0.x86_64 (due to unsatisfied mesa-libGLU)

Ответить
Аватара пользователя
rickin
Сообщения: 28
Зарегистрирован: 06 мар 2018, 16:22
Operating system: Linux dx 4.9.76-nrj-desktop-1rosa-x86_64

google-earth-pro-stable-7.3.1.4507-0.x86_64 (due to unsatisfied mesa-libGLU)

Сообщение rickin » 15 апр 2018, 23:07

Hi all :)

I am wondering if anyone knows if possible to get a stable version of google earth running on Rosa Fresh. I have been able to get a version running using wine a windows download, but it has to many glitches.

For some reason I dont know but some times Fedora RPM's have installed find on ROSA . Like ZOOM.us video software.

But Ive tried a few methods know and best guide closest related to ROSA was this bug page for Mageia https://bugs.mageia.org/show_bug.cgi?id=22747
But I have had no luck with such methods.
I still end up with error message

google-earth-pro-stable-7.3.1.4507-0.x86_64 (due to unsatisfied mesa-libGLU)

But I do have Package lib64glu1-9.0.0-9-rosa2016.1.x86_64 is already installed

Any thoughts would be great !!
Thanks

______________________________________________________________________

Привет всем :)

Я интересно, если кто-нибудь знает, если можно получить стабильная версия google earth на роса. Я смог получить версию используя вина windows скачать, но имеет много глюков.

По какой-то причине я не знаю, но несколько раз Fedora мин было установлено на роза . Как и ZOOM.ru программное обеспечение для видео.

Но Ive пытались несколько способов узнать и лучший гид ближе всего связаны с роза была эта ошибка страница https://bugs.mageia.org/show_bug.cgi?id=22747 Mageia,
но у меня не было никаких успехов в таких методов.
Я до сих пор работают с сообщением об ошибке

google-earth-pro-stable-7.3.1.4507-0.x86_64 (из-за неудовлетворенной Меса-libGLU),

но у меня есть пакет64lib glu1-9.0.0-9-Роза2016.1.x86_64 уже установлен

какой-либо мысли, было бы здорово!!!
Спасибо

Аватара пользователя
rickin
Сообщения: 28
Зарегистрирован: 06 мар 2018, 16:22
Operating system: Linux dx 4.9.76-nrj-desktop-1rosa-x86_64

Re: google-earth-pro-stable-7.3.1.4507-0.x86_64 (due to unsatisfied mesa-libGLU)

Сообщение rickin » 15 апр 2018, 23:28

dx9 dx9 # urpmi libglu -a
Package libglu1-9.0.0-9-rosa2016.1.i586 is already installed
Marking libglu1 as manually installed, it won't be auto-orphaned
writing /var/lib/rpm/installed-through-deps.list
To satisfy dependencies, the following packages are going to be installed:
Package Version Release Dist DEpoch Arch
(medium "Main")
lib64xv-devel 1.0.11 3 rosa 2016.1 x86_64
llvm 3.9.0 5 rosa 2016.1 x86_64
llvm-polly 3.9.0 5 rosa 2016.1 x86_64
(medium "Main32")
libffi-devel 3.2.1 3 rosa 2016.1 i586
libglu-devel 9.0.0 9 rosa 2016.1 i586
libllvm-devel 3.9.0 5 rosa 2016.1 i586
libx11-devel 1.6.4 3 rosa 2016.1 i586
libxau-devel 1.0.8 8 rosa 2016.1 i586
libxdamage-devel 1.1.4 5 rosa 2016.1 i586
libxdmcp-devel 1.1.2 4 rosa 2016.1 i586
libxext-devel 1.3.3 6 rosa 2016.1 i586
libxfixes-devel 5.0.3 3 rosa 2016.1 i586
libxv-devel 1.0.11 3 rosa 2016.1 i586
libxvmc-devel 1.0.10 3 rosa 2016.1 i586
libxxf86vm-devel 1.1.4 4 rosa 2016.1 i586
(medium "Main32 Updates")
libdrm-devel 2.4.90 2 rosa 2016.1 i586
libdrm_etnaviv1 2.4.90 2 rosa 2016.1 i586
libdrm_exynos1 2.4.90 2 rosa 2016.1 i586
libdrm_omap1 2.4.90 2 rosa 2016.1 i586
libdrm_tegra0 2.4.90 2 rosa 2016.1 i586
libexpat-devel 2.2.5 1 rosa 2016.1 i586
libgl-devel 17.3.6 4 rosa 2016.1 i586
libglapi-devel 17.3.6 4 rosa 2016.1 i586
libkms1 2.4.90 2 rosa 2016.1 i586
libpciaccess-devel 0.14 1 rosa 2016.1 i586
libxcb-composite0 1.13 2 rosa 2016.1 i586
libxcb-damage0 1.13 2 rosa 2016.1 i586
libxcb-devel 1.13 2 rosa 2016.1 i586
libxcb-dpms0 1.13 2 rosa 2016.1 i586
libxcb-randr0 1.13 2 rosa 2016.1 i586
libxcb-record0 1.13 2 rosa 2016.1 i586
libxcb-res0 1.13 2 rosa 2016.1 i586
libxcb-screensaver0 1.13 2 rosa 2016.1 i586
libxcb-shape0 1.13 2 rosa 2016.1 i586
libxcb-xf86dri0 1.13 2 rosa 2016.1 i586
libxcb-xinerama0 1.13 2 rosa 2016.1 i586
libxcb-xinput0 1.13 2 rosa 2016.1 i586
libxcb-xkb1 1.13 2 rosa 2016.1 i586
libxcb-xselinux0 1.13 2 rosa 2016.1 i586
libxcb-xtest0 1.13 2 rosa 2016.1 i586
libxcb-xv0 1.13 2 rosa 2016.1 i586
libxcb-xvmc0 1.13 2 rosa 2016.1 i586
libxshmfence-devel 1.3 2 rosa 2016.1 i586
161MB of additional disk space will be used.
32MB of packages will be retrieved.
Proceed with the installation of the 43 packages? (Y/n) y
http://mirror.rosalab.ru/rosa/rosa2016. ... x86_64.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... x86_64.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... x86_64.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm
http://mirror.rosalab.ru/rosa/rosa2016. ... 1.i586.rpm


installing libglapi-devel-17.3.6-4-rosa2016.1.i586.rpm libxcb-xvmc0-1.13-2-rosa2016.1.i586.rpm libxcb-record0-1.13-2-rosa2016.1.i586.rpm libdrm_exynos1-2.4.90-2-rosa2016.1.i586.rpm libxdmcp-devel-1.1.2-4-rosa2016.1.i586.rpm libxcb-xselinux0-1.13-2-rosa2016.1.i586.rpm libpciaccess-devel-0.14-1-rosa2016.1.i586.rpm libxvmc-devel-1.0.10-3-rosa2016.1.i586.rpm libxshmfence-devel-1.3-2-rosa2016.1.i586.rpm libxcb-screensaver0-1.13-2-rosa2016.1.i586.rpm lib64xv-devel-1.0.11-3-rosa2016.1.x86_64.rpm libglu-devel-9.0.0-9-rosa2016.1.i586.rpm libexpat-devel-2.2.5-1-rosa2016.1.i586.rpm libdrm-devel-2.4.90-2-rosa2016.1.i586.rpm libxcb-dpms0-1.13-2-rosa2016.1.i586.rpm libxfixes-devel-5.0.3-3-rosa2016.1.i586.rpm libxcb-xv0-1.13-2-rosa2016.1.i586.rpm libllvm-devel-3.9.0-5-rosa2016.1.i586.rpm libxcb-xtest0-1.13-2-rosa2016.1.i586.rpm llvm-3.9.0-5-rosa2016.1.x86_64.rpm libgl-devel-17.3.6-4-rosa2016.1.i586.rpm libxcb-devel-1.13-2-rosa2016.1.i586.rpm libx11-devel-1.6.4-3-rosa2016.1.i586.rpm libxcb-shape0-1.13-2-rosa2016.1.i586.rpm libxcb-xkb1-1.13-2-rosa2016.1.i586.rpm libxcb-xinerama0-1.13-2-rosa2016.1.i586.rpm libdrm_tegra0-2.4.90-2-rosa2016.1.i586.rpm libdrm_omap1-2.4.90-2-rosa2016.1.i586.rpm libxcb-damage0-1.13-2-rosa2016.1.i586.rpm libdrm_etnaviv1-2.4.90-2-rosa2016.1.i586.rpm libxau-devel-1.0.8-8-rosa2016.1.i586.rpm libxext-devel-1.3.3-6-rosa2016.1.i586.rpm libkms1-2.4.90-2-rosa2016.1.i586.rpm libffi-devel-3.2.1-3-rosa2016.1.i586.rpm libxv-devel-1.0.11-3-rosa2016.1.i586.rpm libxcb-composite0-1.13-2-rosa2016.1.i586.rpm libxxf86vm-devel-1.1.4-4-rosa2016.1.i586.rpm libxcb-randr0-1.13-2-rosa2016.1.i586.rpm libxcb-res0-1.13-2-rosa2016.1.i586.rpm libxcb-xf86dri0-1.13-2-rosa2016.1.i586.rpm libxdamage-devel-1.1.4-5-rosa2016.1.i586.rpm llvm-polly-3.9.0-5-rosa2016.1.x86_64.rpm libxcb-xinput0-1.13-2-rosa2016.1.i586.rpm from /var/cache/urpmi/rpms
Preparing... ##################################################################################################################
1/43: libxshmfence-devel ##################################################################################################################
2/43: llvm-polly ##################################################################################################################
3/43: llvm ##################################################################################################################
4/43: libffi-devel ##################################################################################################################
5/43: libexpat-devel ##################################################################################################################
6/43: libpciaccess-devel ##################################################################################################################
7/43: libglapi-devel ##################################################################################################################
8/43: libxcb-xinput0 ##################################################################################################################
9/43: libxcb-xf86dri0 ##################################################################################################################
10/43: libxcb-res0 ##################################################################################################################
11/43: libxcb-randr0 ##################################################################################################################
12/43: libxcb-composite0 ##################################################################################################################
13/43: libkms1 ##################################################################################################################
14/43: libdrm_etnaviv1 ##################################################################################################################
15/43: libxcb-damage0 ##################################################################################################################
16/43: libdrm_omap1 ##################################################################################################################
17/43: libdrm_tegra0 ##################################################################################################################
18/43: libxcb-xinerama0 ##################################################################################################################
19/43: libxcb-xkb1 ##################################################################################################################
20/43: libxcb-shape0 ##################################################################################################################
21/43: libxcb-xtest0 ##################################################################################################################
22/43: libxcb-xv0 ##################################################################################################################
23/43: libxcb-dpms0 ##################################################################################################################
24/43: libxcb-screensaver0 ##################################################################################################################
25/43: libxcb-xselinux0 ##################################################################################################################
26/43: libdrm_exynos1 ##################################################################################################################
27/43: libxcb-record0 ##################################################################################################################
28/43: libxcb-xvmc0 ##################################################################################################################
29/43: libxdmcp-devel ##################################################################################################################
30/43: libxau-devel ##################################################################################################################
31/43: libllvm-devel ##################################################################################################################
32/43: libdrm-devel ##################################################################################################################
33/43: libxcb-devel ##################################################################################################################
34/43: libx11-devel ##################################################################################################################
35/43: libxfixes-devel ##################################################################################################################
36/43: libxext-devel ##################################################################################################################
37/43: libxdamage-devel ##################################################################################################################
38/43: lib64xv-devel ##################################################################################################################
39/43: libxv-devel ##################################################################################################################
40/43: libxxf86vm-devel ##################################################################################################################
41/43: libxvmc-devel ##################################################################################################################
42/43: libgl-devel ##################################################################################################################
43/43: libglu-devel ##################################################################################################################
dx9 dx9 # urpmi google-earth -a
Some requested packages cannot be installed:
google-earth-ec-stable-7.3.1.4507-0.x86_64 (due to unsatisfied mesa-libGLU)

Аватара пользователя
VictorR2007
Сообщения: 5223
Зарегистрирован: 12 сен 2011, 12:00
Operating system: ROSA 2016.1
Откуда: Северодвинск

Re: google-earth-pro-stable-7.3.1.4507-0.x86_64 (due to unsatisfied mesa-libGLU)

Сообщение VictorR2007 » 15 апр 2018, 23:53

There is a package google-earth-pro-stable-current.x86_64.rpm here https://www.google.com/earth/download/gep/agree.html

You need to install the command

Код: Выделить всё

rpm -Uvh --nodeps /path to the package/google-earth-pro-stable-current.x86_64.rpm
The package mesa-libGLU is already installed

Аватара пользователя
rickin
Сообщения: 28
Зарегистрирован: 06 мар 2018, 16:22
Operating system: Linux dx 4.9.76-nrj-desktop-1rosa-x86_64

Re: google-earth-pro-stable-7.3.1.4507-0.x86_64 (due to unsatisfied mesa-libGLU)

Сообщение rickin » 16 апр 2018, 00:33

Thanks for reply. This is what has happened .

dx9@dx9 ~ $ google-earth-pro-stable
bash: google-earth-pro-stable: command not found
dx9@dx9 ~ $ urpme google-earth
The following packages contain google-earth:
google-earth-pro-stable-7.3.1.4507-0.x86_64
google-earth-stable-6.2.2.6613-0.x86_64
dx9@dx9 ~ $ urpme google-earth-pro-stable
removing google-earth-pro-stable-7.3.1.4507-0.x86_64
removing package google-earth-pro-stable-7.3.1.4507-0.x86_64
1/1: removing google-earth-pro-stable-7.3.1.4507-0.x86_64
##################################################################################################################
dx9@dx9 ~ $ urpme google-earth-stable-6.2.2.6613
removing google-earth-stable-6.2.2.6613-0.x86_64
removing package google-earth-stable-6.2.2.6613-0.x86_64
1/1: removing google-earth-stable-6.2.2.6613-0.x86_64
##################################################################################################################
dx9@dx9 ~ $ rpm -Uvh --nodeps google-earth-pro-stable-7.3.1.4507-0.x86_64.rpm
Preparing... ########################################### [100%]
1:google-earth-pro-stable########################################### [100%]
error: unpacking of archive failed on file /etc/cron.daily: cpio: chmod failed - Operation not permitted
dx9@dx9 ~ $ chmod a+x google-earth-pro-stable-current.x86_64.rpm
dx9@dx9 ~ $ rpm -Uvh --nodeps google-earth-pro-stable-7.3.1.4507-0.x86_64.rpm
Preparing... ########################################### [100%]
1:google-earth-pro-stable########################################### [100%]
error: unpacking of archive failed on file /etc/cron.daily: cpio: chmod failed - Operation not permitted
dx9@dx9 ~ $ su
Password:
dx9 dx9 # rpm -Uvh --nodeps google-earth-pro-stable-7.3.1.4507-0.x86_64.rpm
Preparing... ########################################### [100%]
1:google-earth-pro-stable########################################### [100%]
Redirecting to /bin/systemctl start atd.service
warning: commands will be executed using (in order) a) $SHELL b) login shell c) /bin/sh
job 8 at Mon Apr 16 07:29:00 2018
dx9 dx9 #


The program loads but loads very glitch filled in many ways not usable.
Вложения
glitchy.png
Screen shot of earth running, distorted views

Аватара пользователя
VictorR2007
Сообщения: 5223
Зарегистрирован: 12 сен 2011, 12:00
Operating system: ROSA 2016.1
Откуда: Северодвинск

Re: google-earth-pro-stable-7.3.1.4507-0.x86_64 (due to unsatisfied mesa-libGLU)

Сообщение VictorR2007 » 16 апр 2018, 00:49


Аватара пользователя
rickin
Сообщения: 28
Зарегистрирован: 06 мар 2018, 16:22
Operating system: Linux dx 4.9.76-nrj-desktop-1rosa-x86_64

Re: google-earth-pro-stable-7.3.1.4507-0.x86_64 (due to unsatisfied mesa-libGLU)

Сообщение rickin » 21 апр 2018, 06:02

This did not work for me. Same issue

Ответить