ПРОБЛЕМА с добавлением "Новых" виджетов на панель

Ответить
ник
Сообщения: 63
Зарегистрирован: 13 сен 2017, 11:06
Operating system: ROSA Fresh R11 Plasma5 x64

ПРОБЛЕМА с добавлением "Новых" виджетов на панель

Сообщение ник » 12 июн 2019, 17:34

ROSA_Fresh_R11_Plasma5.14
НУЖНО чтобы верхняя панель слева имела вид: "кнопки_управления | Имя_приложения---Заголовок_приложения | Глобальное_меню"
Для этого из последнего есть три отдельных виджета:
1. Window Buttons Applet (psifidotos)
2. Window Title Applet (psifidotos)
3. Window AppMenu Applet (psifidotos) это чуть лучше встроенного глоб. меню - он умеет сворачиваться и работать в режиме слайдера

Все они поддерживают версии плазмы от 5.13, а на РОСЕ R11 работает только один "Window Title Applet".
Остальные два (через "получить новые виджеты") WidgetExplorer скачивет/устанавливает НО при попытке "добавить виджеты" на панель эти якобы установленные виджеты отсутствуют.
Последний раз редактировалось ник 16 июн 2019, 09:41, всего редактировалось 1 раз.

Аватара пользователя
Andreas17
Сообщения: 321
Зарегистрирован: 21 май 2017, 20:07
Operating system: AMD Athlon II X4 640, 12 ГБ ОЗУ, NVIDIA GTX 650, РОСА Fresh R11
Откуда: Москва

ПРОБЛЕМА с добавлением Новых виджетов на панель

Сообщение Andreas17 » 15 июн 2019, 23:35

Попробовал Ваш первый апплет. После установки отсутствуют файлы в .local/share/plasma/plasmoids.
Тогда скачал и установил вручную. Плазмоид появился в списке, но активировать его нельзя.

А там в комментах некоторые пользователи жаловались на неработоспособность. Наверное какая-то несовместимость.

ник
Сообщения: 63
Зарегистрирован: 13 сен 2017, 11:06
Operating system: ROSA Fresh R11 Plasma5 x64

ПРОБЛЕМА с добавлением "Новых" виджетов на панель

Сообщение ник » 16 июн 2019, 09:35

Andreas17
Разработчик утверждает, что все три плазмоида (Versions 0.4) должны работать как минимум в Plasma5.13 и 5.14
На store.kde.org есть конечно пояснения для установки каждого плазмоида и не секрет, что в первую очередь почти все они тестируются на KDE_Neon и OpenSUSE. Там все точно работает и на github.com есть инструкция как одним скриптом доустановить требуемые пакеты (если их небыло). НЕПОНЯТНО то что в скрипте для NEON и OpenSUSE разное количество пакетов при том что некоторые из них видимо для каждого дистрибутива могут называться по разному. Отсюда вопрос а как с необходимым перечнем пакетов обстоит в РОСЕ, и как они у нас могут называться (насколько все может совпадать с NEON или OpenSUSE).

Ps:
Требования для плазмоида Заголовка приложения:
Plasma >= 5.8
KDeclarative
В РОСЕ условия удовлетворяются - вот плазмоид и работает.

Ответить