[РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Ответить
Аватара пользователя
asupstudent
Сообщения: 122
Зарегистрирован: 15 май 2012, 13:44
Operating system: ROSA Marathon 2012 (LTS)
Откуда: г. Кулебаки, Нижегородская область

[РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Сообщение asupstudent » 22 ноя 2016, 20:00

Компания Mail.ru прекратила поддержку старых версий клиента к облаку и на сайте лежат новые версии для линукса. Раньше была возможность заргузить bin и работать, все работало отлично, сейчас только rpm.

Но при установке требует qt5-qtbase и qt5-qtx11extras. Имеется ли возможность обойти эту проблему, в репозитарии данных компонентов нет.
Возможно подключив какие то другие, но какие? или есть у кого bin новой версии клиента.

Спасибо
Последний раз редактировалось asupstudent 23 ноя 2016, 11:01, всего редактировалось 1 раз.
Не обижай слабого детеныша — он может оказаться сыном тигра.

vlad
Сообщения: 369
Зарегистрирован: 27 дек 2012, 04:44
Operating system: ОС

Re: Новая версия Облако Mail.ru для linux - не работает

Сообщение vlad » 22 ноя 2016, 21:30

Они не умеют rpm собирать.

Аватара пользователя
ans
Сообщения: 2087
Зарегистрирован: 11 сен 2011, 08:42
Operating system: Rosa
Откуда: Ekaterinburg
Контактная информация:

Re: Новая версия Облако Mail.ru для linux - не работает

Сообщение ans » 22 ноя 2016, 22:10

asupstudent писал(а):или есть у кого bin новой версии клиента.
Спасибо
А разархивировать rpm и достать оттуда bin?
Screenshot_20161123_001157.png
Изображение

Аватара пользователя
Barmalei
Сообщения: 4560
Зарегистрирован: 29 дек 2014, 15:45
Operating system: Intel Pentium 2020M / 6 Gb RAM / AMD GRadeon HD 8570 / Rosa Fresh R10 KDE 2016.1 x64

Re: Новая версия Облако Mail.ru для linux - не работает

Сообщение Barmalei » 22 ноя 2016, 22:22

Он просит libQt5X11Extras.so.5

keleg
Сообщения: 5276
Зарегистрирован: 15 сен 2011, 01:58

Re: Новая версия Облако Mail.ru для linux - не работает

Сообщение keleg » 23 ноя 2016, 02:41

urpmf libQt5X11Extras.so.5
lib64qt5x11extras5:/usr/lib64/libQt5X11Extras.so.5

Аватара пользователя
VictorR2007
Сообщения: 5315
Зарегистрирован: 12 сен 2011, 13:00
Operating system: ROSA 2016.1
Откуда: Северодвинск

Re: Новая версия Облако Mail.ru для linux - не работает

Сообщение VictorR2007 » 23 ноя 2016, 04:36

asupstudent писал(а):Но при установке требует qt5-qtbase и qt5-qtx11extras. Имеется ли возможность обойти эту проблему, в репозитарии данных компонентов нет.
Возможно подключив какие то другие, но какие? или есть у кого bin новой версии клиента.

Спасибо
Все пакеты есть в репах.
Только называются по другому.
Например lib64qt5x11extras5 или libqt5x11extras5.
Чтобы не искать нужные пакеты, можно установить какую-нибудь программу из реп на qt5,
чтобы подтянула нужные зависимости.
А потом удалить.
Например, plasma5-ark, а потом снова установить ark.

Аватара пользователя
asupstudent
Сообщения: 122
Зарегистрирован: 15 май 2012, 13:44
Operating system: ROSA Marathon 2012 (LTS)
Откуда: г. Кулебаки, Нижегородская область

Re: Новая версия Облако Mail.ru для linux - не работает

Сообщение asupstudent » 23 ноя 2016, 11:00

Спасибо за советы, проблему с установкой решил:

1 Скачал RPM пакет для 64 разрядной системы;
2 Извлек bin файл;
3 Удали ark, установил plasma5-ark + все зависимости;
4 запустил bin файл;
5 добавил в автозагрузку


Спасибо
Не обижай слабого детеныша — он может оказаться сыном тигра.

Аватара пользователя
alexander-d3
Сообщения: 767
Зарегистрирован: 31 мар 2014, 22:48
Operating system: rosa fresh r2
Откуда: Москва

Re: [РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Сообщение alexander-d3 » 11 окт 2017, 18:49

Устанавливать можно командой
rpm -Uvh --nodeps --force mail-cloud15.rpm

tn243
Сообщения: 19
Зарегистрирован: 13 окт 2017, 09:11
Operating system: r8

Re: [РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Сообщение tn243 » 13 окт 2017, 09:18

xy MAILRU # rpm -Uvh --nodeps --force mail.ru-cloud-fedora-15.06-0112.x86_64.rpm
Подготовка... ########################################### [100%]
1:mail.ru-cloud ########################################### [100%]
Unexpected error.
Please follow instructions for manual installation on https://help.mail.ru/cloud_web/app/linux
error: %post(mail.ru-cloud-15.06-0112.x86_64) scriptlet failed, exit status 2

Однако неработает

Аватара пользователя
alexander-d3
Сообщения: 767
Зарегистрирован: 31 мар 2014, 22:48
Operating system: rosa fresh r2
Откуда: Москва

Re: [РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Сообщение alexander-d3 » 13 окт 2017, 09:33

Посмотри внимательней. Я ставлю на роса фреш R9x64. ставиться с ошибкой но устанавливается и работает. Да пробовал оба пакета. При установке импортирую публичный ключ.

tn243
Сообщения: 19
Зарегистрирован: 13 окт 2017, 09:11
Operating system: r8

Re: [РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Сообщение tn243 » 13 окт 2017, 09:42

да на r8 работает хоть и ош инсталл error: %post(mail.ru-cloud-15.06-0112.x86_64) scriptlet failed, exit status 2 !!
Хорошего настроения и удачного дня!

Аватара пользователя
alexander-d3
Сообщения: 767
Зарегистрирован: 31 мар 2014, 22:48
Operating system: rosa fresh r2
Откуда: Москва

Re: [РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Сообщение alexander-d3 » 13 окт 2017, 16:24

Два раза писал в теххподдержку с предложением собрать пакет для РОСЫ. Безуспешно, ноль реакции.
Пока видимо так придется устанавливать.
Вложения
1447747518_cloud-icon.png

Аватара пользователя
vladi105
Сообщения: 30
Зарегистрирован: 09 ноя 2016, 16:35
Operating system: ROSA Fresh R10 XFCE

Re: [РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Сообщение vladi105 » 01 июн 2018, 06:14

alexander-d3 писал(а):
13 окт 2017, 16:24
Два раза писал в теххподдержку с предложением собрать пакет для РОСЫ. Безуспешно, ноль реакции.
Пока видимо так придется устанавливать.
вот перепакованная для себя х64 версия https://abf.io/build_lists/2927724

Аватара пользователя
mikhailnov
Сообщения: 75
Зарегистрирован: 29 авг 2015, 22:53
Operating system: Ubuntu, ROSA, FreeBSD
Контактная информация:

Re: [РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Сообщение mikhailnov » 02 июн 2018, 02:58

vladi105 писал(а):
01 июн 2018, 06:14
alexander-d3 писал(а):
13 окт 2017, 16:24
Два раза писал в теххподдержку с предложением собрать пакет для РОСЫ. Безуспешно, ноль реакции.
Пока видимо так придется устанавливать.
вот перепакованная для себя х64 версия https://abf.io/build_lists/2927724
Интересно, почему автоугадав не поставил зависимость от, например, libpng16?

Код: Выделить всё

$ ldd ./cloud
        linux-vdso.so.1 (0x00007ffceb169000)
        libidn.so.11 => /lib/x86_64-linux-gnu/libidn.so.11 (0x00007f1cf1af9000)
        libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f1cf18dc000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f1cf16d8000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f1cf134a000)
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f1cf1011000)
        libQt5X11Extras.so.5 => /usr/lib/x86_64-linux-gnu/libQt5X11Extras.so.5 (0x00007f1cf0e0d000)
        libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f1cf05c6000)
        libQt5Gui.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007f1cefe5d000)
        libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007f1cef712000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f1cef4f3000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f1cef155000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f1ceef3d000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f1ceeb4c000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f1cf1d2c000)
        libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f1cee924000)
        libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007f1cee698000)
        libpng16.so.16 => /usr/lib/x86_64-linux-gnu/libpng16.so.16 (0x00007f1cee466000)
        libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f1cee1c8000)
        libicui18n.so.60 => /usr/lib/x86_64-linux-gnu/libicui18n.so.60 (0x00007f1cedd27000)
        libicuuc.so.60 => /usr/lib/x86_64-linux-gnu/libicuuc.so.60 (0x00007f1ced970000)
        libdouble-conversion.so.1 => /usr/lib/x86_64-linux-gnu/libdouble-conversion.so.1 (0x00007f1ced75f000)
        libglib-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f1ced449000)
        libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f1ced245000)
        libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f1ced03f000)
        libGLX.so.0 => /usr/lib/x86_64-linux-gnu/libGLX.so.0 (0x00007f1cece0e000)
        libGLdispatch.so.0 => /usr/lib/x86_64-linux-gnu/libGLdispatch.so.0 (0x00007f1cecb58000)
        libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f1cec8a4000)
        libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f1cec677000)
        libicudata.so.60 => /usr/lib/x86_64-linux-gnu/libicudata.so.60 (0x00007f1ceaace000)
        libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f1cea85c000)
        libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f1cea647000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f1cea43f000)
DeepinScreenshot_выберите-область_20180602025448.png

Аватара пользователя
alexander-d3
Сообщения: 767
Зарегистрирован: 31 мар 2014, 22:48
Operating system: rosa fresh r2
Откуда: Москва

[РЕШЕНО] Новая версия Облако Mail.ru для linux - не работает

Сообщение alexander-d3 » 16 июл 2018, 19:16

а можно свежую ссылку на перепакованный пакет

Ответить