[Решено] Проблема с обновлением

Ответить
Аватара пользователя
artemmen
Сообщения: 129
Зарегистрирован: 10 июн 2014, 03:35
Operating system: Ubuntu 10.04
ROSA LXDE Fresh
Simply 7.1

[Решено] Проблема с обновлением

Сообщение artemmen » 05 июн 2015, 06:54

Не обновляются пакеты dracut и bridge-utils-1.5-5-rosa2014.1.x86_64, как через ГУЙ, так и через терминал.

Код: Выделить всё

[root@ROSA ~]# urpmi --auto-update 
medium "main" is up-to-date
medium "main updates" is up-to-date
medium "Main32" is up-to-date
medium "Main32 Updates" is up-to-date
medium "contrib" is up-to-date
medium "contrib updates" is up-to-date
medium "non-free" is up-to-date
medium "non-free updates" is up-to-date
medium "Non-free32" is up-to-date
medium "Non-free32 Updates" is up-to-date
medium "restricted" is up-to-date
medium "restricted updates" is up-to-date
medium "Restricted32" is up-to-date
medium "Restricted32 Updates" is up-to-date
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
To satisfy dependencies, the following packages are going to be installed:
 Package                        Version      Release       Dist  DEpoch Arch 
(medium "main")
 bridge-utils                   1.5          5             rosa  2014.1 x86_64 
(medium "main updates")
 dracut                         037          28            rosa  2014.1 x86_64 
43KB of additional disk space will be used.
259KB of packages will be retrieved.
Proceed with the installation of the 2 packages? (Y/n) y
error: rpmdb: header #91 cannot be loaded -- skipping.


installing dracut-037-28-rosa2014.1.x86_64.rpm bridge-utils-1.5-5-rosa2014.1.x86_64.rpm from /var/cache/urpmi/rpms
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
Preparing...                     ##############################error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
error: rpmdb: header #91 cannot be loaded -- skipping.
###############
Installation failed:	package bridge-utils-1.5-5.x86_64 is already installed

[root@ROSA ~]# urpme bridge-utils-1.5-5-rosa2014.1.x86_64
error: rpmdb: header #91 cannot be loaded -- skipping.
unknown package: bridge-utils-1.5-5-rosa2014.1.x86_64
Последний раз редактировалось artemmen 07 июл 2015, 03:34, всего редактировалось 1 раз.

PastorDi
Сообщения: 2579
Зарегистрирован: 25 авг 2011, 11:34
Operating system: IBM DOS, OS/2
Откуда: Санкт-Петербург
Контактная информация:

Re: Проблема с обновлением

Сообщение PastorDi » 05 июн 2015, 09:57

Вот почитайте: Если упала база rpm Поле починки попробуйте еще раз обновиться.

Аватара пользователя
artemmen
Сообщения: 129
Зарегистрирован: 10 июн 2014, 03:35
Operating system: Ubuntu 10.04
ROSA LXDE Fresh
Simply 7.1

Re: Проблема с обновлением

Сообщение artemmen » 20 июн 2015, 20:40

Первый способ ошибку убрал, но на ее место пришла другая.

Код: Выделить всё

[root@ROSA etc]# urpmi --auto-update 
medium "main" is up-to-date
medium "main updates" is up-to-date
medium "Main32" is up-to-date
medium "Main32 Updates" is up-to-date
medium "contrib" is up-to-date
    http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/contrib/updates/media_info/20150620-161233-synthesis.hdlist.cz
    http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/contrib/updates/media_info/20150620-161233-info.xml.lzma
    http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/contrib/updates/media_info/20150620-161233-files.xml.lzma
    http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/contrib/updates/media_info/20150620-161233-changelog.xml.lzma
updated medium "contrib updates"                                               
medium "non-free" is up-to-date
medium "non-free updates" is up-to-date
medium "Non-free32" is up-to-date
medium "Non-free32 Updates" is up-to-date
medium "restricted" is up-to-date
medium "restricted updates" is up-to-date
medium "Restricted32" is up-to-date
medium "Restricted32 Updates" is up-to-date
To satisfy dependencies, the following packages are going to be installed:
 Package                        Version      Release       Dist  DEpoch Arch 
(medium "main updates")
 perl-XML-LibXML                2.12.100     2             rosa  2014.1 x86_64 
 python-cups                    1.9.72       1             rosa  2014.1 x86_64 
 rosa-icons                     1.1.5        2             rosa  2014.1 noarch 
 tmpwatch                       2.11         6             rosa  2014.1 x86_64 
5KB of additional disk space will be used.
11MB of packages will be retrieved.
Proceed with the installation of the 4 packages? (Y/n) y


installing tmpwatch-2.11-6-rosa2014.1.x86_64.rpm python-cups-1.9.72-1-rosa2014.1.x86_64.rpm perl-XML-LibXML-2.12.100-2-rosa2014.1.x86_64.rpm rosa-icons-1.1.5-2-rosa2014.1.noarch.rpm from /var/cache/urpmi/rpms
Installation failed:	wxgtk3.0 = 3.0.2-1:2014.1 is needed by (installed) lib64wx_baseu3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 is needed by (installed) lib64wx_gtk2u_core3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 is needed by (installed) lib64wx_gtk2u_adv3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 is needed by (installed) lib64wx_baseu_xml3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 is needed by (installed) lib64wx_baseu_net3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 is needed by (installed) lib64wx_gtk2u_html3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 is needed by (installed) lib64wx_gtk2u_aui3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 is needed by (installed) lib64wx_gtk2u_xrc3.0_0-3.0.2-1.x86_64
	libprocps.so.4()(64bit) is needed by (installed) procps-ng-3.3.10-1.x86_64
	libprocps.so.4(LIBPROCPS_0)(64bit) is needed by (installed) procps-ng-3.3.10-1.x86_64
	error while checking dependencies

[root@ROSA etc]# urpmi wxgtk3.0
Package wxgtk3.0-3.0.2-1-rosa2014.1.x86_64 is already installed
Есть варианты?

keleg
Сообщения: 5170
Зарегистрирован: 15 сен 2011, 00:58

Re: Проблема с обновлением

Сообщение keleg » 22 июн 2015, 03:56

а если пакет procps-ng-3.3.10-1.x86_64 установить вручную?

Аватара пользователя
artemmen
Сообщения: 129
Зарегистрирован: 10 июн 2014, 03:35
Operating system: Ubuntu 10.04
ROSA LXDE Fresh
Simply 7.1

Re: Проблема с обновлением

Сообщение artemmen » 01 июл 2015, 09:30

Аналогично

Код: Выделить всё

[root@ROSA ~]# urpmi procps-ng-3.3.10-1.x86_64
Пакет procps-ng-3.3.10-1-rosa2014.1.x86_64 уже установлен

keleg
Сообщения: 5170
Зарегистрирован: 15 сен 2011, 00:58

Re: Проблема с обновлением

Сообщение keleg » 01 июл 2015, 11:32

Еще раз попробуйте urpmi --auto-update

Аватара пользователя
artemmen
Сообщения: 129
Зарегистрирован: 10 июн 2014, 03:35
Operating system: Ubuntu 10.04
ROSA LXDE Fresh
Simply 7.1

Re: Проблема с обновлением

Сообщение artemmen » 02 июл 2015, 01:58

Конечно же попробовал:

Код: Выделить всё

[root@ROSA ~]# urpmi --auto-update 
источник «main» уже обновлён
источник «main updates» уже обновлён
источник «Main32» уже обновлён
источник «Main32 Updates» уже обновлён
источник «contrib» уже обновлён
источник «contrib updates» уже обновлён
источник «non-free» уже обновлён
источник «non-free updates» уже обновлён
источник «Non-free32» уже обновлён
источник «Non-free32 Updates» уже обновлён
источник «restricted» уже обновлён
источник «restricted updates» уже обновлён
источник «Restricted32» уже обновлён
источник «Restricted32 Updates» уже обновлён
Для удовлетворения зависимостей будут установлены следующие пакеты:
 Пакет                          Версия       Релиз         Dist  DEpoch Платформа 
(источник «main»)
 lib64colord2                   1.2.0        2             rosa  2014.1 x86_64 
 lib64colordprivate2            1.2.0        2             rosa  2014.1 x86_64 
(источник «main updates»)
 cups-filters                   1.0.69       1             rosa  2014.1 x86_64 
 gtk+3.0                        3.12.2       8             rosa  2014.1 x86_64 
 gtk+3.0-common                 3.12.2       8             rosa  2014.1 noarch 
 lib64cupsfilters1              1.0.69       1             rosa  2014.1 x86_64 
 lib64fontembed1                1.0.69       1             rosa  2014.1 x86_64 
 lib64gtk+3_0                   3.12.2       8             rosa  2014.1 x86_64 
 lib64gtk-modules3.0            3.12.2       8             rosa  2014.1 x86_64 
 perl-IO-Compress               2.68.0       1             rosa  2014.1 noarch 
 perl-IO-Socket-SSL             2.16.0       1             rosa  2014.1 noarch 
 perl-XML-LibXML                2.12.100     2             rosa  2014.1 x86_64 
 python-cups                    1.9.72       1             rosa  2014.1 x86_64 
 rosa-icons                     1.1.5        2             rosa  2014.1 noarch 
 tmpwatch                       2.11         6             rosa  2014.1 x86_64 
Будет использовано 665КБ дополнительного дискового пространства.
Будет загружено 17МБ пакетов.
Установить 15 пакетов? (Y/n) y


устанавливается lib64fontembed1-1.0.69-1-rosa2014.1.x86_64.rpm lib64cupsfilters1-1.0.69-1-rosa2014.1.x86_64.rpm rosa-icons-1.1.5-2-rosa2014.1.noarch.rpm python-cups-1.9.72-1-rosa2014.1.x86_64.rpm perl-XML-LibXML-2.12.100-2-rosa2014.1.x86_64.rpm lib64colordprivate2-1.2.0-2-rosa2014.1.x86_64.rpm tmpwatch-2.11-6-rosa2014.1.x86_64.rpm lib64colord2-1.2.0-2-rosa2014.1.x86_64.rpm из /var/cache/urpmi/rpms


устанавливается gtk+3.0-common-3.12.2-8-rosa2014.1.noarch.rpm cups-filters-1.0.69-1-rosa2014.1.x86_64.rpm lib64gtk-modules3.0-3.12.2-8-rosa2014.1.x86_64.rpm perl-IO-Compress-2.68.0-1-rosa2014.1.noarch.rpm gtk+3.0-3.12.2-8-rosa2014.1.x86_64.rpm lib64gtk+3_0-3.12.2-8-rosa2014.1.x86_64.rpm perl-IO-Socket-SSL-2.16.0-1-rosa2014.1.noarch.rpm из /var/cache/urpmi/rpms
Установка не удалась:	libprocps.so.4()(64bit) нужен для (установлен)procps-ng-3.3.10-1.x86_64
	libprocps.so.4(LIBPROCPS_0)(64bit) нужен для (установлен)procps-ng-3.3.10-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 нужен для (установлен)lib64wx_baseu3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 нужен для (установлен)lib64wx_gtk2u_core3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 нужен для (установлен)lib64wx_gtk2u_adv3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 нужен для (установлен)lib64wx_baseu_xml3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 нужен для (установлен)lib64wx_baseu_net3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 нужен для (установлен)lib64wx_gtk2u_html3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 нужен для (установлен)lib64wx_gtk2u_aui3.0_0-3.0.2-1.x86_64
	wxgtk3.0 = 3.0.2-1:2014.1 нужен для (установлен)lib64wx_gtk2u_xrc3.0_0-3.0.2-1.x86_64
	error while checking dependencies
	libcolord.so.2()(64bit) нужен для lib64gtk-modules3.0-3.12.2-8.x86_64
	error while checking dependencies
[root@ROSA ~]# 

d_uragan
Сообщения: 503
Зарегистрирован: 23 ноя 2011, 20:27

Re: Проблема с обновлением

Сообщение d_uragan » 02 июл 2015, 16:20

Возможно, база rpm все-таки немного поломалась. Можно попробовать насильно переустановить пакеты, которые вроде установлены, а вроде и нет:

urpmi --replacepkgs lib64procps4 wxgtk3.0

Аватара пользователя
artemmen
Сообщения: 129
Зарегистрирован: 10 июн 2014, 03:35
Operating system: Ubuntu 10.04
ROSA LXDE Fresh
Simply 7.1

Re: Проблема с обновлением

Сообщение artemmen » 02 июл 2015, 23:44

Еще интереснее:

Код: Выделить всё

[root@ROSA ~]# urpmi --replacepkgs lib64procps4 wxgtk3.0
    http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/main/updates/lib64procps4-3.3.10-1-rosa2014.1.x86_64.rpm
    http://mirror.rosalab.ru/rosa/rosa2014.1/repository/x86_64/media/main/updates/wxgtk3.0-3.0.2-1-rosa2014.1.x86_64.rpm
                                                                               

устанавливается wxgtk3.0-3.0.2-1-rosa2014.1.x86_64.rpm lib64procps4-3.3.10-1-rosa2014.1.x86_64.rpm из /var/cache/urpmi/rpms
Подготовка...                    #############################################
      1/2: lib64procps4          #############################################
      2/2: wxgtk3.0              #############################################
[root@ROSA ~]# urpmi --auto-update 
источник «main» уже обновлён
источник «main updates» уже обновлён
источник «Main32» уже обновлён
источник «Main32 Updates» уже обновлён
источник «contrib» уже обновлён
источник «contrib updates» уже обновлён
источник «non-free» уже обновлён
источник «non-free updates» уже обновлён
источник «Non-free32» уже обновлён
источник «Non-free32 Updates» уже обновлён
источник «restricted» уже обновлён
источник «restricted updates» уже обновлён
источник «Restricted32» уже обновлён
источник «Restricted32 Updates» уже обновлён
rpmdb: /var/lib/rpm/Packages: BDB0088 DB_SECONDARY_BAD: Secondary index inconsistent with primary
error: db3cget:db3.c:1406: dbcursor->get(-30972): BDB0088 DB_SECONDARY_BAD: Secondary index inconsistent with primary
perl: rpmdb.c:2323: rpmmiNext: Проверочное утверждение «0» не выполнено.
Аварийный останов (слепок снят)

PastorDi
Сообщения: 2579
Зарегистрирован: 25 авг 2011, 11:34
Operating system: IBM DOS, OS/2
Откуда: Санкт-Петербург
Контактная информация:

Re: Проблема с обновлением

Сообщение PastorDi » 03 июл 2015, 00:24

artemmen писал(а):Еще интереснее:
Тогда вам сюда: http://wiki.rosalab.ru/ru/index.php/%D0 ... %D0%B0_RPM
И потом еще раз пробовать обновиться.

Аватара пользователя
artemmen
Сообщения: 129
Зарегистрирован: 10 июн 2014, 03:35
Operating system: Ubuntu 10.04
ROSA LXDE Fresh
Simply 7.1

Re: Проблема с обновлением

Сообщение artemmen » 04 июл 2015, 23:21

Ни один метод не сработал.

Код: Выделить всё

[root@ROSA ~]# rm -f /var/lib/rpm/__db.*
[root@ROSA ~]# /usr/lib/rpm/bin/rpmdbchk
checking /var/lib/rpm/Packages: 1986/1986 100%
0/1986 (0,000000%) headers damaged

[root@ROSA ~]# db52_recover -vh /var/lib/rpm
BDB2526 Finding last valid log LSN: file: 38 offset 7871393
BDB1518 Recovery complete at Sat Jul  4 23:19:17 2015
BDB1519 Maximum transaction ID 0 recovery checkpoint [38][7871301]

[root@ROSA ~]# perl -MURPM -e 'URPM::DB::convert("/", "btree", 1, 1)'
Undefined subroutine &URPM::DB::convert called at -e line 1.

[root@ROSA ~]# urpmi --auto-update 
источник «main» уже обновлён
источник «main updates» уже обновлён
источник «Main32» уже обновлён
источник «Main32 Updates» уже обновлён
источник «contrib» уже обновлён
источник «contrib updates» уже обновлён
источник «non-free» уже обновлён
источник «non-free updates» уже обновлён
источник «Non-free32» уже обновлён
источник «Non-free32 Updates» уже обновлён
источник «restricted» уже обновлён
источник «restricted updates» уже обновлён
источник «Restricted32» уже обновлён
источник «Restricted32 Updates» уже обновлён
rpmdb: /var/lib/rpm/Packages: BDB0088 DB_SECONDARY_BAD: Secondary index inconsistent with primary
error: db3cget:db3.c:1406: dbcursor->get(-30972): BDB0088 DB_SECONDARY_BAD: Secondary index inconsistent with primary
perl: rpmdb.c:2323: rpmmiNext: Проверочное утверждение «0» не выполнено.
Аварийный останов (слепок снят)

Аватара пользователя
VictorR2007
Сообщения: 5090
Зарегистрирован: 12 сен 2011, 12:00
Operating system: ROSA 2016.1
Откуда: Северодвинск

Re: Проблема с обновлением

Сообщение VictorR2007 » 05 июл 2015, 11:49

Попробуйте дать команду

Код: Выделить всё

urpm-package-cleanup --help
Будет ли она работать с любыми из предложенных параметров.
Во всём виноваты русские. Они всем вредят. Всегда. И ещё Путин. Ещё тот гусь. Тоже вредит. Всем. И всех захватывает. Ужас.:)

keleg
Сообщения: 5170
Зарегистрирован: 15 сен 2011, 00:58

Re: Проблема с обновлением

Сообщение keleg » 05 июл 2015, 17:05

Я б переставил уже давно с сохранением хомяка. Дел то на полчаса максимум.

Аватара пользователя
artemmen
Сообщения: 129
Зарегистрирован: 10 июн 2014, 03:35
Operating system: Ubuntu 10.04
ROSA LXDE Fresh
Simply 7.1

Re: [Решено] Проблема с обновлением

Сообщение artemmen » 07 июл 2015, 03:36

Все восстановилось стандартной процедурой:

Код: Выделить всё

rm -f /var/lib/rpm/__db* 
rpm -vv --rebuilddb 

Ответить