Страница 1 из 1

Конфликтующие пакеты. Невозможно установить обновления.

Добавлено: 09 фев 2018, 21:01
Makukhin82
Здравствуйте!

Не могу установить системные обновления из-за конфликтующих пакетов.

Код: Выделить всё

Конфликтующие пакеты
    Ошибка! Пакет, который вы пытаетесь установить/обновить конфликтует с уже установленным, их невозможно инсталлировать одновременно! Пожалуйста проверьте, подключены ли источники с обновлениями, и попробуйте ещё раз.
    Если вы знаете, что делаете, то вы можете удалить конфликтующие пакеты либо произвести установку в консоли с автоматическим удалением конфликтующих пакетов.
   Помните, что все пакеты, зависимые от удаляемых, также будут удалены. Это может привести к неработоспособности всей системы!
------------------------
Следующие пакеты будут удалены для обновления остальных:
 systemd-230-8-rosa2016.1.i586
(чтобы установить systemd-230-8-rosa2016.1.i586)
systemd-units-230-8-rosa2016.1.i586
(чтобы установить systemd-units-230-8-rosa2016.1.i586)

Re: Конфликтующие пакеты. Невозможно установить обновления.

Добавлено: 10 фев 2018, 08:01
*d0s

Re: Конфликтующие пакеты. Невозможно установить обновления.

Добавлено: 10 фев 2018, 12:24
Алзим

Re: Конфликтующие пакеты. Невозможно установить обновления.

Добавлено: 10 фев 2018, 13:19
Makukhin82
Решение

Консоль

sudo su
urpme systemd-230-8-rosa2016.1.i586
urpme systemd-units-230-8-rosa2016.1.i586
urpmi --auto-update

Re: Конфликтующие пакеты. Невозможно установить обновления.

Добавлено: 10 фев 2018, 13:52
*d0s
Makukhin82 писал(а):
10 фев 2018, 13:19
Решение

Консоль

sudo su
Либо su либо sudo. Что-то одно.

Re: Конфликтующие пакеты. Невозможно установить обновления.

Добавлено: 10 фев 2018, 14:48
Алзим
Makukhin82 писал(а):
10 фев 2018, 13:19
Решение

Консоль

sudo su
urpme systemd-230-8-rosa2016.1.i586
urpme systemd-units-230-8-rosa2016.1.i586
urpmi --auto-update
Хм… Интересно, смог бы ты такое сделать через графическую программу…
С такими прогами, как systemd лучше не шутить так, а то можно сломать систему.
Изображение_20180210_144456.png

Re: Конфликтующие пакеты. Невозможно установить обновления.

Добавлено: 10 фев 2018, 15:13
*d0s
Алзим писал(а):
10 фев 2018, 14:48
Makukhin82 писал(а):
10 фев 2018, 13:19
Решение

Консоль

sudo su
urpme systemd-230-8-rosa2016.1.i586
urpme systemd-units-230-8-rosa2016.1.i586
urpmi --auto-update
Хм… Интересно, смог бы ты такое сделать через графическую программу…
С такими прогами, как systemd лучше не шутить так, а то можно сломать систему.
Изображение_20180210_144456.png
По сути он такое и в графике сделал.
Если бы после urpmi --auto-update не обновились systemd и systemd-units, а затем ребут, тогда да, кранты.

Re: Конфликтующие пакеты. Невозможно установить обновления.

Добавлено: 10 фев 2018, 15:19
Алзим
*d0s писал(а):
10 фев 2018, 15:13
По сути он такое и в графике сделал.
А попробуй нажать это в графике. :)
*d0s писал(а):
10 фев 2018, 15:13
Если бы после urpmi --auto-update не обновились systemd и systemd-units, а затем ребут, тогда да, кранты.
Согласен. :)

Re: Конфликтующие пакеты. Невозможно установить обновления.

Добавлено: 05 мар 2018, 19:40
alexxhelp
Makukhin82 писал(а):
10 фев 2018, 13:19
Решение

Консоль

sudo su
urpme systemd-230-8-rosa2016.1.i586
urpme systemd-units-230-8-rosa2016.1.i586
urpmi --auto-update

Код: Выделить всё

urpme systemd-230-8-rosa2016.1.x86_64
удаляется systemd-230-8-rosa2016.1.x86_64
dracut-install: ERROR: installing 'poweroff'
dracut-install: ERROR: installing 'reboot'
dracut-install: ERROR: installing 'halt'
dracut: FAILED: /usr/sbin/dracut-install -D /var/tmp/dracut.wXNbDA/initramfs -a umount poweroff reboot halt losetup stat
после чего

urpme systemd-units-230-8-rosa2016.1.x86_64

снес кучу пакетов

Код: Выделить всё

alexxhelp-desktop alexxhelp # urpmi --auto-update
Следующий пакет будет удалён для обновления остальных:
systemd-230-8-rosa2016.1.x86_64
 (чтобы установить systemd-230-8-rosa2016.1.x86_64) (y/N) y
Для удовлетворения зависимостей будут установлены следующие пакеты:
 Пакет                          Версия       Релиз         Dist  DEpoch Платформа 
(источник «Main»)
 initscripts                    9.56         10            rosa  2016.1 x86_64 
(источник «Main Updates»)
 systemd                        230          8             rosa  2016.1 x86_64 
 systemd-units                  230          8             rosa  2016.1 x86_64 
(источник «Main32»)
 rpm-helper                     0.24.12      16            rosa  2016.1 noarch 
Будет освобождено 11МБ дискового пространства.
Будет загружено 5.5МБ пакетов.
Установить 4 пакетов? (Y/n) y


устанавливается systemd-230-8-rosa2016.1.x86_64.rpm initscripts-9.56-10-rosa2016.1.x86_64.rpm rpm-helper-0.24.12-16-rosa2016.1.noarch.rpm systemd-units-230-8-rosa2016.1.x86_64.rpm из /var/cache/urpmi/rpms
warning: LOOP:
warning: removing initscripts-9.56-10.x86_64 "Requires: resolvconf >= 1.41" from tsort relations.
warning: removing systemd-units-230-8.x86_64 "Requires: /lib/systemd" from tsort relations.
warning: not removing systemd-230-8.x86_64 "Requires(pre): initscripts >= 9.56" from tsort relations.
warning: LOOP:
warning: removing initscripts-9.56-10.x86_64 "Requires: /lib/systemd" from tsort relations.
warning: not removing systemd-230-8.x86_64 "Requires(pre): initscripts >= 9.56" from tsort relations.
Подготовка...                    ###########################################################################################
Установка не удалась:   пакет systemd-230-8.x86_64 уже установлен
Хоть часть пакетов и могла быть установлена, произошли ошибки.
Следующий пакет будет удалён для обновления остальных:
systemd-230-8-rosa2016.1.x86_64
 (чтобы установить systemd-230-8-rosa2016.1.x86_64)
думаю сейчас после перезагрузки получу нерабочую систему