ROSA 64 bit: не подключается wi-fi в live режиме (РЕШЕНО)

Ответить
AVB
Сообщения: 423
Зарегистрирован: 10 окт 2012, 19:22
Operating system: Mandriva 2011

ROSA 64 bit: не подключается wi-fi в live режиме (РЕШЕНО)

Сообщение AVB » 03 мар 2017, 13:19

Сделал для себя открытие: в 64-х битных дистрибутивах запущенных в live режиме (ROSA, Минт, Кубунту) не срабатывает подключение к wi-fi, тогда как в 32-х битных версиях в live режиме всё подключается на ура.

Wi-fi карта PCI: TP-LINK TL-WN751ND (Qualcomm Atheros AR9227)
Материнская плата GIGABYT 970A-DS3P rev2

Мартовская оттепель?
Последний раз редактировалось AVB 14 мар 2017, 11:00, всего редактировалось 1 раз.

Борис3
Сообщения: 129
Зарегистрирован: 15 янв 2017, 14:48
Operating system: ROSA Fresh R8 x86-64

Re: ROSA 64 bit: не подключается wi-fi в live режиме

Сообщение Борис3 » 04 мар 2017, 10:18

Да нет, работает всё в live режиме. Специально только проверил Росу R8 64 bit KDE, MATE, GNOME. У меня средний ноутбук АSUS K52JU c Atheros AR9285 Wireless Network Adapter . Так что это у Вас где-то проблема. А вообще недавно была такая проблема на винде в режиме WinPE 64 bit, но потом исправилась.

AVB
Сообщения: 423
Зарегистрирован: 10 окт 2012, 19:22
Operating system: Mandriva 2011

Re: ROSA 64 bit: не подключается wi-fi в live режиме

Сообщение AVB » 14 мар 2017, 10:35

Причина найдена, средство лечения тоже (возможно, не в первый раз).

И так, "счастливым" обладателям материнской платы GYGABIT 970A-DS3P (rev2) для нормальной работы live-дистрибутивов 64-битных систем (когда работают USB2 порты и сетевая карта (PCI), а не только лишь USB3 порты без сетевой карты), надо зайти в BIOS и в разделе PERIPHERALS установить ENABLED для IOMMU Controller.

Эту же операцию следует проделать и перед установкой 64-битной системы Linux.

После установки системы, надо в файле /etc/default/grub подправить строку GRUB_CMDLINE_LINUX=" " дописав iommu=soft между кавычками.
Затем выполнить sudo update grub
Перезагрузиться, снова войти в BIOS и установить DISABLED для IOMMU Controller.

Ответить