Шумит кулер в моноблоке

Ответить
mexx400
Сообщения: 396
Зарегистрирован: 13 окт 2013, 16:06
Operating system: Ноутбук MSI & ROSA R10 Plasma [amd64] & Debian 8 MATE [amd64]

Шумит кулер в моноблоке

Сообщение mexx400 » 08 авг 2018, 14:41

Здравствуйте. Предпенсионного возраста моноблок Sony VPCL14M1R - https://www.sony.ru/electronics/support ... ifications - под ROSA10/64/Plasma. При включении моноблока какой-то кулер на пару секунд завывает на максимальных оборотах, потом падает до некого среднего, но некомфортного для уха, значения и на этом уровне жужжит потом всё время. Аналогичное жужжание, насколько помню, было всегда, в том чиcле и под заводской Windows. Поскольку сегодняшнее использование моноблока это 100% серфинг + текстовый редактор, хотелось бы это жужжание программным путем убрать (снизить до комфортного).
От темы далек. После первичного поиска вот так:

Код: Выделить всё

systemctl status lm_sensors
● lm_sensors.service - Initialize hardware monitoring sensors
Loaded: loaded (/lib/systemd/system/lm_sensors.service; enabled; vendor preset: enabled)
Active: active (exited) since Ср 2018-08-08 00:49:08 MSK; 4min 6s ago
Process: 5879 ExecStart=/usr/bin/sensors -s (code=exited, status=0/SUCCESS)
Process: 5867 ExecStart=/sbin/modprobe -qab $BUS_MODULES $HWMON_MODULES (code=exited, status=0/SUCCESS)
Main PID: 5879 (code=exited, status=0/SUCCESS)

авг 08 00:49:08 VPCL14M1R systemd[1]: Starting Initialize hardware monitoring sensors...
авг 08 00:49:08 VPCL14M1R systemd[1]: Started Initialize hardware monitoring sensors.

Код: Выделить всё

sudo sensors-detect
# sensors-detect revision 6284 (2015-05-31 14:00:33 +0200)
# System: Sony Corporation VPCL14M1R [C6U1K88X]
# Board: Sony Corporation VAIO
# Kernel: 4.9.111-nrj-desktop-2rosa-x86_64 x86_64
# Processor: Intel(R) Core(TM)2 Duo CPU E7600 @ 3.06GHz (6/23/10)

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you're doing.

Some south bridges, CPUs or memory controllers contain embedded sensors.
Do you want to scan for them? This is totally safe. (YES/no): y
Module cpuid loaded successfully.
Silicon Integrated Systems SIS5595... No
VIA VT82C686 Integrated Sensors... No
VIA VT8231 Integrated Sensors... No
AMD K8 thermal sensors... No
AMD Family 10h thermal sensors... No
AMD Family 11h thermal sensors... No
AMD Family 12h and 14h thermal sensors... No
AMD Family 15h thermal sensors... No
AMD Family 16h thermal sensors... No
AMD Family 15h power sensors... No
AMD Family 16h power sensors... No
Intel digital thermal sensor... Success!
(driver `coretemp')
Intel AMB FB-DIMM thermal sensor... No
Intel 5500/5520/X58 thermal sensor... No
VIA C7 thermal sensor... No
VIA Nano thermal sensor... No

Some Super I/O chips contain embedded sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no): y
Probing for Super-I/O at 0x2e/0x2f
Trying family `National Semiconductor/ITE'... No
Trying family `SMSC'... No
Trying family `VIA/Winbond/Nuvoton/Fintek'... No
Trying family `ITE'... No
Probing for Super-I/O at 0x4e/0x4f
Trying family `National Semiconductor/ITE'... No
Trying family `SMSC'... No
Trying family `VIA/Winbond/Nuvoton/Fintek'... No
Trying family `ITE'... No

Some systems (mainly servers) implement IPMI, a set of common interfaces
through which system health data may be retrieved, amongst other things.
We first try to get the information from SMBIOS. If we don't find it
there, we have to read from arbitrary I/O ports to probe for such
interfaces. This is normally safe. Do you want to scan for IPMI
interfaces? (YES/no): y
Probing for `IPMI BMC KCS' at 0xca0... No
Probing for `IPMI BMC SMIC' at 0xca8... No

Some hardware monitoring chips are accessible through the ISA I/O ports.
We have to write to arbitrary I/O ports to probe them. This is usually
safe though. Yes, you do have ISA I/O ports even if you do not have any
ISA slots! Do you want to scan the ISA I/O ports? (YES/no): y
Probing for `National Semiconductor LM78' at 0x290... No
Probing for `National Semiconductor LM79' at 0x290... No
Probing for `Winbond W83781D' at 0x290... No
Probing for `Winbond W83782D' at 0x290... No

Lastly, we can probe the I2C/SMBus adapters for connected hardware
monitoring devices. This is the most risky part, and while it works
reasonably well on most systems, it has been reported to cause trouble
on some systems.
Do you want to probe the I2C/SMBus adapters now? (YES/no): y
Using driver `i2c-i801' for device 0000:00:1f.3: Intel ICH10
Module i2c-dev loaded successfully.

Next adapter: SMBus I801 adapter at 0400 (i2c-0)
Do you want to scan it? (YES/no/selectively): y
Client found at address 0x2f
Probing for `National Semiconductor LM78'... No
Probing for `National Semiconductor LM79'... No
Probing for `National Semiconductor LM80'... No
Probing for `National Semiconductor LM96080'... No
Probing for `TI / National Semiconductor ADC128D818'... No
Probing for `Analog Devices ADT7470'... No
Probing for `Winbond W83781D'... No
Probing for `Winbond W83782D'... No
Probing for `Winbond W83791D'... No
Probing for `Winbond W83792D'... No
Probing for `Winbond W83793R/G'... No
Probing for `Nuvoton W83795G/ADG'... No
Probing for `Nuvoton NCT7802Y'... No
Probing for `Winbond W83627HF'... No
Probing for `Winbond W83627EHF'... No
Probing for `Winbond W83627DHG/W83667HG/W83677HG'... No
Probing for `Asus AS99127F (rev.1)'... No
Probing for `Asus AS99127F (rev.2)'... No
Probing for `Asus ASB100 Bach'... No
Probing for `Winbond W83L786NR/NG/R/G'... No
Probing for `Analog Devices ADM9240'... No
Probing for `Dallas Semiconductor DS1780'... No
Probing for `National Semiconductor LM81'... No
Probing for `Maxim MAX6639'... No
Probing for `Analog Devices ADM1029'... No
Probing for `ITE IT8712F'... No
Probing for `SMSC EMC2104'... No
Probing for `Fintek custom power control IC'... No
Probing for `Winbond W83791SD'... No
Client found at address 0x50
Probing for `Analog Devices ADM1033'... No
Probing for `Analog Devices ADM1034'... No
Probing for `SPD EEPROM'... Yes
(confidence 8, not a hardware monitoring chip)
Probing for `EDID EEPROM'... No
Client found at address 0x52
Probing for `Analog Devices ADM1033'... No
Probing for `Analog Devices ADM1034'... No
Probing for `SPD EEPROM'... Yes
(confidence 8, not a hardware monitoring chip)

Next adapter: NVIDIA i2c adapter 0 at 1:00.0 (i2c-1)
Do you want to scan it? (yes/NO/selectively): y

Next adapter: NVIDIA i2c adapter 1 at 1:00.0 (i2c-2)
Do you want to scan it? (yes/NO/selectively): y

Next adapter: NVIDIA i2c adapter 2 at 1:00.0 (i2c-3)
Do you want to scan it? (yes/NO/selectively): y

Next adapter: NVIDIA i2c adapter 5 at 1:00.0 (i2c-4)
Do you want to scan it? (yes/NO/selectively): y

Now follows a summary of the probes I have just done.
Just press ENTER to continue:

Driver `coretemp':
* Chip `Intel digital thermal sensor' (confidence: 9)

Do you want to overwrite /etc/sysconfig/lm_sensors? (YES/no): y
Unloading i2c-dev... OK
Unloading cpuid... OK
coretemp-isa-0000
Adapter: ISA adapter
Core 0: +40.0°C (high = +76.0°C, crit = +100.0°C)
Core 1: +34.0°C (high = +76.0°C, crit = +100.0°C)

Код: Выделить всё

sudo pwmconfig
# pwmconfig revision 6243 (2014-03-20)
This program will search your sensors for pulse width modulation (pwm)
controls, and test each one to see if it controls a fan on
your motherboard. Note that many motherboards do not have pwm
circuitry installed, even if your sensor chip supports pwm.

We will attempt to briefly stop each fan using the pwm controls.
The program will attempt to restore each fan to full speed
after testing. However, it is ** very important ** that you
physically verify that the fans have been to full speed
after the program has completed.

/usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed

Код: Выделить всё

sudo fancontrol
Loading configuration from /etc/fancontrol ...
Error: Can't read configuration file
Подскажите, куда идти дальше?
Debian 8 MATE [amd64]
ROSA Desktop R10 Plasma [amd64] *4
ROSA Desktop R10 Plasma [x86]

mexx400
Сообщения: 396
Зарегистрирован: 13 окт 2013, 16:06
Operating system: Ноутбук MSI & ROSA R10 Plasma [amd64] & Debian 8 MATE [amd64]

Шумит кулер в моноблоке

Сообщение mexx400 » 08 авг 2018, 17:13

В BIOS:
MS_BIOS.JPG
И все RPM "живые". Открыть корпус не вариант.
Debian 8 MATE [amd64]
ROSA Desktop R10 Plasma [amd64] *4
ROSA Desktop R10 Plasma [x86]

keleg
Сообщения: 5308
Зарегистрирован: 15 сен 2011, 01:58

Шумит кулер в моноблоке

Сообщение keleg » 09 авг 2018, 07:56

похоже, если комп старый и "There are no pwm-capable sensor modules installed" - там нет программного управления.
Искать в биос или менять вентилятор. Ну или кондиционер в комнату ставить.

mexx400
Сообщения: 396
Зарегистрирован: 13 окт 2013, 16:06
Operating system: Ноутбук MSI & ROSA R10 Plasma [amd64] & Debian 8 MATE [amd64]

Шумит кулер в моноблоке

Сообщение mexx400 » 16 авг 2018, 14:52

keleg писал(а):
09 авг 2018, 07:56
похоже, если комп старый и "There are no pwm-capable sensor modules installed" - там нет программного управления
Вот нашел в сообществе Sony:
Вам не надо искать способов обойти настройки BIOS, в которых специально закрыт доступ в управлению охлаждением! Этим процессом управляет VAIO Control Center, в котором вам надо зайти в закладку Управление питанием/Электропитание, а там справа в разделе "Стратегия нагрева" выбрать позицию "Режим тишины"...
Получается, ПО для Windows может как-то управлять режимом кулера? Если так, значит программная регулировка возможна?
keleg писал(а):
09 авг 2018, 07:56
Искать в биос
Нет, там всё по минимуму, регулировка не предусмотрена.
Debian 8 MATE [amd64]
ROSA Desktop R10 Plasma [amd64] *4
ROSA Desktop R10 Plasma [x86]

Аватара пользователя
Barmalei
Сообщения: 4629
Зарегистрирован: 29 дек 2014, 15:45
Operating system: Intel Pentium 2020M / 6 Gb RAM / AMD GRadeon HD 8570 / Rosa Fresh R10 KDE 2016.1 x64

Шумит кулер в моноблоке

Сообщение Barmalei » 16 авг 2018, 15:31

Драйвера для Windows пишут по максимуму, а для Линукс как получится.

Аватара пользователя
Andreas17
Сообщения: 156
Зарегистрирован: 21 май 2017, 20:07
Operating system: AMD Athlon II X4 640 / 12 ГБ ОЗУ / NVIDIA GTX 650 / ROSA FRESH R10
Откуда: Москва

Шумит кулер в моноблоке

Сообщение Andreas17 » 20 авг 2018, 23:06

В виндовом Speedfan видны кулеры? Если нет, то и Линукс не увидит, т.к. управляются нестандартным контроллером.

У меня так с видюхой Palit (производитель сэкономил). Кулер видится только прогой от NVIDIA.

mexx400
Сообщения: 396
Зарегистрирован: 13 окт 2013, 16:06
Operating system: Ноутбук MSI & ROSA R10 Plasma [amd64] & Debian 8 MATE [amd64]

Шумит кулер в моноблоке

Сообщение mexx400 » 21 авг 2018, 13:13

Andreas17 писал(а):
20 авг 2018, 23:06
В виндовом Speedfan видны кулеры?
Не знаю, там только ROSA.
Debian 8 MATE [amd64]
ROSA Desktop R10 Plasma [amd64] *4
ROSA Desktop R10 Plasma [x86]

Ответить