Нет зависимостей для сборки mplayer (пакет из репозитория)

Ответить
Аватара пользователя
Yamah
Сообщения: 1318
Зарегистрирован: 04 май 2012, 06:30
Operating system: Десктоп (дом): Rosa Fresh R8.1, Rosa Fresh R10
Десктоп (работа): Rosa Fresh R8.1/Rosa Fresh R10
Сервер (работа): Rosa Enterprise Linux Sercver 6.7
Нетбук: Rosa Fresh R10
Контактная информация:

Нет зависимостей для сборки mplayer (пакет из репозитория)

Сообщение Yamah » 03 дек 2014, 11:14

rpmbuild -ba mplayer.spec
error: Неудовлетворенные зависимости сборки:
libdxr3-devel нужен для mplayer-1.1.1-2.r36417.11.src

rpmbuild --rebuild mplayer-1.1.1-2.r36417.11.src.rpm
Устанавливается mplayer-1.1.1-2.r36417.11.src.rpm
error: Неудовлетворенные зависимости сборки:
libdxr3-devel нужен для mplayer-1.1.1-2.r36417.11.src
Где его взять непонятно.

Изначально нужно было собрать mplayer из ревизии 37329 (там вроде как поддержка x265 есть).

Аватара пользователя
Pulfer
Сообщения: 3358
Зарегистрирован: 15 фев 2012, 01:57
Operating system: ROSA Desktop Fresh 2016.1 i586
Откуда: Vladivostok, Russia

Re: Нет зависимостей для сборки mplayer (пакет из репозитория)

Сообщение Pulfer » 03 дек 2014, 15:55

В rosa2014.1 этого пакета нет и для сборки mplayer он больше не используется. Можно эту зависимость просто убрать из спека.
Intel Core i7-6700 / 8 Gb RAM / GeForce GTX 750 Ti / Rosa 2016.1 i586

Аватара пользователя
Yamah
Сообщения: 1318
Зарегистрирован: 04 май 2012, 06:30
Operating system: Десктоп (дом): Rosa Fresh R8.1, Rosa Fresh R10
Десктоп (работа): Rosa Fresh R8.1/Rosa Fresh R10
Сервер (работа): Rosa Enterprise Linux Sercver 6.7
Нетбук: Rosa Fresh R10
Контактная информация:

Re: Нет зависимостей для сборки mplayer (пакет из репозитория)

Сообщение Yamah » 03 дек 2014, 17:13

Pulfer писал(а):В rosa2014.1 этого пакета нет и для сборки mplayer он больше не используется. Можно эту зависимость просто убрать из спека.
Спасибо!

Ответить