Несовместимый репозиторий NicCo

Вопросы и обсуждения, касающиеся РОСА Марафон (релиз с долговременной поддержкой)
Ответить
Аватара пользователя
Zeffanyx
Сообщения: 1106
Зарегистрирован: 12 сен 2011, 13:25
Operating system: Rosa Fresh R10, OpenMandriva Lx 3.03
Откуда: Санкт-Петербург

Несовместимый репозиторий NicCo

Сообщение Zeffanyx » 19 янв 2015, 10:41

Столкнулся с неприятным и не до конца понятным моментом. Мне захотелось поставить свежую версию ядра на Rosa Marathon X1.
Я подключил к системе данный репозиторий:
http://abf-downloads.rosalinux.ru/kerne ... n/release/
Но Rpmdrake не смог показать мне пакеты из него. При запуске из командной строки стал ругаться, чего раньше не было. Тогда я скачал пакеты вручную и поставил их через rpm -Uvh *.rpm. Пакеты корректно установились, я смог нормально перезагрузиться с новеньким ядром.
Однако при этом у меня ВООБЩЕ сломался rpmdrake, при загрузке списка пакетов он стал вываливать сообщение о каких-то перловых ошибках.
консольный urpmi работал, но сыпал ошибки типа BDB2017 Freeing mutex for process: ...
Я не сразу понял источник проблемы и поначалу пытался понять, не сломал ли я себе Perl где-то. Но выяснилось, что стоит только удалить все пакеты из того репозитория, как rpmdrake восстанавливает работоспособность. Причём, я оставил себе ядро, удалив пакеты только из базы (--justdb).
Вопрос: ЧТО ЭТО БЫЛО?
Что-то поменялось в формате репозитория? А что тогда с пакетами? Один rpm 5.x несовместим с другим rpm 5.x? Тестируются ли вообще репозитории для Marathon?

Аватара пользователя
Галахов Роман
Сообщения: 2266
Зарегистрирован: 26 фев 2012, 19:02
Operating system: Rosa 2016.1 Fresh KDE (HP ProBook 440 G4 (y7z81ea))
Откуда: Моск. обл. Волоколамск

Re: Несовместимый репозиторий NicCo

Сообщение Галахов Роман » 19 янв 2015, 18:49

Zeffanyx писал(а):Столкнулся с неприятным и не до конца понятным моментом. Мне захотелось поставить свежую версию ядра на Rosa Marathon X1.
Я подключил к системе данный репозиторий:
http://abf-downloads.rosalinux.ru/kerne ... n/release/
Но Rpmdrake не смог показать мне пакеты из него. При запуске из командной строки стал ругаться, чего раньше не было. Тогда я скачал пакеты вручную и поставил их через rpm -Uvh *.rpm. Пакеты корректно установились, я смог нормально перезагрузиться с новеньким ядром.
Однако при этом у меня ВООБЩЕ сломался rpmdrake, при загрузке списка пакетов он стал вываливать сообщение о каких-то перловых ошибках.
консольный urpmi работал, но сыпал ошибки типа BDB2017 Freeing mutex for process: ...
Я не сразу понял источник проблемы и поначалу пытался понять, не сломал ли я себе Perl где-то. Но выяснилось, что стоит только удалить все пакеты из того репозитория, как rpmdrake восстанавливает работоспособность. Причём, я оставил себе ядро, удалив пакеты только из базы (--justdb).
Вопрос: ЧТО ЭТО БЫЛО?
Что-то поменялось в формате репозитория? А что тогда с пакетами? Один rpm 5.x несовместим с другим rpm 5.x? Тестируются ли вообще репозитории для Marathon?
А почему вы думаете, что данное ядро можно ставить на марафон? NiCco же четко указал:
Kernel 3.17.8 for ROSA 2012 2012.1 2014.1 OMV2014 2015
http://forum.rosalab.ru/viewtopic.php?f ... 200#p37016
А когда можно на Марафон он это указывает, например
Kernel 3.4.33 nrjQL for ROSA Marathon 2012.0 & MDV 2010 2011
http://forum.rosalab.ru/viewtopic.php?f ... 223#p14174
Зачем на Марафон ставить то, что не указал NicCo? Перед тем как ставить ядра, надо заглянуть в ту тему и посмотреть можно ставить или нет, если, конечно, вы разбираетесь в ядрах хуже NicCo.
Rosa 2016.1 Fresh KDE5 x64-86 (HP ProBook 440 G4 (y7z81ea))

keleg
Сообщения: 5202
Зарегистрирован: 15 сен 2011, 00:58

Re: Несовместимый репозиторий NicCo

Сообщение keleg » 19 янв 2015, 18:53

Не, там в теме манафон и дальше 2012lts

Аватара пользователя
Zeffanyx
Сообщения: 1106
Зарегистрирован: 12 сен 2011, 13:25
Operating system: Rosa Fresh R10, OpenMandriva Lx 3.03
Откуда: Санкт-Петербург

Re: Несовместимый репозиторий NicCo

Сообщение Zeffanyx » 19 янв 2015, 20:31

В адресе
http://abf-downloads.rosalinux.ru/kerne ... n/release/
что такое rosa2012lts, по вашему?

NicCo
Сообщения: 276
Зарегистрирован: 06 май 2012, 19:37

Re: Несовместимый репозиторий NicCo

Сообщение NicCo » 22 янв 2015, 17:22

Для меня: ROSA 2012 = ROSA 2012.0 LTS или Marathon X1

Мои PHPBB названия темы есть проблемы с принятием больше персонажей ..., в следующий раз я буду удалять omv2013 из названия


В настоящее время мой ROSA Marathon X1 (x86_64) работает 3.18.1
Конечно, я использую все свободное драйвер, нет старый проприетарный драйвер (NVIDIA / ATI и / или другие DKMS), что, безусловно, будет иметь проблемы в присутствии последних ядер

до свидания

Аватара пользователя
Zeffanyx
Сообщения: 1106
Зарегистрирован: 12 сен 2011, 13:25
Operating system: Rosa Fresh R10, OpenMandriva Lx 3.03
Откуда: Санкт-Петербург

Re: Несовместимый репозиторий NicCo

Сообщение Zeffanyx » 23 янв 2015, 09:35

Я тоже так умею:
Non è il driver video e non nel nucleo. Il problema è che il repository stesso ha qualche altro formato. URPMI può installare pacchetti da essa, ma rpmdrake non lo vedi. Se almeno un pacchetto del repository è impostato, rpmdrake pause. Ho visto qualcosa di simile quando ha cercato di prendere i pacchetti da OMV Cooker. Dimmi, si fa a controllare il kernel su sistemi reali, o semplicemente raccogliere automaticamente ABF?
Ti auguro il meglio!

NicCo
Сообщения: 276
Зарегистрирован: 06 май 2012, 19:37

Re: Несовместимый репозиторий NicCo

Сообщение NicCo » 23 янв 2015, 10:21

I use drakrpm not often. I use urpmi to update kernels on Marathon,
you may try adding the --update to the urpmi.addmedia command

just for example

Kernel 3.18 for ROSA 2014.1 32-bit

Код: Выделить всё

urpmi.addmedia --update Kernel318 http://abf-downloads.rosalinux.ru/kernels_3_18x_personal/repository/rosa2014.1/i586/main/release/
Kernel 3.18 for ROSA 2014.1 64-bit

Код: Выделить всё

urpmi.addmedia --update Kernel318 http://abf-downloads.rosalinux.ru/kernels_3_18x_personal/repository/rosa2014.1/x86_64/main/release/
this morning is avalaible Kernel 3.18.2, I have already installed it on my Marathon 64bit with urpmi, all is smooth for my PC

Аватара пользователя
Zeffanyx
Сообщения: 1106
Зарегистрирован: 12 сен 2011, 13:25
Operating system: Rosa Fresh R10, OpenMandriva Lx 3.03
Откуда: Санкт-Петербург

Re: Несовместимый репозиторий NicCo

Сообщение Zeffanyx » 23 янв 2015, 11:08

I'll try to check it as soon as I get to my Marathon machine.

NicCo
Сообщения: 276
Зарегистрирован: 06 май 2012, 19:37

Re: Несовместимый репозиторий NicCo

Сообщение NicCo » 28 янв 2015, 13:44

Zeffanyx писал(а):I'll try to check it as soon as I get to my Marathon machine.
this morning is avalable Kernel 3.18.3,
I have already installed it also on my Marathon 64bit with urpmi, everything is smooth for my PCs

Аватара пользователя
Zeffanyx
Сообщения: 1106
Зарегистрирован: 12 сен 2011, 13:25
Operating system: Rosa Fresh R10, OpenMandriva Lx 3.03
Откуда: Санкт-Петербург

Re: Несовместимый репозиторий NicCo

Сообщение Zeffanyx » 28 янв 2015, 14:11

NicCo писал(а):everything is smooth for my PCs
Can you confirm that rpmdrake also works correctly?

NicCo
Сообщения: 276
Зарегистрирован: 06 май 2012, 19:37

Re: Несовместимый репозиторий NicCo

Сообщение NicCo » 28 янв 2015, 14:23

I have already installed it with the "urpmi" command,
(why not using urpmi?)

I'll try with the "rpmdrake" with next kernel 3.18.4 ...
(I hope will be ready asap)

Аватара пользователя
Zeffanyx
Сообщения: 1106
Зарегистрирован: 12 сен 2011, 13:25
Operating system: Rosa Fresh R10, OpenMandriva Lx 3.03
Откуда: Санкт-Петербург

Re: Несовместимый репозиторий NicCo

Сообщение Zeffanyx » 28 янв 2015, 14:52

NicCo писал(а):I have already installed it with the "urpmi" command,
(why not using urpmi?)
Because in my case the new packages from your repo break rpmdrake, while urpmi continues to work correctly. I assume that it is unacceptable if a package breaks graphical package management tool, isn't it?

d_uragan
Сообщения: 503
Зарегистрирован: 23 ноя 2011, 20:27

Re: Несовместимый репозиторий NicCo

Сообщение d_uragan » 05 фев 2015, 12:10

The problem is that perl-URPM package in Marathon (responsible for parsing repository metadata) is not able to parse metadata from NicCo's personal repositories for the new kernels. We have backported a patch for this from ROSA Fresh, the new perl-URPM (perl-URPM-4.43-6) should come with updates soon.

Аватара пользователя
Zeffanyx
Сообщения: 1106
Зарегистрирован: 12 сен 2011, 13:25
Operating system: Rosa Fresh R10, OpenMandriva Lx 3.03
Откуда: Санкт-Петербург

Re: Несовместимый репозиторий NicCo

Сообщение Zeffanyx » 05 фев 2015, 12:59

Great, many thanks!

NicCo
Сообщения: 276
Зарегистрирован: 06 май 2012, 19:37

Re: Несовместимый репозиторий NicCo

Сообщение NicCo » 27 фев 2015, 12:58

after latest update into my ROSA MArathon
perl-URPM from 4.43-5 to 4.43-6 version

Код: Выделить всё

[b]perl-URPM[/b] - Modulo di Perl URPM​                                                                                                                         
The URPM module allows you to manipulate rpm files, rpm header files and hdlist files and manage them in memory.

Versione: 4.43-6-rosa.lts2012.0
        Versione attualmente installata: 4.43-5
        Gruppo: Sviluppo/Perl
        Architettura: x86_64
        Dimensioni: 466 kB
        Fonte: Main_64_updates
        URL: 
        
   * gio 05 feb 2015 13:00:00 CET Denis Silakov <denis.silakov@rosalab.ru> 4.43-6
        + Revision: 521102f
        - BAckport bufsize increment
I add the kernel 3.18 as repository, then

Код: Выделить всё

# urpmi.addmedia Kernel_3.18 --update http://abf.rosalinux.ru/downloads/kernels_3_18x_personal/repository/rosa2012lts/x86_64/main/release]
installing kernel 3.18 using URPMI is OK
before perl-URPM update, urpm crashed if used by remote downloads, it worked only from local files (w/o using lists.cz)

Код: Выделить всё

localhost ~ # LC_ALL=C urpmi --auto-update
.......................................................
medium "Kernel_3.18" is up-to-date
To satisfy dependencies, the following packages are going to be installed:
 Package                        Version      Release       Dist  DEpoch Arch 
(medium "Kernel_3.18")
 cpupower                       3.18.6       1             rosa> 2012.0 x86_64 
 kernel-headers                 3.18.6       1             rosa> 2012.0 x86_64 
 kernel-nrj-desktop-3.18.6-1ro> 1            1             rosa> 2012.0 x86_64 
 kernel-nrj-desktop-devel-3.18> 1            1             rosa> 2012.0 x86_64 
 kernel-nrj-desktop-devel-late> 3.18.6       1             rosa> 2012.0 x86_64 
 kernel-nrj-desktop-latest      3.18.6       1             rosa> 2012.0 x86_64 
82MB of additional disk space will be used.
54MB of packages will be retrieved.
Proceed with the installation of the 6 packages? (Y/n)
drakrpm / rpmdrake : ok because now lists.cz are generated and managed properly, I can see the installed 3.18.6 in the gui

currently 3.18 repository has 3.18.6, in few hours there will be also 3.18.7 > http://forum.rosalab.ru/viewtopic.php?f ... 200#p39426

bye, NicCo

NicCo
Сообщения: 276
Зарегистрирован: 06 май 2012, 19:37

Re: Несовместимый репозиторий NicCo

Сообщение NicCo » 27 фев 2015, 14:26

after the first reboot, everything is working fine...

Код: Выделить всё

$ cat /etc/product.id; uname -a; uptime

vendor=ROSA Marathon,distribution=ROSA Marathon,type=Basic,version=2012.0,branch=Official,release=1,arch=x86_64,product=One

Linux localhost.localdomain 3.18.6-nrj-desktop-1rosa.lts #1 SMP PREEMPT Thu Feb 26 10:45:24 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

 12:37:00 up 3 min,  5 users,  load average: 9.23, 4.32, 1.66
below, it's my HW and SW configuration:

Код: Выделить всё

$ inxi -F
System:    Host: localhost.localdomain Kernel: 3.18.6-nrj-desktop-1rosa.lts x86_64 (64 bit) 
           Desktop: KDE 4.8.3 Distro: ROSALinux 2012.0 turtle
Machine:   Mobo: ASUSTek model: M2NPV-VM version: 1.xx Bios: Phoenix version: ASUS M2NPV-VM 1401 date: 08/07/2008
CPU:       Dual core AMD Athlon 64 X2 6400+ (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 svm) 
           Clock Speeds: 1: 3206.645 MHz 2: 3206.645 MHz
Graphics:  Card: nVidia C51PV [GeForce 6150] X.Org: 1.10.3 drivers: nv (unloaded: vesa,fbdev) Resolution: 1280x1024@60.0hz 
           GLX Renderer: Gallium 0.4 on llvmpipe GLX Version: 2.1 Mesa 7.11.2
Audio:     Card-1: nVidia MCP51 High Definition Audio driver: snd_hda_intel Sound: ALSA ver: k3.18.6-nrj-desktop-1rosa.lts
           Card-2: Creative Labs SB Audigy driver: snd_emu10k1 
Network:   Card: nVidia MCP51 Ethernet Controller driver: forcedeth 
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:18:f3:e2:1d:f4
Drives:    HDD Total Size: 5001.0GB (17.7% used) 1: id: /dev/sda model: ST31000528AS size: 1000.2GB 
           2: id: /dev/sdb model: WDC_WD20EARS size: 2000.4GB 3: id: /dev/sdc model: WDC_WD20EARS size: 2000.4GB 
Partition: ID: / size: 50G used: 15G (32%) fs: ext4 ID: /home size: 366G used: 357G (98%) fs: ext4 
           ID: swap-1 size: 10.74GB used: 0.00GB (0%) fs: swap ID: swap-2 size: 10.74GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 19.0C mobo: 22.0C 
           Fan Speeds (in rpm): cpu: 3341 sys-1: 0 
Info:      Processes: 271 Uptime: 5 min Memory: 1925.5/3921.9MB Client: Shell (bash) inxi: 1.9.14 

Аватара пользователя
Zeffanyx
Сообщения: 1106
Зарегистрирован: 12 сен 2011, 13:25
Operating system: Rosa Fresh R10, OpenMandriva Lx 3.03
Откуда: Санкт-Петербург

Re: Несовместимый репозиторий NicCo

Сообщение Zeffanyx » 27 фев 2015, 15:51

You can see above that perl-URPM was recently updated and that fixed the issue. But I still wonder how can you roll out a kernel for a LTS distro without checking if it's working fine. Surely there used to be a huge problem, but now it's finally solved.

NicCo
Сообщения: 276
Зарегистрирован: 06 май 2012, 19:37

Re: Несовместимый репозиторий NicCo

Сообщение NicCo » 27 фев 2015, 17:05

Zeffanyx писал(а):You can see above that perl-URPM was recently updated and that fixed the issue. But I still wonder how can you roll out a kernel for a LTS distro without checking if it's working fine. Surely there used to be a huge problem, but now it's finally solved.
The Official kernel for ROSA Marathon is Kernel 3.0.x serie
The modern and current kernel, like 3.18, are intended as an optional chance, for who need support for new hardware, are NOT official

I have tested all kernels into my ROSA Marathon developer PC, but, I used the rpms produced and built in my own PC, installing with:

# rpm -ivh /local_path/kernel....
or
# urpmi /local_path/kernel....

without quering the lists.cz, so I am sorry, I did not realized about the issue that started only lately, after around the kernel 3.14.x serie

but now it's finally solved. :-)
bye

Ответить