master-pdf-editor: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by master-pdf-editor)

Ответить
rolf
Сообщения: 20
Зарегистрирован: 30 май 2013, 17:18
Operating system: ROSA Desktop.Fresh release 2012.1 (Desktop) for x86_64

master-pdf-editor: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by master-pdf-editor)

Сообщение rolf » 30 авг 2014, 04:06

I am running an installation of ROSA release 2012.0 (LTS) for x86_64.

Several times, when I try to build or install a software that is fairly current, I get a failed dependency on glibc-2.14. There is glibc-2.13-7 in LTS. In 2012.1, there is glibc-2.15-8. For this particular software, there is an rpm and the requires show:

Код: Выделить всё

$ rpm -qp --requires master-pdf-editor-1.9.25.x86_64.rpm 
libQtCore.so.4()(64bit)
libQtGui.so.4()(64bit)
libQtNetwork.so.4()(64bit)
libc.so.6()(64bit)
libc.so.6(GLIBC_2.11)(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libc.so.6(GLIBC_2.7)(64bit)
libfreetype.so.6()(64bit)
libgcc_s.so.1()(64bit)
libgcc_s.so.1(GCC_3.0)(64bit)
libm.so.6()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libpthread.so.0()(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libstdc++.so.6()(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)
BTW, I also run into rpm version dependency failures but glibc is all that is reported, at first, when I try to install this rpm.

I wonder, if I had 2012.1 with glibc-2.15-8, would GLIBC_2.14 be satisfied by some backwards compatibility? I see various older glibc versions in the requires and that seems to suggest backward compatibility but idk.

If 2012.1 would satisfy glibc requirements for this and other such softwares, is it possible to just switch media sources to 2012.1 and update with urpmi?
:o

Аватара пользователя
ДроноваЮ
Сообщения: 2636
Зарегистрирован: 01 июн 2011, 12:11
Operating system: Ubuntu/ROSA
Откуда: Москва

Re: master-pdf-editor: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by master-pdf-editor)

Сообщение ДроноваЮ » 30 авг 2014, 23:40

rolf писал(а):is it possible to just switch media sources to 2012.1 and update with urpmi?
No, by various reasons. :( Only clean installation. If your hardware is ok for Fresh (aka 2012.1), just install it.

rolf
Сообщения: 20
Зарегистрирован: 30 май 2013, 17:18
Operating system: ROSA Desktop.Fresh release 2012.1 (Desktop) for x86_64

Re: master-pdf-editor: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by master-pdf-editor)

Сообщение rolf » 31 авг 2014, 06:24

just install it.
Ok, thanks for the instruction. :)

Ответить