ROSA Server R12

ROSA Enterprise Linux Server -- вопросы и проблемы
Правила форума
Уважаемые пользователи! Поддержка, ответы на вопросы и проблемы по серверу принимаются:
1) на багзилле http://bugs.rosalinux.ru/enter_bug.cgi? ... A%20Server
2) или после заполнения формы на http://www.rosalab.ru/products/server/download вы получаете 30 дней БЕСПЛАТНОЙ техподдержки по серверу.
Ответы на ваши вопросы на форуме НЕ ГАРАНТИРУЮТСЯ. Спасибо за понимание!
Ответить
PastorDi
Сообщения: 2742
Зарегистрирован: 25 авг 2011, 12:34
Operating system: IBM DOS, OS/2
Откуда: Санкт-Петербург
Контактная информация:

ROSA Server R12

Сообщение PastorDi » 21 май 2022, 11:58

ROSA Server R12

Серверный образ Росы R12 в минимальной сборке, без DE. ssh сервер по дефолту включен.

https://abf.io/platforms/rosa2021.1/pro ... ists/43173

Mad AlexX
Сообщения: 54
Зарегистрирован: 16 окт 2014, 14:49
Operating system: Rosa, OpenSuse

ROSA Server R12

Сообщение Mad AlexX » 11 июл 2022, 06:10

Небольшой BugReport. Запустил в виртуалке более свежий образ - ROSA_2021.1_SERVER_x86_64_43728.iso. На окне выбора языка выдаётся ошибка: Unable to find osimg for /dev/mapper/live-base
unable_to_find_osimg.png
Причём окно "Неизвестная ошибка", хотя и отрисовывается поверх, но нажать можно только кнопку "Выход из установки" из другого окна находящегося под ним. Соответственно "Подробнее" и "Сообщить об ошибке" невозможно нажать.

Обновляю сообщение 15.07.2022: с образом ROSA_2021.1_SERVER_x86_64_44022.iso собранного 2022-07-14 08:24:54 UTC установка проходит успешно. Но ОС не загружается в графическом режиме - выдаётся сообщение "Failed to start Initialize hardware monitoring sensors" (запускал в виртуалке).

Mad AlexX
Сообщения: 54
Зарегистрирован: 16 окт 2014, 14:49
Operating system: Rosa, OpenSuse

ROSA Server R12

Сообщение Mad AlexX » 02 авг 2022, 05:24

С образом ROSA_2021.1_SERVER_x86_64_44160.iso по-прежнему не загружается графический режим после установки: на секунду появляется надпись "Failed to start Initialize hardware monitoring sensors" и дальше работа продолжается в текстовом режиме.

irton
Сообщения: 353
Зарегистрирован: 30 окт 2021, 04:17
Operating system: PuppyRus linux

ROSA Server R12

Сообщение irton » 02 авг 2022, 16:15

В сервере нет xorg. Ошибка насчет сенсоров, это нормально т.к. в виртуалке их нет.

Raskaton
Сообщения: 7
Зарегистрирован: 05 ноя 2022, 03:45
Operating system: ROSA Fresh Desktop 2021.1
ROSA Fresh Server 2021.1

ROSA Server R12

Сообщение Raskaton » 15 ноя 2022, 20:11

Гхм... а сеть то чего не работает?
Установил, перенёс на место, а адрес по DHCP не получает. Никак вообще в сети не появляется.
Единственный вариант был указание статического ip при установке что ли?

Доп.:
Так и пришлось сервер к монитору тащить. Разобрался. Оказалось, что для моего интерфейса "ONBOOT=no" почему-то в файле:

Код: Выделить всё

/etc/sysconfig/network-scripts/ifcfg-enp0s8
NetworkManadger, наверное, через команду "nmcli" можно настроить, но я исправил в файле на

Код: Выделить всё

BOOTPROTO=dhcp
ONBOOT=yes
после перезагрузки заработала сеть и получала адреса по dhcp.
ipv6 тоже из коробки заработал. По ssh с удалённого хоста подключился.
Непонятно почему так произошло. При установке, я только hostname задавал, а сеть вообще не трогал. Провод тоже не подключался. Адаптер сетевой в установщике было видно.

Осталось выяснить почему не работает "Wake On Lan". То ли NetworkManadger, то ли systemd клинят драйвер адаптера. В биосе всё включено и линк светится на адаптере на выключенной системе.

Вообще, не хватает описание к дистру. Что сеть тут через NetworkManadger, что установщики rpm и dnf.
А то не ясно новичку даже, что гуглить.

Ответить