How to install GIMP 2.10

Ответить
Аватара пользователя
rickin
Сообщения: 34
Зарегистрирован: 06 мар 2018, 16:22
Operating system: Linux dx 4.9.76-nrj-desktop-1rosa-x86_64

How to install GIMP 2.10

Сообщение rickin » 29 апр 2018, 09:25

Hi all,

As some of you might now, a major stable release of Gimp has arrived, with many more features, improvements. It's been six years since version 2.8 was released. If I try and install in ROSA :

mbt@mbt ~ $ urpmi gimp
To satisfy dependencies, the following packages are going to be installed:
Package Version Release Dist DEpoch Arch
(medium "Main")
gimp-help-2-en 2.6.0 10 rosa 2016.1 noarch (suggested)
(medium "Main Updates")
gimp 2.8.22 2 rosa 2016.1 x86_64
92MB of additional disk space will be used.
37MB of packages will be retrieved.
Proceed with the installation of the 2 packages? (Y/n)

You see ROSA still has version 2.8.22 which is of no surprise.

The article I found about the release had install guide, but it was based for Ubuntu users.

This is the article link:

https://itsfoss.com/gimp-2-10-release/

Further down in the article it says :

Get GIMP 2.10 source code
Alternatively, you can always install from source code. You can download the source code from the link below:

https://download.gimp.org/mirror/pub/gimp/v2.10/

When I visit this link would I be correct in thinking that I would install the option listed as:

gimp-2.10.0.tar.bz2 27-Apr-2018 14:21 29M ?

Further down the page it has two folder one for Linux and one for Windows.

The Linux folder directs you here;

https://download.gimp.org/mirror/pub/gimp/v2.10/linux/

Now I can see this is where they want you to install the Flatpak ( which I have never heard of before )
The Ubuntu guide shows how to install it , but my main question I guess is. On the last link I listed for the Flatpack download ,
I need to install gimp-2.10.0-RC2-x86_64.flatpak ( thats my OS match ). I have no idea how to install gimp-2.10.0-RC2-x86_64.flatpak in ROSA .

I did run urpmi flatpak & ;

mbt@mbt ~ $ urpmi flatpak
To satisfy dependencies, the following packages are going to be installed:
Package Version Release Dist DEpoch Arch
(medium "Main")
lib64seccomp2 2.2.0 3 rosa 2016.1 x86_64
(medium "Main Updates")
bubblewrap 0.1.8 2 rosa 2016.1 x86_64
flatpak 0.9.7 1 rosa 2016.1 x86_64
lib64flatpak-gir1.0 0.9.7 1 rosa 2016.1 x86_64
lib64flatpak0 0.9.7 1 rosa 2016.1 x86_64
lib64ostree1 2017.7 1 rosa 2016.1 x86_64
ostree 2017.7 1 rosa 2016.1 x86_64
4.9MB of additional disk space will be used.
1.2MB of packages will be retrieved.
Proceed with the installation of the 7 packages? (Y/n)

So, without confusing myself anymore, my ultimate question is , could someone assist me to install the new version of Gimp . That would be awesome. !

Thanks all :)

**********************************************************************************************************************************************************************************

Привет всем,

Как некоторые из вас могли бы сейчас, основной стабильный выпуск Gimp прибыл, со многими другими функциями, улучшениями. Прошло шесть лет с момента выпуска версии 2.8. Если я попытаюсь установить в ROSA :

mbt@mbt ~ $ urpmi gimp
Для удовлетворения зависимостей будут установлены следующие пакеты:
Версия Пакета Релиз Dist DEpoch Arch
(средний " основной")
gimp-help-2-en 2.6.0 10 rosa 2016.1 noarch (рекомендуется)
(средние " Основные обновления")
gimp 2.8.22 2 роза 2016.1 архитектуру x86_64
Будет использовано 92 МБ дополнительного дискового пространства.
37MB пакеты будут получены.
Продолжить установку 2 пакетов? (Y / n)

Вы видите, что у розы все еще есть версия 2.8.22, что неудивительно.

Статья, которую я нашел о выпуске, имела руководство по установке, но она была основана для пользователей Ubuntu.

Это ссылка на статью:

https://itsfoss.com/gimp-2-10-release/

Далее в статье говорится: :

Получить исходный код GIMP 2.10
Кроме того, вы всегда можете установить из исходных кодов. Вы можете скачать исходный код по ссылке ниже:

https://download.gimp.org/mirror/pub/gimp/v2.10/

Когда я посещаю эту ссылку, я был бы прав, думая, что я установлю опцию, указанную как:

gimp-2.10.0.Тар.bz2, что 27-апр-2018 14:21 29М ?

Далее вниз по странице он имеет две папки один для Linux и один для Windows.

Папка Linux направляет вас сюда;

https://download.gimp.org/mirror/pub/gimp/v2.10/linux/

Теперь я вижу, что они хотят, чтобы вы установили Flatpak ( о котором я никогда не слышал раньше )
Руководство Ubuntu показывает, как установить его, но мой главный вопрос, который я думаю. По последней ссылке я перечислил для скачивания Flatpack ,
Мне нужно установить gimp-2.10.0-RC2-x86_64.flatpak (это мой матч ОС ). Я понятия не имею, как установить gimp-2.10.0-RC2-x86_64.флэтпак в Розе .

Я запустил urpmi flatpak & ;

mbt@mbt ~ $ urpmi flatpak
Для удовлетворения зависимостей будут установлены следующие пакеты:
Версия Пакета Релиз Dist DEpoch Arch
(средний " основной")
lib64seccomp2 2.2.0 3 роза 2016.1 архитектуру x86_64
(средние " Основные обновления")
0.1.8 2 роза bubblewrap 2016.1 архитектуру x86_64
0.9.7 1 flatpak роза 2016.1 архитектуру x86_64
lib64flatpak-gir1.0 0.9.7 1 rosa 2016.1 x86_64
lib64flatpak0 0.9.7 1 роза 2016.1 архитектуру x86_64
lib64ostree1 2017.7 1 роза 2016.1 архитектуру x86_64
острее 2017.7 1 роза 2016.1 архитектуру x86_64
Будет использовано 4,9 МБ дополнительного дискового пространства.
Будет извлечено 1,2 МБ пакетов.
Продолжить установку 7 пакетов? (Y / n)

Так что, не путая себя больше, мой окончательный вопрос, может ли кто-нибудь помочь мне установить новую версию Gimp . Это было бы потрясающе. !

Спасибо всем :)

Ответить