Problème avec pilotes graphiques propriétaires

Ответить
Аватара пользователя
Celtique
Сообщения: 93
Зарегистрирован: 10 дек 2012, 12:29
Operating system: Windows 8

Problème avec pilotes graphiques propriétaires

Сообщение Celtique » 15 май 2013, 20:10

Hello,

Je rencontre un problème avec rosa fresh 2012.1, quand je navigue dans dolphin ou que je lance une application j'ai des barres qui défilent très vite sur mon écran, ça dure juste le temps de l'action, mais ça devient désagréable à la longue.
J'ai rencontré ce problème aussi avec Mageia mais c'était beaucoup plus prononcé qu'avec Rosa.
Sur Mageia j'ai installé les pilotes propriétaires pour voir si cela s'améliorait, en effet je me retrouvais comme avec Rosa, donc j'ai tenté sur Rosa, tout se passe bien, je redémarre mon pc et là j'arrive en console, cela me demande mon login et mon pass mais ça reste en console, le pilote propriétaire à un problème ?

Ma carte: Carte Graphique - ATI Cedar PRO [Radeon HD 5450/6350] et écran AsusVK246H relié en HDMI et l'écran apparaît bien dans la liste de choix de Rosa ...

merci @+

A Noter que je ne rencontre pas ce problème de barres sur l'écran avec le live cd.

Аватара пользователя
akdengi
Сообщения: 1381
Зарегистрирован: 12 сен 2011, 13:44

Re: Problème avec pilotes graphiques propriétaires

Сообщение akdengi » 16 май 2013, 06:59

AMD not provide proprietary legacy drivers for X-server 13, using in Fresh and needing for you videcard. You did not use proprietary drivers, only free.

Аватара пользователя
sylvainsjc
Сообщения: 1275
Зарегистрирован: 28 июн 2012, 20:39
Operating system: ROSA Linux
Контактная информация:

Re: Problème avec pilotes graphiques propriétaires

Сообщение sylvainsjc » 16 май 2013, 07:19

Salut :)

Je n'ai pas d'expérience avec ATI mais de quelle manière as tu installé ces pilotes "propriétaires"?

Quand tu es bloqué en console au démarrage après avoir touché aux réglages graphiques, tu passes en root et tu configurés de nouveau à l'aide de XFdrake

Аватара пользователя
Celtique
Сообщения: 93
Зарегистрирован: 10 дек 2012, 12:29
Operating system: Windows 8

Re: Problème avec pilotes graphiques propriétaires

Сообщение Celtique » 16 май 2013, 15:26

Pour ce qui est de XFdrake je ne sais pas ce que c'est, je n'ai jamais eu de problème avec les drivers propriétaires par le passé.
Sinon je suis passé par configuration système/ configurer le serveur d'affichage et je choisis le drivers etc...

Je veux bien rester avec le drivers libre mais comment améliorer l'affichage avec ces barres et scintillements ? je voudrais filmer mon bureau pour montrer mais je ne sais pas quel outil utiliser!

@+

Аватара пользователя
sylvainsjc
Сообщения: 1275
Зарегистрирован: 28 июн 2012, 20:39
Operating system: ROSA Linux
Контактная информация:

Re: Problème avec pilotes graphiques propriétaires

Сообщение sylvainsjc » 16 май 2013, 22:35

Commence par reconfigurer ta carte avec le driver libre et on verra pour les scintillements

1) Se loguer "root" avec la console
2) taper "XFdrake" (attention XF en majuscules et drake en minuscules)
3) Selectionne le pilote libre
4) redémarre

Аватара пользователя
Celtique
Сообщения: 93
Зарегистрирован: 10 дек 2012, 12:29
Operating system: Windows 8

Re: Problème avec pilotes graphiques propriétaires

Сообщение Celtique » 16 май 2013, 23:01

Bon,
J'ai sélectionné le drivers ou était marqué free (dans la liste ati) par défaut il était sur celui que j'ai tenté d'installer, là j'ai eu le message qui me disait qu'il existait un drivers propriétaire etc... j'ai dis non.
Là sélection de mon écran qui est sur personnalisé par défaut, je sélectionne mon Asus.
Message qui me donne la définition de l'écran, ok, puis redémarré ok et paf je reviens en console...
Je précise que je venais de réinstaller rosa avec les mises à jour avec tout par défaut.

@+

Аватара пользователя
sylvainsjc
Сообщения: 1275
Зарегистрирован: 28 июн 2012, 20:39
Operating system: ROSA Linux
Контактная информация:

Re: Problème avec pilotes graphiques propriétaires

Сообщение sylvainsjc » 17 май 2013, 09:18

Personnellement, je vais avoir du mal à t'aider car je ne dispose pas de ce type de configuration.

Quand tu es planté avec un problème de carte graphique, il n'est pas utile de réinstaller. Tu fais comme indiqué plus haut sauf que tu choisis le pilote "Vesa" pour retrouver un écran graphique au démarrage. Ensuite tu peux recommencer avec d'autres choix.

@akdengi : I believed that only ATI 2xxx - 4xxx could no longer use the proprietary driver? What should he choose in XFdrake to have a functional Radeon HD 5450/6350 ?

Аватара пользователя
akdengi
Сообщения: 1381
Зарегистрирован: 12 сен 2011, 13:44

Re: Problème avec pilotes graphiques propriétaires

Сообщение akdengi » 17 май 2013, 10:26

My mistake. For 5xxx-6xxx will work fglrx (see Card+)

NAME ATI Radeon HD 6400 and later (radeon/fglrx)
DRIVER radeon
FIRMWARE radeon-firmware
DRIVER_NO_FIRMWARE vesa
DRIVER2 fglrx

# Radeon cards supported by proprietary driver but not by free driver
NAME ATI Radeon HD 5000 and later without free driver (vesa/fglrx)
DRIVER vesa
DRIVER2 fglrx

But if proprietary driver did not work need say in Xorg.log for determine error.

Аватара пользователя
sylvainsjc
Сообщения: 1275
Зарегистрирован: 28 июн 2012, 20:39
Operating system: ROSA Linux
Контактная информация:

Re: Problème avec pilotes graphiques propriétaires

Сообщение sylvainsjc » 17 май 2013, 10:30

Thanks ;)

@Celtique dis moi si tu souhaites une traduction

Аватара пользователя
Celtique
Сообщения: 93
Зарегистрирован: 10 дек 2012, 12:29
Operating system: Windows 8

Re: Problème avec pilotes graphiques propriétaires

Сообщение Celtique » 17 май 2013, 10:58

NAME ATI Radeon HD 6400 and later (radeon/fglrx) c'est ce que j'ai essayé avec ou drivers propriétaire ça ne fonctionne pas, par contre lire le fichier xorg.log en ligne de commande il me faudra de l'aide :)

merci

@+

Аватара пользователя
sylvainsjc
Сообщения: 1275
Зарегистрирован: 28 июн 2012, 20:39
Operating system: ROSA Linux
Контактная информация:

Re: Problème avec pilotes graphiques propriétaires

Сообщение sylvainsjc » 17 май 2013, 11:26

Après avoir configuré "NAME ATI Radeon HD 6400 and later (radeon/fglrx)", tu redémarres (et tu tombes d'après ce que tu indiques en console)
En root tu copies le fichier Xorg.0.log dans un endroit ou tu pourras ensuite le récupérer intact facilement - exemple :

Код: Выделить всё

cp /var/log/Xorg.0.log /home/[ton-user]/Documents
Tu reconfigure ensuite ta carte graphique avec XFdrake pour pouvoir redémarrer graphiquement et tu copies/colles le contenu du fichier log ici

J'espère que c'est assez clair ?

Аватара пользователя
Celtique
Сообщения: 93
Зарегистрирован: 10 дек 2012, 12:29
Operating system: Windows 8

Re: Problème avec pilotes graphiques propriétaires

Сообщение Celtique » 17 май 2013, 11:52

Je ne redémarre toujours pas, mais j'ai pu retrouver le log après la manipulation avec le live cd de rosa..
Par contre je ne vais pas faire copié/collé car c'est énorme, je vais tenter l'upload de fichier du forum

@+
Вложения
Xorg.0.log
(63.38 КБ) 458 скачиваний

Аватара пользователя
sylvainsjc
Сообщения: 1275
Зарегистрирован: 28 июн 2012, 20:39
Operating system: ROSA Linux
Контактная информация:

Re: Problème avec pilotes graphiques propriétaires

Сообщение sylvainsjc » 17 май 2013, 12:29

Bien... Je vois des erreurs mais je pense que l'analyse akdengi permettra d'y voir plus clair

Аватара пользователя
sylvainsjc
Сообщения: 1275
Зарегистрирован: 28 июн 2012, 20:39
Operating system: ROSA Linux
Контактная информация:

Re: Problème avec pilotes graphiques propriétaires

Сообщение sylvainsjc » 18 май 2013, 15:09

Salut, akdengi n'a pas encore vu le fichier je pense.

L'erreur est ici à mon avis mais je ne sais dire pourquoi.

Код: Выделить всё

[    21.892] (WW) Warning, couldn't open module fglrx
[    21.892] (II) UnloadModule: "fglrx"
[    21.892] (II) Unloading fglrx
[    21.892] (EE) Failed to load module "fglrx" (module does not exist, 0)
Tu peux essayer dans l'ordre
==> Reconfigurer le pilote propriétaire avec XFdrake
==> ne pas redémarrer
==> lancer cette commande

Код: Выделить всё

amdconfig --initial -f
Si c'est toujours pas bon, ajouter "nomodeset" aux options de démarrage du kernel dans grub
==> Au démarrage, sur la ligne de grub, faire "E" pour éditer le script de lancement
==> Reperer et aller à la fin de la ligne qui contient "splash=silent logo.nologo quiet" et ajouter "nomodeset" (sans les guillemets) puis faire "F10" pour lancer le boot

Dis nous si c'est ok ;)

Аватара пользователя
Celtique
Сообщения: 93
Зарегистрирован: 10 дек 2012, 12:29
Operating system: Windows 8

Re: Problème avec pilotes graphiques propriétaires

Сообщение Celtique » 18 май 2013, 16:11

Toujours pareil et pour nomodeset j'ai un message qui me dit impossible de trouver commande nomodeset.
Je l'ai mis comme tu as dis à la fin de la ligne qui d'ailleurs se termine par systemd

@+

Аватара пользователя
Celtique
Сообщения: 93
Зарегистрирован: 10 дек 2012, 12:29
Operating system: Windows 8

Re: Problème avec pilotes graphiques propriétaires

Сообщение Celtique » 20 май 2013, 15:44

J'ai laissé tomber, je vais réinstaller, mais jai tenté avec Kubuntu 13.04 qui fonctionne très bien mais là j'ai ajouté les drivers propriétaires.
Résultat, il a fallu que je fasse de réglages dans le panneau de contrôle radeon pour ajuster la taille de la fenêtre par rapport à l'écran (affichage plus petit que l'écran), en réglant un curseur vers sur-balayage au maximum, et j'ai un logo AMD en bas à droite qui reste affcihé ou est écrit Hardware not supported.

Je vais rester avec le libre mais je vais poster pour le problème de barres etc...

merci encore

@+

Аватара пользователя
sylvainsjc
Сообщения: 1275
Зарегистрирован: 28 июн 2012, 20:39
Operating system: ROSA Linux
Контактная информация:

Re: Problème avec pilotes graphiques propriétaires

Сообщение sylvainsjc » 20 май 2013, 16:38

Salut,

Souvent les développeurs peuvent filer un coup de main ici mais je pense qu'ouvrir un bug sur bugzilla serait plus approprié quand ça "coince" de cette manière.

As tu essayé avec la dernière Mageia pour voir ?

Аватара пользователя
Celtique
Сообщения: 93
Зарегистрирован: 10 дек 2012, 12:29
Operating system: Windows 8

Re: Problème avec pilotes graphiques propriétaires

Сообщение Celtique » 20 май 2013, 19:08

Je me retrouve avec l'affichage plus petit que l'écran comme pour Kubuntu mais là juste en bootant sur le live cd donc drivers libre..
Je vais rester avec le drivers libre pour Rosa, mais je vais essayer de filmer le problème de barres que je parlais précédemment car à expliquer ce n'est pas évident :D

@+

Аватара пользователя
sylvainsjc
Сообщения: 1275
Зарегистрирован: 28 июн 2012, 20:39
Operating system: ROSA Linux
Контактная информация:

Re: Problème avec pilotes graphiques propriétaires

Сообщение sylvainsjc » 20 май 2013, 21:04

Bon je viens de faire le test d'ajouter "nomodeset" sur la ligne de Grub et je n'ai pas d'erreur et je le retrouve bien après démarrage dans le fichier /var/log/messages.

Код: Выделить всё

May 20 18:52:39 Rosa2012Fresh kernel: [    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.6.10-nrj-desktop-1rosa root=UUID=54a4fa82-49c7-4c10-844b-5120bbd2adda ro splash=silent logo.nologo quiet nomodeset resume=/dev/sda5 init=/lib/systemd/systemd
J'ai rajouté "nomodeset" après "quiet"
Изображение

Ответить