Alsamixer не верно управляет каналами

Ответить
Borisov_Artem
Сообщения: 2
Зарегистрирован: 22 мар 2019, 08:02
Operating system: ROSA Desktop Fresh R11 release 2016.1

Alsamixer не верно управляет каналами

Сообщение Borisov_Artem » 22 мар 2019, 08:27

Всем доброго времени суток. Установил знакомому ROSA R11 release 2016.1 for i586 KDE на нетбук ASUS Eee PC X101CH.
Звуковая карта HDA Intel, чип Realtek ALC269VB.

При подключении наушников звук в них есть, при отключении звук в динамик не идёт, при этом в alsamixer происходит переключение каналов на вид правильно. Чтоб добиться звука из динамика нужно поднять ползунок Headphon при этом неважно стоит ли там mute, а вот ползунок Speaker ни как на громкость не влияет но mute этого ползунка работает.

Подскажите как то возможно это исправить, или подскажите как правильно сделать скрипт в автозагрузке для asound.state, я так понял что он должен запускаться после pulseaudio.

Заранее благодарен.

Borisov_Artem
Сообщения: 2
Зарегистрирован: 22 мар 2019, 08:02
Operating system: ROSA Desktop Fresh R11 release 2016.1

Alsamixer не верно управляет каналами

Сообщение Borisov_Artem » 23 мар 2019, 12:27

Отключил pulseaudio. Хоть alsamixer ведёт себя так же не адекватно, но перестали сбрасываться его настройки, в результате происходит физически правильное переключение наушников и динамика, то есть звук есть там где надо и когда надо. Но возникла новая проблема браузер без pulseaudio не может направить звук куда надо.

Вопрос: как сделать так чтоб команда alsactl restore от пользователя root запускалась при старте операционной системы, но после запуска pulseaudio.

Survolog
Сообщения: 231
Зарегистрирован: 30 авг 2016, 22:30
Operating system: ROSA Fresh

Alsamixer не верно управляет каналами

Сообщение Survolog » 25 мар 2019, 10:14

Borisov_Artem писал(а):
23 мар 2019, 12:27
Вопрос: как сделать так чтоб команда alsactl restore от пользователя root запускалась при старте операционной системы, но после запуска pulseaudio.
В сторону составления сервисов systemd копать.

Ответить