"Сломалось" изображение на экране

Ответить
AlAnat
Сообщения: 15
Зарегистрирован: 20 июл 2016, 11:33
Operating system: ROSA.FRESH.KDE.R8.X86_64

"Сломалось" изображение на экране

Сообщение AlAnat » 13 дек 2019, 18:02

На одном из компьютеров с установленной Rosa R11 KDE, сегодня случилось следующее. Изображение как бы наложилось само на себя со сдвигов вправо (или влево). Причем, при открытии любого нового окна, оно сначала прорисовывается правильно, а затем портится. Свернув и затем развернув окно, оно опять может отрисоваться нормально, но как только поверх него перемещается курсор мыши или в нём обновляется информация, оно опять "ломается". На приложенном скриншоте видно, что рокетбар перерисовался нормально, а рабочий стол испортился. Но если навести курсор на рокетбар, он тоже испортится. Предыдущий сеанс работы закончился вполне нормально, во время его ничего необычного не было. Обновление системы, которое пришло сегодня ни чего не изменило.
Вложения
screen.png

Аватара пользователя
Zeffanyx
Сообщения: 1368
Зарегистрирован: 12 сен 2011, 14:25
Operating system: Rosa Fresh R11, OpenMandriva Lx 4 (Cooker)
Откуда: Санкт-Петербург

"Сломалось" изображение на экране

Сообщение Zeffanyx » 13 дек 2019, 21:45

какой видеодрайвер?

AlAnat
Сообщения: 15
Зарегистрирован: 20 июл 2016, 11:33
Operating system: ROSA.FRESH.KDE.R8.X86_64

"Сломалось" изображение на экране

Сообщение AlAnat » 13 дек 2019, 22:24

Zeffanyx писал(а):
13 дек 2019, 21:45
какой видеодрайвер?
Свободный.

Olej
Сообщения: 129
Зарегистрирован: 14 сен 2016, 14:06
Operating system: Fedora 30, Debian 10, Mint 19.2

"Сломалось" изображение на экране

Сообщение Olej » 13 дек 2019, 23:44

AlAnat писал(а):
13 дек 2019, 22:24
Свободный.
Свободный от кого? :Yahoo!:

AlAnat
Сообщения: 15
Зарегистрирован: 20 июл 2016, 11:33
Operating system: ROSA.FRESH.KDE.R8.X86_64

"Сломалось" изображение на экране

Сообщение AlAnat » 14 дек 2019, 08:11

Olej писал(а):
13 дек 2019, 23:44
AlAnat писал(а):
13 дек 2019, 22:24
Свободный.
Свободный от кого? :Yahoo!:
От Intel'а. :) Интегрированная графика. На, если не ошибаюсь, 915 чипсете.

Аватара пользователя
Алзим
Сообщения: 4443
Зарегистрирован: 18 июн 2015, 11:57
Operating system: ROSA Desktop Fresh R10
Откуда: Интернет

"Сломалось" изображение на экране

Сообщение Алзим » 14 дек 2019, 11:03

AlAnat писал(а):
14 дек 2019, 08:11
На, если не ошибаюсь,
https://linux-hardware.org/index.php?view=howto
Думаю, так будет надёжнее.

AlAnat
Сообщения: 15
Зарегистрирован: 20 июл 2016, 11:33
Operating system: ROSA.FRESH.KDE.R8.X86_64

"Сломалось" изображение на экране

Сообщение AlAnat » 14 дек 2019, 11:40

Алзим писал(а):
14 дек 2019, 11:03
AlAnat писал(а):
14 дек 2019, 08:11
На, если не ошибаюсь,
https://linux-hardware.org/index.php?view=howto
Думаю, так будет надёжнее.
Согласен, но это будет возможно только в понедельник. А пока, с вероятностью 90% могу сказать, что процессор Intel Core 2 Duo E7700 или 7500.

На самом деле, меня больше всего в этой ситуации интересует, что такое произошло в процессе последнего выключения или загрузки, что поломало изображение. Я сомневаюсь, что это случилось в то время, пока компьютер был выключен или работал под виндой (у него двойная загрузка).

AlAnat
Сообщения: 15
Зарегистрирован: 20 июл 2016, 11:33
Operating system: ROSA.FRESH.KDE.R8.X86_64

"Сломалось" изображение на экране

Сообщение AlAnat » 16 дек 2019, 13:02

Алзим писал(а):
14 дек 2019, 11:03
AlAnat писал(а):
14 дек 2019, 08:11
На, если не ошибаюсь,
https://linux-hardware.org/index.php?view=howto
Думаю, так будет надёжнее.
Вот добрался до компьютера и сделал пробу.
https://linux-hardware.org/?probe=b94afb67e0

Сам мало что по ней понял. В логах смутило следущее:
[ 28.028] (II) LoadModule: "fbdev"
[ 28.028] (WW) Warning, couldn't open module fbdev
[ 28.028] (II) UnloadModule: "fbdev"
[ 28.028] (II) Unloading fbdev
[ 28.028] (EE) Failed to load module "fbdev" (module does not exist, 0)
[ 28.028] (II) LoadModule: "vesa"
Будучи уверен, что у меня не VESA, а Free (i915) попробовал менять видеодрайверы. Это сообщение было оставалось на любом видеодрайвере. Но после выбора Free (UXA) загрузка не удалась. При следующей загрузке я выбрал предыдущее ядро и система загрузилась почти нормально. Т.е. изображение портится, но немного. Я попробовал перезагрузиться с последним ядром и опять почти удача. На изображении есть артефакты в верхней части окна и непосредственно под окном (скриншот прилагаю). Это уже гораздо лучше, чем было, но всё-таки не очень приятно ))

А это проба c Free (UXA):
https://linux-hardware.org/?probe=e5a422358f
в ней уже нет упоминания о VESA.
Вложения
screen1.png

AlAnat
Сообщения: 15
Зарегистрирован: 20 июл 2016, 11:33
Operating system: ROSA.FRESH.KDE.R8.X86_64

"Сломалось" изображение на экране

Сообщение AlAnat » 16 дек 2019, 14:31

Не стал редактировать предыдущее сообщение. Но чем дальше, тем интереснее. Почитал на форуме некоторые темы, наткнулся на тему о эффектах рабочего стола и посмотрел, а что у меня. Все оказалось стандартным, но стоило мне попробовать сменить движок XRender на OpenGL 2.0 - артефакты пропали и не вернулись при возврашении движка в исходное состояние. Попробовал OpenGL 3.1 - не пошло, оставил OpenGL 2.0. В результате картинка на экране идеальная, но в чем было дело и какие именно действия привели к решению проблемы я так и не понял.

Аватара пользователя
Andreas17
Сообщения: 392
Зарегистрирован: 21 май 2017, 20:07
Operating system: ROSA Fresh R11
Откуда: Москва

"Сломалось" изображение на экране

Сообщение Andreas17 » 16 дек 2019, 23:57

AlAnat, значит у Вас проблемы не с драйверами, а с иксами. XRender - расширение X11.

Ответить