device not accepting adress 5, error -62

Ответить
Аватара пользователя
tverskoy
Сообщения: 1139
Зарегистрирован: 12 сен 2011, 13:30
Operating system: Rosa 2016.1 Fresh
Откуда: Тверь

device not accepting adress 5, error -62

Сообщение tverskoy » 26 июл 2017, 16:56

При загрузке и выключении вылезает надпись usb 2-4 device not accepting adress 5, error -62. Что значит сие, и как с этим бороться?

Код: Выделить всё

lsusb
Bus 001 Device 005: ID 2232:1028 Silicon Motion WebCam SC-03FFL11939N
Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 005: ID 0cf3:3004 Qualcomm Atheros Communications AR3012 Bluetooth 4.0
Bus 002 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Код: Выделить всё

$ dmesg | grep 'usb 2-4'
[ 3.803429] usb 2-4: new full-speed USB device number 3 using ohci-pci
[ 4.345433] usb 2-4: device not accepting address 3, error -62
[ 25.464784] usb 2-4: new full-speed USB device number 5 using ohci-pci
[ 25.619824] usb 2-4: New USB device found, idVendor=0cf3, idProduct=3004
[ 25.619829] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 25.619831] usb 2-4: Product: Bluetooth USB Host Controller
[ 25.619834] usb 2-4: Manufacturer: Atheros Communications
[ 25.619835] usb 2-4: SerialNumber: Alaska Day 2006

Аватара пользователя
tverskoy
Сообщения: 1139
Зарегистрирован: 12 сен 2011, 13:30
Operating system: Rosa 2016.1 Fresh
Откуда: Тверь

Re: device not accepting adress 5, error -62

Сообщение tverskoy » 26 июл 2017, 17:03

В вконтакте начали обсуждать, чтобы не потерялось https://vk.com/rosa_linux?w=wall-33847957_197082%2Fall
https://linux-hardware.org/index.php?probe=4b723bf920
Я так понял что в Росе не определена последовательность загрузки ehci-hcd ehci-pci ohci-pci, и ядро пытается использовать не тот модуль. Я сделал rmmod ohci-pci у меня отвалилась мышь и встроенный блютус, потом modprobe ohci-pci, все снова заработало, перезагрузил и эта ошибка пропала, но теперь другой девайс жалуется

Код: Выделить всё

$ dmesg | grep 'error -62'
[    4.340290] usb 4-4: device not accepting address 3, error -62
правда эту ошибку уже не видно при загрузке

https://unix.stackexchange.com/question ... ux-kernels
З.Ы.
Незадолго до выхода R9 я поставил второй HDD вместо DVD, на R8.1 нормально работало, Роса уже пять лет на этом ноуте стоит. На R9 стало зависать, вытащил второй HDD перестало, но на 4.9.11 и 12 опять стало зависать.

trs
Сообщения: 1939
Зарегистрирован: 07 сен 2015, 16:08
Operating system: -

Re: device not accepting adress 5, error -62

Сообщение trs » 28 июл 2017, 09:30

tverskoy писал(а):Я так понял что в Росе не определена последовательность загрузки ehci-hcd ehci-pci ohci-pci, и ядро пытается использовать не тот модуль.
Определено следующее:

Код: Выделить всё

usb.conf
--------
# kernel warns: ehci_hcd should always be loaded before uhci_hcd and ohci_hcd, not after
softdep uhci_hcd pre: ehci_hcd
softdep ohci_hcd pre: ehci_hcd
https://linux-hardware.org/index.php?pr ... modprobe.d

-62 это Timer expired. Т.е. ответ не получен вовремя.
tverskoy писал(а):Роса уже пять лет на этом ноуте стоит.
Возможно, пришла пора переподключить коннектор, а то бывает ещё и так:

Код: Выделить всё

[   84.404056] usb 1-1.2: new low-speed USB device number 5 using ehci-pci
[   84.477383] usb 1-1.2: device descriptor read/64, error -32
[   84.657401] usb 1-1.2: device descriptor read/64, error -32
[   84.837400] usb 1-1.2: new low-speed USB device number 6 using ehci-pci
[   84.910727] usb 1-1.2: device descriptor read/64, error -32
[   85.090776] usb 1-1.2: device descriptor read/64, error -32
[   85.270765] usb 1-1.2: new low-speed USB device number 7 using ehci-pci
[   85.684148] usb 1-1.2: device not accepting address 7, error -32

Код: Выделить всё

[ 6398.917733] usb 1-1-port2: disabled by hub (EMI?), re-enabling...
[ 6398.917856] usb 1-1.2: USB disconnect, device number 30
[ 6399.125953] usb 1-1.2: new high-speed USB device number 31 using ehci-pci
[ 6399.209343] usb 1-1.2: device descriptor read/64, error -71
[ 6399.472662] usb 1-1.2: new high-speed USB device number 32 using ehci-pci
[ 6399.629353] usb 1-1.2: new high-speed USB device number 33 using ehci-pci
[ 6400.049357] usb 1-1.2: device not accepting address 33, error -71
[ 6400.329377] usb 1-1.2: new high-speed USB device number 34 using ehci-pci
[ 6400.749403] usb 1-1.2: device not accepting address 34, error -71

Аватара пользователя
tverskoy
Сообщения: 1139
Зарегистрирован: 12 сен 2011, 13:30
Operating system: Rosa 2016.1 Fresh
Откуда: Тверь

Re: device not accepting adress 5, error -62

Сообщение tverskoy » 30 июл 2017, 01:05

Проблема пропала после rmmod ohci-pci и ohci-pci, система не тот драйвер пыталась использовать

trs
Сообщения: 1939
Зарегистрирован: 07 сен 2015, 16:08
Operating system: -

Re: device not accepting adress 5, error -62

Сообщение trs » 30 июл 2017, 06:47

Сделали rmmod и после перезапуска системы проблема не повторилась? Или добавили ещё softdep для ohci-pci?

Аватара пользователя
tverskoy
Сообщения: 1139
Зарегистрирован: 12 сен 2011, 13:30
Operating system: Rosa 2016.1 Fresh
Откуда: Тверь

Re: device not accepting adress 5, error -62

Сообщение tverskoy » 30 июл 2017, 09:37

Удалил модуль ядра, вставил модуль , перезагрузил.

trs
Сообщения: 1939
Зарегистрирован: 07 сен 2015, 16:08
Operating system: -

Re: device not accepting adress 5, error -62

Сообщение trs » 31 июл 2017, 06:27

И после перезапуска системы проблема исчезла, или приходится каждый раз перезагружать драйвер? В первом случае дело скорее всего не в порядке запуска, поскольку он не изменился. Во втором - надо составлять зависимость по аналогии с вышеприведённой из usb.conf.

Аватара пользователя
tverskoy
Сообщения: 1139
Зарегистрирован: 12 сен 2011, 13:30
Operating system: Rosa 2016.1 Fresh
Откуда: Тверь

Re: device not accepting adress 5, error -62

Сообщение tverskoy » 31 июл 2017, 08:49

trs писал(а):И после перезапуска системы проблема исчезла, или приходится каждый раз перезагружать драйвер?
Исчезла. Но я вчера, ядро 4.9.12 запускал неудачно, снова вылезла эта ошибка. Повторил действия, ошибка пропала

Ответить