[РЕШЕНО, но криво] autofs и NFS-шары

Ответить
tavrist
Сообщения: 12
Зарегистрирован: 29 апр 2018, 20:44
Operating system: openSUSE 42.3
ROSA XFCE R10

[РЕШЕНО, но криво] autofs и NFS-шары

Сообщение tavrist » 30 апр 2018, 20:04

ROSA R10 LXQT-LXDE.
Есть расшаренный на NAS каталог по NFS.
Я включил autofs, в конфиге /etc/autofs/auto.master раскоментировал строку:

Код: Выделить всё

/net     -hosts
создал каталог /net
но когда я выполняю

Код: Выделить всё

ls /net/nas
получаю

Код: Выделить всё

ls: невозможно получить доступ к /net/nas: Нет такого файла или каталога
Вывод systemctl status autofs

Код: Выделить всё

# systemctl status autofs
● autofs.service - Automounts filesystems on demand
   Loaded: loaded (/lib/systemd/system/autofs.service; enabled; vendor preset: disabled)
   Active: active (running) since Пн 2018-04-30 19:49:51 MSK; 4min 4s ago
  Process: 6343 ExecStart=/usr/sbin/automount $OPTIONS --pid-file /run/autofs.pid (code=exited, status=0/SUCCESS)
 Main PID: 6345 (automount)
    Tasks: 3 (limit: 512)
   CGroup: /system.slice/autofs.service
           └─6345 /usr/sbin/automount --pid-file /run/autofs.pid

апр 30 19:49:51 testuser systemd[1]: Starting Automounts filesystems on demand...
апр 30 19:49:51 testuser automount[6345]: open_lookup:104: cannot open lookup module hosts (/usr/lib64/autofs/lookup_hosts.so: undefined symbol: rpc_exports_free)
апр 30 19:49:51 testuser automount[6345]: mount_autofs_indirect: failed to read map for /net
апр 30 19:49:51 testuser automount[6345]: handle_mounts: mount of /net failed!
апр 30 19:49:51 testuser automount[6345]: master_do_mount: failed to startup mount
апр 30 19:49:51 testuser systemd[1]: Started Automounts filesystems on demand.
Что за глюки с библиотекой? Кто знает как пофиксить?
Последний раз редактировалось tavrist 30 апр 2018, 23:01, всего редактировалось 1 раз.

tavrist
Сообщения: 12
Зарегистрирован: 29 апр 2018, 20:44
Operating system: openSUSE 42.3
ROSA XFCE R10

Re: autofs и NFS-шары

Сообщение tavrist » 30 апр 2018, 23:00

Пошел на авантюру. Взял пакет из PCLinuxOS (autofs-5.0.7-1pclos2013.x86_64.rpm). Установил его. Автомонтирование в /net работает!

Будем с костылями, пока разрабы родной пакет не починят.

Ответить